aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ffmpeg-devel/Makefile5
-rw-r--r--multimedia/ffmpeg/Makefile5
-rw-r--r--multimedia/gstreamer-plugins/Makefile8
-rw-r--r--multimedia/gstreamer-plugins80/Makefile8
-rw-r--r--multimedia/mjpegtools/Makefile5
-rw-r--r--multimedia/mplayer/Makefile5
-rw-r--r--multimedia/mplayerxp/Makefile13
-rw-r--r--multimedia/oqtplayer/Makefile2
-rw-r--r--multimedia/transcode/Makefile5
9 files changed, 27 insertions, 29 deletions
diff --git a/multimedia/ffmpeg-devel/Makefile b/multimedia/ffmpeg-devel/Makefile
index 67b0f555b100..390da734ce52 100644
--- a/multimedia/ffmpeg-devel/Makefile
+++ b/multimedia/ffmpeg-devel/Makefile
@@ -20,6 +20,7 @@ HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_SIZE= yes
+WANT_SDL= yes
CONFIGURE_ARGS= --cc="${CC}" --prefix="${PREFIX}" \
--make="${GMAKE}" --enable-shared \
--extra-ldflags="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
@@ -59,7 +60,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-bktr-patch-libavformat::Makefile
##
##
## SDL
-.if exists(${LOCALBASE}/lib/libSDL-1.1.so)
+.if ${HAVE_SDL:Msdl}
WITH_SDL=yes
.endif
## freetype2
@@ -116,7 +117,7 @@ CONFIGURE_ARGS+= --disable-mmx
.endif
## SDL
.ifdef(WITH_SDL)
-USE_SDL= yes
+USE_SDL= sdl
PLIST_SUB+= SDL=""
.else
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 67b0f555b100..390da734ce52 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -20,6 +20,7 @@ HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_SIZE= yes
+WANT_SDL= yes
CONFIGURE_ARGS= --cc="${CC}" --prefix="${PREFIX}" \
--make="${GMAKE}" --enable-shared \
--extra-ldflags="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
@@ -59,7 +60,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-bktr-patch-libavformat::Makefile
##
##
## SDL
-.if exists(${LOCALBASE}/lib/libSDL-1.1.so)
+.if ${HAVE_SDL:Msdl}
WITH_SDL=yes
.endif
## freetype2
@@ -116,7 +117,7 @@ CONFIGURE_ARGS+= --disable-mmx
.endif
## SDL
.ifdef(WITH_SDL)
-USE_SDL= yes
+USE_SDL= sdl
PLIST_SUB+= SDL=""
.else
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 3a41d7ca36db..7153c000d7b4 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -32,6 +32,7 @@ USE_GNOME= gnomehack \
USE_LIBTOOL= yes
USE_REINPLACE= yes
USE_SIZE= yes
+WANT_SDL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-tests \
--disable-alsa \
@@ -56,7 +57,6 @@ WANT_GNOME= yes
MAN1= gst-launch-ext.1 gst-visualise.1
PKG_CONFIG?="${LOCALBASE}/bin/pkg-config"
-SDL_CONFIG?="${LOCALBASE}/bin/sdl11-config"
XMMS_CONFIG?="${LOCALBASE}/bin/xmms-config"
# library minor number
@@ -258,7 +258,7 @@ WITH_PNG=yes
.endif
# sdl
-.if exists(${LOCALBASE}/lib/libSDL-1.1.a)
+.if ${HAVE_SDL:Msdl}
WITH_SDL=yes
.endif
@@ -582,11 +582,9 @@ CONFIGURE_ARGS+= --disable-sdl \
--disable-sdltest
PLIST_SUB+= SDL="@comment "
.else
-LIB_DEPENDS+= SDL-1.1.5:${PORTSDIR}/devel/sdl12
-
+USE_SDL= sdl
CONFIGURE_ARGS+= --with-sdl-prefix=${LOCALBASE} \
--with-sdl-exec-prefix=${LOCALBASE}
-CONFIGURE_ENV+= SDL_CONFIG=${SDL_CONFIG}
PLIST_SUB+= SDL=""
.endif
diff --git a/multimedia/gstreamer-plugins80/Makefile b/multimedia/gstreamer-plugins80/Makefile
index 3a41d7ca36db..7153c000d7b4 100644
--- a/multimedia/gstreamer-plugins80/Makefile
+++ b/multimedia/gstreamer-plugins80/Makefile
@@ -32,6 +32,7 @@ USE_GNOME= gnomehack \
USE_LIBTOOL= yes
USE_REINPLACE= yes
USE_SIZE= yes
+WANT_SDL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-tests \
--disable-alsa \
@@ -56,7 +57,6 @@ WANT_GNOME= yes
MAN1= gst-launch-ext.1 gst-visualise.1
PKG_CONFIG?="${LOCALBASE}/bin/pkg-config"
-SDL_CONFIG?="${LOCALBASE}/bin/sdl11-config"
XMMS_CONFIG?="${LOCALBASE}/bin/xmms-config"
# library minor number
@@ -258,7 +258,7 @@ WITH_PNG=yes
.endif
# sdl
-.if exists(${LOCALBASE}/lib/libSDL-1.1.a)
+.if ${HAVE_SDL:Msdl}
WITH_SDL=yes
.endif
@@ -582,11 +582,9 @@ CONFIGURE_ARGS+= --disable-sdl \
--disable-sdltest
PLIST_SUB+= SDL="@comment "
.else
-LIB_DEPENDS+= SDL-1.1.5:${PORTSDIR}/devel/sdl12
-
+USE_SDL= sdl
CONFIGURE_ARGS+= --with-sdl-prefix=${LOCALBASE} \
--with-sdl-exec-prefix=${LOCALBASE}
-CONFIGURE_ENV+= SDL_CONFIG=${SDL_CONFIG}
PLIST_SUB+= SDL=""
.endif
diff --git a/multimedia/mjpegtools/Makefile b/multimedia/mjpegtools/Makefile
index 3789d436f5ea..89cd52533913 100644
--- a/multimedia/mjpegtools/Makefile
+++ b/multimedia/mjpegtools/Makefile
@@ -29,6 +29,7 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS:S/"//g}" \
PTHREAD_LIBS="${PTHREAD_LIBS:S/"//g}"
WANT_GNOME= yes
+WANT_SDL= yes
MAN1= divxdec.1 jpeg2yuv.1 lav2divx.1 lav2mpeg.1 lav2wav.1 lav2yuv.1 \
lavpipe.1 lavplay.1 lavrec.1 lavtrans.1 mjpegtools.1 mp2enc.1 \
@@ -76,7 +77,7 @@ WITH_LIBMOVTAR= yes
WITH_QUICKTIME= yes
.endif
# SDL
-.if exists(${LOCALBASE}/lib/libSDL-1.1.so.5)
+.if ${HAVE_SDL}:Msdl}!=""
WITH_SDL= yes
.endif
@@ -105,7 +106,7 @@ CONFIGURE_ARGS+= --with-movtar-prefix=${LOCALBASE}
.endif
#
.ifdef(WITH_SDL)
-USE_SDL= yes
+USE_SDL= sdl
CONFIGURE_ARGS+= --with-sdl
.endif
#
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 348612b873ac..d5d507816cc0 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -216,6 +216,7 @@ CONFIGURE_ARGS+=--language=${WITH_LANG}
.endif
WANT_GNOME= yes
+WANT_SDL= yes
USE_REINPLACE= yes
MAN1= mplayer.1
MANCOMPRESSED= no
@@ -271,7 +272,7 @@ WITH_SVGALIB= yes
WITH_AALIB= yes
.endif
-.if exists(${LOCALBASE}/lib/libSDL-1.1.so.5)
+.if ${HAVE_SDL:Msdl}!=""
WITH_SDL= yes
WITH_AALIB= yes
.endif
@@ -418,7 +419,7 @@ LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
.endif
.if defined(WITH_SDL)
-USE_SDL= yes
+USE_SDL= sdl
.endif
.if defined(WITH_ESOUND)
diff --git a/multimedia/mplayerxp/Makefile b/multimedia/mplayerxp/Makefile
index 84a83d707acb..82ecb31f51b4 100644
--- a/multimedia/mplayerxp/Makefile
+++ b/multimedia/mplayerxp/Makefile
@@ -29,10 +29,10 @@ USE_GMAKE= yes
USE_REINPLACE= yes
USE_SIZE= yes
HAS_CONFIGURE= yes
+WANT_SDL= yes
MAN1= mplayerxp.1
-SDL_CONFIG?= "${LOCALBASE}/bin/sdl11-config"
WIN32_CODEC_PREFIX= ${LOCALBASE}/lib/win32
# dirs to create before installation
@@ -80,11 +80,11 @@ WITH_CDPARANOIA=yes
WITH_DVD=yes
.endif
# sdl
-.if exists(${LOCALBASE}/lib/libSDL-1.1.a)
+.if ${HAVE_SDL:Msdl}!=""
WITH_SDL=yes
.endif
# sdl_image
-.if exists(${LOCALBASE}/lib/libSDL_image.a)
+.if ${HAVE_SDL:Mimage}!=""
WITH_SDL_IMAGE=yes
.endif
# xvid
@@ -139,17 +139,14 @@ CONFIGURE_ARGS+= --with-libdvdnav=${LOCALBASE}
.endif
# sdl
.ifdef(WITH_SDL)
-LIB_DEPENDS+= SDL-1.1.5:${PORTSDIR}/devel/sdl12
-
+USE_SDL= sdl
CONFIGURE_ARGS+= --enable-sdl
-CONFIGURE_ENV+= SDL_CONFIG=${SDL_CONFIG}
.else
CONFIGURE_ARGS+= --disable-sdl
.endif
# sdl_image
.ifdef(WITH_SDL_IMAGE)
-LIB_DEPENDS+= SDL_image.10:${PORTSDIR}/graphics/sdl_image
-
+USE_SDL+= image
CONFIGURE_ARGS+= --enable-sdl-image
.else
CONFIGURE_ARGS+= --disable-sdl-image
diff --git a/multimedia/oqtplayer/Makefile b/multimedia/oqtplayer/Makefile
index 7a70857bae67..9c79ca05c07a 100644
--- a/multimedia/oqtplayer/Makefile
+++ b/multimedia/oqtplayer/Makefile
@@ -20,7 +20,7 @@ COMMENT= A very very small, not functionnal, video OpenQuicktime (TM) player
LIB_DEPENDS= openquicktime.0:${PORTSDIR}/multimedia/openquicktime
USE_SIZE= yes
-USE_SDL= yes
+USE_SDL= sdl
MAKE_ENV= SDL_CONFIG=${SDL_CONFIG}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/multimedia/transcode/Makefile b/multimedia/transcode/Makefile
index 2f1734c27948..0e50f055eb23 100644
--- a/multimedia/transcode/Makefile
+++ b/multimedia/transcode/Makefile
@@ -29,6 +29,7 @@ CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
+WANT_SDL= yes
MAN1= avifix.1 aviindex.1 avimerge.1 avisplit.1 avisync.1 tccat.1 tcdemux.1 \
tcprobe.1 tcscan.1 transcode.1 tcextract.1 tcdecode.1 tcmodinfo.1 \
@@ -48,7 +49,7 @@ WITH_IMAGEMAGICK= yes
WITH_AVIFILE= yes
.endif
-.if exists(${LOCALBASE}/lib/libSDL-1.1.so)
+.if ${HAVE_SDL:Msdl}!=""
WITH_SDL= yes
.endif
@@ -138,7 +139,7 @@ WITHOUT_FFMPEG= YES
.endif
.if defined(WITH_SDL)
-LIB_DEPENDS+= SDL-1.1.5:${PORTSDIR}/devel/sdl12
+USE_SDL= sdl
WITH_LIBDV= yes
PLIST_SUB+= WITH_SDL=""
.else