aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/kdemultimedia4/Makefile3
-rw-r--r--multimedia/kdemultimedia4/distinfo6
-rw-r--r--multimedia/kdemultimedia4/files/patch-kioslave-audiocd-audiocd.cpp151
-rw-r--r--multimedia/kdemultimedia4/pkg-plist27
4 files changed, 121 insertions, 66 deletions
diff --git a/multimedia/kdemultimedia4/Makefile b/multimedia/kdemultimedia4/Makefile
index ced5e6871a88..e6cde23802f9 100644
--- a/multimedia/kdemultimedia4/Makefile
+++ b/multimedia/kdemultimedia4/Makefile
@@ -6,7 +6,6 @@
PORTNAME= kdemultimedia
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
CATEGORIES= multimedia kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
@@ -32,7 +31,7 @@ CONFLICTS= dolphin-plugins-mplayerthumbs-1.*
LATEST_LINK= ${PORTNAME}4
USE_BZIP2= yes
-USE_KDE4= kdelibs kdeprefix kdehier automoc4 kdeexp
+USE_KDE4= kdelibs kdeprefix kdehier automoc4
KDE4_BUILDENV= yes
USE_QT_VER= 4
QT_COMPONENTS= corelib opengl dbus qt3support designer network svg qtestlib \
diff --git a/multimedia/kdemultimedia4/distinfo b/multimedia/kdemultimedia4/distinfo
index 9fd998a6f7dc..9d4ccd3f5927 100644
--- a/multimedia/kdemultimedia4/distinfo
+++ b/multimedia/kdemultimedia4/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/kdemultimedia-4.3.5.tar.bz2) = 08611f34d1779f1bf773962b4efa9d81
-SHA256 (KDE/kdemultimedia-4.3.5.tar.bz2) = fdbdad9c973c20cba0b79757a20eb9f48c4419b240f9b31b618b480237485e79
-SIZE (KDE/kdemultimedia-4.3.5.tar.bz2) = 1591456
+MD5 (KDE/kdemultimedia-4.4.3.tar.bz2) = cb1648e560f523a1bac6caf5574854be
+SHA256 (KDE/kdemultimedia-4.4.3.tar.bz2) = b278e3dbc36d5f744a20f51bf81183a77a62584997c38d584ed2f8c8e9adfc52
+SIZE (KDE/kdemultimedia-4.4.3.tar.bz2) = 1454035
diff --git a/multimedia/kdemultimedia4/files/patch-kioslave-audiocd-audiocd.cpp b/multimedia/kdemultimedia4/files/patch-kioslave-audiocd-audiocd.cpp
index db7a814182d8..8abaaa1c208d 100644
--- a/multimedia/kdemultimedia4/files/patch-kioslave-audiocd-audiocd.cpp
+++ b/multimedia/kdemultimedia4/files/patch-kioslave-audiocd-audiocd.cpp
@@ -1,43 +1,110 @@
---- kioslave/audiocd/audiocd.cpp.orig 2009-09-03 16:55:47.000000000 +0200
-+++ kioslave/audiocd/audiocd.cpp 2009-09-03 19:36:22.000000000 +0200
-@@ -225,20 +225,21 @@
- // name associated with the device, which throws the rest of audiocd
- // for a loop.
- //
-+ QString devname;
- if ( !(drive->dev) || (COOKED_IOCTL == drive->interface) )
- {
- // For ATAPI devices, we have no real choice. Use the
- // user selected value, even if there is none.
- //
- kWarning(7117) << "Found an ATAPI device, assuming it is the one specified by the user.";
-- d->cd.setDevice( d->device );
-+ devname = d->device;
- }
- else
- {
- kDebug(7117) << "Found a SCSI or ATAPICAM device.";
- if ( strlen(drive->dev->device_path) > 0 )
- {
-- d->cd.setDevice( drive->dev->device_path );
-+ devname = drive->dev->device_path;
- }
- else
- {
-@@ -246,13 +247,14 @@
- // circumstances, so build a representation from
- // the unit number and SCSI device name.
- //
+--- kioslave/audiocd/audiocd.cpp.orig 2009-12-31 13:30:01.000000000 +0000
++++ kioslave/audiocd/audiocd.cpp 2010-01-11 00:05:10.235745679 +0000
+@@ -215,52 +215,6 @@
+ return encoderFromExtension(filename.right(len - pos));
+ }
+
+-static void setDeviceToCd(KCompactDisc *cd, struct cdrom_drive *drive)
+-{
+-#if defined(HAVE_CDDA_IOCTL_DEVICE)
+- cd->setDevice(drive->ioctl_device_name, 50, false);
+-#elif defined(__FreeBSD__) || defined(__DragonFly__)
+- // FreeBSD's cdparanoia as of january 5th 2006 has rather broken
+- // support for non-SCSI devices. Although it finds ATA cdroms just
+- // fine, there is no straightforward way to discover the device
+- // name associated with the device, which throws the rest of audiocd
+- // for a loop.
+- //
+- if ( !(drive->dev) || (COOKED_IOCTL == drive->interface) )
+- {
+- // For ATAPI devices, we have no real choice. Use the
+- // user selected value, even if there is none.
+- //
+- kWarning(7117) << "Found an ATAPI device, assuming it is the one specified by the user.";
+- cd->setDevice( d->device );
+- }
+- else
+- {
+- kDebug(7117) << "Found a SCSI or ATAPICAM device.";
+- if ( strlen(drive->dev->device_path) > 0 )
+- {
+- cd->setDevice( drive->dev->device_path );
+- }
+- else
+- {
+- // But the device_path can be empty under some
+- // circumstances, so build a representation from
+- // the unit number and SCSI device name.
+- //
- QString devname = QString::fromLatin1( "/dev/%1%2" )
-+ devname = QString::fromLatin1( "/dev/%1%2" )
- .arg( drive->dev->given_dev_name )
- .arg( drive->dev->given_unit_number ) ;
- kDebug(7117) << " Using derived name " << devname;
-- d->cd.setDevice( devname );
- }
- }
-+ if (d->cd.deviceName() != devname)
-+ d->cd.setDevice( devname );
- #else
- #ifdef __GNUC__
- #warning audiocd ioslave is not going to work for you
+- .arg( drive->dev->given_dev_name )
+- .arg( drive->dev->given_unit_number ) ;
+- kDebug(7117) << " Using derived name " << devname;
+- cd->setDevice( devname );
+- }
+- }
+-#else
+-#ifdef __GNUC__
+- #warning audiocd ioslave is not going to work for you
+-#endif
+-#endif
+-}
+-
+ struct cdrom_drive * AudioCDProtocol::initRequest(const KUrl & url)
+ {
+ if (url.hasHost())
+@@ -284,7 +238,53 @@
+ {
+ // Update our knowledge of the disc
+ KCompactDisc cd(KCompactDisc::Asynchronous);
+- setDeviceToCd(&cd, drive);
++#if defined(HAVE_CDDA_IOCTL_DEVICE)
++ cd.setDevice(drive->ioctl_device_name, 50, false);
++#elif defined(__FreeBSD__) || defined(__DragonFly__)
++ // FreeBSD's cdparanoia as of january 5th 2006 has
++ // rather broken support for non-SCSI devices.
++ // Although it finds ATA cdroms just fine, there is
++ // no straightforward way to discover the device name
++ // associated with the device, which throws the rest
++ // of audiocd for a loop.
++ //
++ QString devname;
++ if ( !(drive->dev) || (COOKED_IOCTL == drive->interface) )
++ {
++ // For ATAPI devices, we have no real choice.
++ // Use the user selected value, even if there
++ // is none.
++ //
++ kWarning(7117) << "Found an ATAPI device, assuming it is the one specified by the user.";
++ devname = d->device;
++ }
++ else
++ {
++ kDebug(7117) << "Found a SCSI or ATAPICAM device.";
++ if ( strlen(drive->dev->device_path) > 0 )
++ {
++ devname = drive->dev->device_path;
++ }
++ else
++ {
++ // But the device_path can be empty
++ // under some circumstances, so build
++ // a representation from the unit
++ // number and SCSI device name.
++ //
++ devname = QString::fromLatin1( "/dev/%1%2" )
++ .arg( drive->dev->given_dev_name )
++ .arg( drive->dev->given_unit_number ) ;
++ kDebug(7117) << " Using derived name " << devname;
++ }
++ }
++ if ( cd.deviceName() != devname )
++ cd.setDevice( devname );
++#else
++#ifdef __GNUC__
++ #warning audiocd ioslave is not going to work for you
++#endif
++#endif
+ d->setToc(drive);
+
+ d->tracks = cd.tracks();
diff --git a/multimedia/kdemultimedia4/pkg-plist b/multimedia/kdemultimedia4/pkg-plist
index 48c104d057de..a88f9ea9f295 100644
--- a/multimedia/kdemultimedia4/pkg-plist
+++ b/multimedia/kdemultimedia4/pkg-plist
@@ -53,7 +53,6 @@ share/apps/kmix/kmixui.rc
share/apps/kmix/pics/kmixdocked.png
share/apps/kmix/pics/kmixdocked_error.png
share/apps/kmix/pics/kmixdocked_mute.png
-share/apps/kmix/pics/mix_record.png
share/apps/kmix/pics/mixer-ac97.png
share/apps/kmix/pics/mixer-capture.png
share/apps/kmix/pics/mixer-cd.png
@@ -79,6 +78,7 @@ share/apps/kscd/skin/default.svg
share/apps/profiles/kscd.profile.xml
share/apps/solid/actions/dragonplayer-opendvd.desktop
share/apps/solid/actions/kscd-play-audiocd.desktop
+share/apps/solid/actions/solid_audiocd.desktop
share/apps/videothumbnail/sprocket-large.png
share/apps/videothumbnail/sprocket-medium.png
share/apps/videothumbnail/sprocket-small.png
@@ -110,6 +110,12 @@ share/doc/HTML/en/juk/juk-tag-guesser.png
share/doc/HTML/en/juk/normal-playlist.png
share/doc/HTML/en/juk/search-playlist.png
share/doc/HTML/en/juk/toolbar.png
+share/doc/HTML/en/kcontrol/cddbretrieval/common
+share/doc/HTML/en/kcontrol/cddbretrieval/index.cache.bz2
+share/doc/HTML/en/kcontrol/cddbretrieval/index.docbook
+share/doc/HTML/en/kcontrol/cddbretrieval/kscd13.png
+share/doc/HTML/en/kcontrol/cddbretrieval/kscd14.png
+share/doc/HTML/en/kcontrol/cddbretrieval/kscd16.png
share/doc/HTML/en/kioslave/audiocd/common
share/doc/HTML/en/kioslave/audiocd/index.cache.bz2
share/doc/HTML/en/kioslave/audiocd/index.docbook
@@ -120,23 +126,6 @@ share/doc/HTML/en/kmix/kmix-channel-playback.png
share/doc/HTML/en/kmix/kmix-channel-record.png
share/doc/HTML/en/kmix/kmix-channel-switches.png
share/doc/HTML/en/kmix/kmix-window.png
-share/doc/HTML/en/kscd/common
-share/doc/HTML/en/kscd/index.cache.bz2
-share/doc/HTML/en/kscd/index.docbook
-share/doc/HTML/en/kscd/kscd.png
-share/doc/HTML/en/kscd/kscd11.png
-share/doc/HTML/en/kscd/kscd12.png
-share/doc/HTML/en/kscd/kscd13.png
-share/doc/HTML/en/kscd/kscd14.png
-share/doc/HTML/en/kscd/kscd16.png
-share/doc/HTML/en/kscd/kscd18.png
-share/doc/HTML/en/kscd/kscd19.png
-share/doc/HTML/en/kscd/kscd2.png
-share/doc/HTML/en/kscd/kscd3.png
-share/doc/HTML/en/kscd/kscd5.png
-share/doc/HTML/en/kscd/kscd6.png
-share/doc/HTML/en/kscd/kscd9.png
-share/doc/HTML/en/kscd/kscdannounc.png
share/icons/hicolor/128x128/apps/dragonplayer.png
share/icons/hicolor/128x128/apps/juk.png
share/icons/hicolor/128x128/apps/kmix.png
@@ -173,9 +162,9 @@ share/kde4/services/dragonplayer_part.desktop
share/kde4/services/kmixctrl_restore.desktop
share/kde4/services/libkcddb.desktop
share/kde4/services/videopreview.desktop
-@dirrm share/doc/HTML/en/kscd
@dirrm share/doc/HTML/en/kmix
@dirrm share/doc/HTML/en/kioslave/audiocd
+@dirrm share/doc/HTML/en/kcontrol/cddbretrieval
@dirrm share/doc/HTML/en/juk
@dirrm share/doc/HTML/en/dragonplayer
@dirrm share/apps/videothumbnail