aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gavl/Makefile23
-rw-r--r--multimedia/gavl/distinfo4
-rw-r--r--multimedia/gavl/files/patch-gavl-timer.c17
-rw-r--r--multimedia/gavl/pkg-plist2
-rw-r--r--multimedia/gmerlin-avdecoder/Makefile85
-rw-r--r--multimedia/gmerlin-avdecoder/distinfo4
-rw-r--r--multimedia/gmerlin-avdecoder/files/patch-lib-demux_ffmpeg.c25
-rw-r--r--multimedia/gmerlin/Makefile150
-rw-r--r--multimedia/gmerlin/distinfo4
-rw-r--r--multimedia/gmerlin/files/patch-plugins-png_ir_png.c10
-rw-r--r--multimedia/gmerlin/pkg-plist50
11 files changed, 172 insertions, 202 deletions
diff --git a/multimedia/gavl/Makefile b/multimedia/gavl/Makefile
index e8f7bd573134..6f4ffcf94e4c 100644
--- a/multimedia/gavl/Makefile
+++ b/multimedia/gavl/Makefile
@@ -6,17 +6,13 @@
#
PORTNAME= gavl
-PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTVERSION= 1.4.0
CATEGORIES= multimedia
MASTER_SITES= SF/gmerlin/${PORTNAME}/${PORTVERSION}
MAINTAINER= mm@FreeBSD.org
COMMENT= A library for handling uncompressed video and audio data
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- samplerate.1:${PORTSDIR}/audio/libsamplerate
-
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -26,21 +22,30 @@ MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --without-cpuflags --without-doxygen
+CONFIGURE_ARGS= --with-cpuflags=none --without-doxygen
PORTDOCS= README
-OPTIONS= OPTIMIZED_CFLAGS "Additional optimizations" off
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS PNG
+OPTIONS_DEFAULT= OPTIMIZED_CFLAGS PNG
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPNG}
+LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
+.else
+CONFIGURE_ARGS+= --disable-libpng
+.endif
.include <bsd.port.pre.mk>
-.if defined(WITH_OPTIMIZED_CFLAGS) && ${ARCH} == i386 && ${OSVERSION} < 700000
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS} && ${ARCH} == i386 && ${OSVERSION} < 700000
# Build fails on FreeBSD-6.3 i386 with optimized cflags with gcc 3.4
USE_GCC= 4.2+
.endif
post-patch:
-.if !defined(WITH_OPTIMIZED_CFLAGS)
+.if empty(PORT_OPTIONS:MOPTIMIZED_CFLAGS)
@${REINPLACE_CMD} -e \
's|-O3 -funroll-all-loops -fomit-frame-pointer -ffast-math||g' \
${WRKSRC}/configure
diff --git a/multimedia/gavl/distinfo b/multimedia/gavl/distinfo
index 8e36854734d8..fea464393e17 100644
--- a/multimedia/gavl/distinfo
+++ b/multimedia/gavl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gavl-1.2.0.tar.gz) = 814120339f7a99d35c36e0eb61ba6cf60bd939ee4a47d73a17f3ba1438c5f88e
-SIZE (gavl-1.2.0.tar.gz) = 4589139
+SHA256 (gavl-1.4.0.tar.gz) = 51aaac41391a915bd9bad07710957424b046410a276e7deaff24a870929d33ce
+SIZE (gavl-1.4.0.tar.gz) = 4592701
diff --git a/multimedia/gavl/files/patch-gavl-timer.c b/multimedia/gavl/files/patch-gavl-timer.c
deleted file mode 100644
index b68cb0b34090..000000000000
--- a/multimedia/gavl/files/patch-gavl-timer.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- gavl/timer.c.orig 2010-03-30 13:33:59.510537263 +0200
-+++ gavl/timer.c 2010-03-30 13:33:49.571212409 +0200
-@@ -109,7 +109,14 @@
- uint64_t gavl_benchmark_get_time(int config_flags)
- {
- struct timespec ts;
-+#if defined(CLOCK_PROCESS_CPUTIME_ID)
- clock_gettime(CLOCK_PROCESS_CPUTIME_ID, &ts);
-+#elif defined(CLOCK_PROF)
-+ clock_gettime(CLOCK_PROF, &ts);
-+#else
-+ clock_gettime(CLOCK_REALTIME, &ts);
-+#endif
-+
- return (uint64_t)(ts.tv_sec) * 1000000000 + ts.tv_nsec;
- }
-
diff --git a/multimedia/gavl/pkg-plist b/multimedia/gavl/pkg-plist
index a93f69420857..c907714c2a27 100644
--- a/multimedia/gavl/pkg-plist
+++ b/multimedia/gavl/pkg-plist
@@ -4,6 +4,8 @@ include/gavl/gavl_version.h
include/gavl/gavldefs.h
include/gavl/gavldsp.h
include/gavl/gavltime.h
+include/gavl/metatags.h
+include/gavl/metadata.h
include/gavl/timecode.h
lib/libgavl.la
lib/libgavl.so
diff --git a/multimedia/gmerlin-avdecoder/Makefile b/multimedia/gmerlin-avdecoder/Makefile
index d35e47e4c44d..eb24da301d8f 100644
--- a/multimedia/gmerlin-avdecoder/Makefile
+++ b/multimedia/gmerlin-avdecoder/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gmerlin-avdecoder
-PORTVERSION= 1.1.0
-PORTREVISION= 7
+PORTVERSION= 1.2.0
CATEGORIES= multimedia
MASTER_SITES= SF/gmerlin/${PORTNAME}/${PORTVERSION}
@@ -17,32 +16,20 @@ COMMENT= General purpose media decoding library
BUILD_DEPENDS= ${LOCALBASE}/include/linux/dvb/frontend.h:${PORTSDIR}/multimedia/v4l_compat
LIB_DEPENDS= gavl.1:${PORTSDIR}/multimedia/gavl
-OPTIONS= GMERLIN "Enable gmerlin support" on \
- FFMPEG "Enable ffmpeg support" on \
- THEORA "Enable theora support" on \
- SPEEX "Enable speex support" on \
- MJPEGTOOLS "Enable mjpegtools support" on \
- VORBIS "Enable vorbis support" on \
- MPEG2 "Enable MPEG2 support" on \
- TIFF "Enable TIFF support" on \
- SAMBA "Enable samba support" on \
- PNG "Enable libpng support" on \
- FAAD "Enabled FAAD2 support" on \
- DVDREAD "Enable libdvdread support" on \
- FLAC "Enable FLAC support" on \
- MUSEPACK "Enable musepack (mpc) support" on \
- MAD "Enable mp3 support" on \
- A52 "Enable A52 support" on \
- DCA "Enable DTS Coherent Acoustics decoder" on \
- CDIO "Enable libcdio support" on \
- OPENJPEG "Enable JPEG2000 support" on \
- SCHROEDINGER "Enable dirac support" on \
- OPTIMIZED_CFLAGS "Additional optimizations" on
+OPTIONS_DEFINE= A52 CDIO DCA DVDREAD FAAD FFMPEG FLAC GMERLIN MAD \
+ MJPEGTOOLS MPEG2 MUSEPACK OPENJPEG OPTIMIZED_CFLAGS PNG \
+ SAMBA SCHROEDINGER SPEEX THEORA TIFF VDPAU VORBIS
+OPTIONS_DEFAULT= A52 CDIO DCA DVDREAD FAAD FFMPEG FLAC GMERLIN MAD \
+ MJPEGTOOLS MPEG2 MUSEPACK OPENJPEG OPTIMIZED_CFLAGS PNG \
+ SAMBA SCHROEDINGER SPEEX THEORA TIFF VDPAU VORBIS
+DVDREAD_DESC= libdvdread support
+GMERLIN_DESC= gmerlin support
+SAMBA_DESC= Samba support using libsmbclient
USE_GNOME= gnomehack pkgconfig
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-cpuflags --without-doxygen
+CONFIGURE_ARGS= --with-cpuflags=none --without-doxygen
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -50,7 +37,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_GMERLIN)
+.if ${PORT_OPTIONS:MGMERLIN}
LIB_DEPENDS+= gmerlin.0:${PORTSDIR}/multimedia/gmerlin
PLIST_SUB+= GMERLIN=""
.else
@@ -58,68 +45,68 @@ CONFIGURE_ARGS+=--disable-gmerlin
PLIST_SUB+= GMERLIN="@comment "
.endif
-.if !defined(WITHOUT_FFMPEG)
+.if ${PORT_OPTIONS:MFFMPEG}
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
.else
CONFIGURE_ARGS+=--disable-libavcodec --disable-libpostproc --disable-libswscale --disable-libavformat
.endif
-.if !defined(WITHOUT_THEORA)
+.if ${PORT_OPTIONS:MTHEORA}
LIB_DEPENDS+= theora.0:${PORTSDIR}/multimedia/libtheora
.else
CONFIGURE_ARGS+=--disable-theoradec
.endif
-.if !defined(WITHOUT_SPEEX)
+.if ${PORT_OPTIONS:MSPEEX}
LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
.else
CONFIGURE_ARGS+=--disable-speex
.endif
-.if !defined(WITHOUT_MJPEGTOOLS)
+.if ${PORT_OPTIONS:MJPEGTOOLS}
LIB_DEPENDS+= lavjpeg-2.0.0:${PORTSDIR}/multimedia/mjpegtools
.else
CONFIGURE_ARGS+=--disable-mjpegtools
.endif
-.if !defined(WITHOUT_VORBIS)
+.if ${PORT_OPTIONS:MVORBIS}
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+=--with-vorbis=${LOCALBASE}
.else
CONFIGURE_ARGS+=--disable-vorbis
.endif
-.if !defined(WITHOUT_MPEG2)
+.if ${PORT_OPTIONS:MMPEG2}
LIB_DEPENDS+= mpeg2.0:${PORTSDIR}/multimedia/libmpeg2
.else
CONFIGURE_ARGS+=--disable-libmpeg2
.endif
-.if !defined(WITHOUT_TIFF)
+.if ${PORT_OPTIONS:MTIFF}
LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
.else
CONFIGURE_ARGS+=--disable-libtiff
.endif
-.if !defined(WITHOUT_SAMBA)
+.if ${PORT_OPTIONS:MSAMBA}
LIB_DEPENDS+= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
.else
CONFIGURE_ARGS+=--disable-samba
.endif
-.if !defined(WITHOUT_PNG)
+.if ${PORT_OPTIONS:MPNG}
LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
.else
CONFIGURE_ARGS+=--disable-libpng
.endif
-.if !defined(WITHOUT_FAAD)
+.if ${PORT_OPTIONS:MFAAD}
LIB_DEPENDS+= faad.2:${PORTSDIR}/audio/faad
.else
CONFIGURE_ARGS+=--disable-faad2
.endif
-.if !defined(WITHOUT_DVDREAD)
+.if ${PORT_OPTIONS:MDVDREAD}
LIB_DEPENDS+= dvdread.4:${PORTSDIR}/multimedia/libdvdread
PLIST_SUB+= DVDREAD=""
.else
@@ -127,38 +114,38 @@ CONFIGURE_ARGS+=--disable-dvdread
PLIST_SUB+= DVDREAD="@comment "
.endif
-.if !defined(WITHOUT_FLAC)
+.if ${PORT_OPTIONS:MFLAC}
LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
.else
CONFIGURE_ARGS+=--disable-flac
.endif
-.if !defined(WITHOUT_MUSEPACK)
+.if ${PORT_OPTIONS:MMUSEPACK}
LIB_DEPENDS+= mpcdec.7:${PORTSDIR}/audio/musepack
.else
CONFIGURE_ARGS+=--disable-musepack
.endif
-.if !defined(WITHOUT_MAD)
+.if ${PORT_OPTIONS:MMAD}
LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
.else
CONFIGURE_ARGS+=--disable-mad
.endif
-.if !defined(WITHOUT_A52)
+.if ${PORT_OPTIONS:MA52}
LIB_DEPENDS+= a52.0:${PORTSDIR}/audio/liba52
.else
CONFIGURE_ARGS+=--disable-liba52
.endif
-.if !defined(WITHOUT_DCA)
+.if ${PORT_OPTIONS:MDCA}
LIB_DEPENDS+= dca.0:${PORTSDIR}/multimedia/libdca
.else
# error in configure
CONFIGURE_ARGS+=--disable-libcda --disable-libdca
.endif
-.if !defined(WITHOUT_CDIO)
+.if ${PORT_OPTIONS:MCDIO}
LIB_DEPENDS+= cdio.13:${PORTSDIR}/sysutils/libcdio
PLIST_SUB+= CDIO=""
.else
@@ -166,20 +153,26 @@ CONFIGURE_ARGS+=--disable-libcdio
PLIST_SUB+= CDIO="@comment "
.endif
-.if !defined(WITHOUT_OPENJPEG)
+.if ${PORT_OPTIONS:MOPENJPEG}
LIB_DEPENDS+= openjpeg.2:${PORTSDIR}/graphics/openjpeg
.else
CONFIGURE_ARGS+=--disable-openjpeg
.endif
-.if !defined(WITHOUT_SCHROEDINGER)
+.if ${PORT_OPTIONS:MSCHROEDINGER}
LIB_DEPENDS+= schroedinger-1.0.11:${PORTSDIR}/multimedia/schroedinger
.else
CONFIGURE_ARGS+=--disable-schroedinger
.endif
+.if ${PORT_OPTIONS:MVDPAU}
+LIB_DEPENDS+= vdpau.1:${PORTSDIR}/multimedia/libvdpau
+.else
+CONFIGURE_ARGS+= --disable-vdpau
+.endif
+
# vendor ocflags from configure
-.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CFLAGS+= -O3 -funroll-all-loops -ffast-math
CXXFLAGS+= -O3 -funroll-all-loops -ffast-math
.endif
@@ -197,7 +190,7 @@ post-patch:
's|malloc.h|stdlib.h|' ${WRKSRC}/lib/in_smb.c
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/multimedia/gmerlin-avdecoder/distinfo b/multimedia/gmerlin-avdecoder/distinfo
index c7832659b912..62b62c26031c 100644
--- a/multimedia/gmerlin-avdecoder/distinfo
+++ b/multimedia/gmerlin-avdecoder/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gmerlin-avdecoder-1.1.0.tar.gz) = b0a9efcf152321d8829d2023660c8d14fdde894dc8881bdd67269c4f4cb4cc35
-SIZE (gmerlin-avdecoder-1.1.0.tar.gz) = 1472068
+SHA256 (gmerlin-avdecoder-1.2.0.tar.gz) = 8e727fe0c9db6875bd71f3f4cac8e8feaca62d0ef1b26a86678241ecbed59afa
+SIZE (gmerlin-avdecoder-1.2.0.tar.gz) = 1496378
diff --git a/multimedia/gmerlin-avdecoder/files/patch-lib-demux_ffmpeg.c b/multimedia/gmerlin-avdecoder/files/patch-lib-demux_ffmpeg.c
new file mode 100644
index 000000000000..51eddc5d9d46
--- /dev/null
+++ b/multimedia/gmerlin-avdecoder/files/patch-lib-demux_ffmpeg.c
@@ -0,0 +1,25 @@
+--- lib/demux_ffmpeg.c.orig 2012-06-08 13:51:34.000000000 +0200
++++ lib/demux_ffmpeg.c 2012-07-22 00:23:38.489505138 +0200
+@@ -774,15 +774,17 @@
+
+ /* Metadata */
+ if(avfc->title[0])
+- ctx->tt->cur->metadata.title = bgav_strdup(avfc->title);
++ gavl_metadata_set(&ctx->tt->cur->metadata, GAVL_META_TITLE, avfc->title);
+ if(avfc->author[0])
+- ctx->tt->cur->metadata.author = bgav_strdup(avfc->author);
++ gavl_metadata_set(&ctx->tt->cur->metadata, GAVL_META_AUTHOR, avfc->author);
+ if(avfc->copyright[0])
+- ctx->tt->cur->metadata.copyright = bgav_strdup(avfc->copyright);
++ gavl_metadata_set(&ctx->tt->cur->metadata, GAVL_META_COPYRIGHT, avfc->copyright);
+ if(avfc->album[0])
+- ctx->tt->cur->metadata.album = bgav_strdup(avfc->album);
++ gavl_metadata_set(&ctx->tt->cur->metadata, GAVL_META_ALBUM, avfc->album);
+ if(avfc->genre[0])
+- ctx->tt->cur->metadata.genre = bgav_strdup(avfc->genre);
++ gavl_metadata_set(&ctx->tt->cur->metadata, GAVL_META_GENRE, avfc->genre);
++ if(avfc->track)
++ gavl_metadata_set_int(&ctx->tt->cur->metadata, GAVL_META_TRACKNUMBER, avfc->track);
+
+ #endif
+
diff --git a/multimedia/gmerlin/Makefile b/multimedia/gmerlin/Makefile
index 3ecda24979f2..6a73de5a8ac0 100644
--- a/multimedia/gmerlin/Makefile
+++ b/multimedia/gmerlin/Makefile
@@ -6,43 +6,33 @@
#
PORTNAME= gmerlin
-PORTVERSION= 1.0.0
-PORTREVISION= 4
+PORTVERSION= 1.2.0
CATEGORIES= multimedia
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Multimedia framework
-LIB_DEPENDS= gavl.1:${PORTSDIR}/multimedia/gavl
-
-OPTIONS= PULSEAUDIO "Enable PulseAudio support" on \
- QUICKTIME "Enable QuickTime support" on \
- VISUAL "Enable libvisual support" on \
- CDIO "Enable libcdio support" on \
- CDDB "Enable CDDB support" on \
- ESOUND "Enable ESounD support" off \
- JACK "Enable Jack support" on \
- JPEG "Enable JPEG support" on \
- PNG "Enable PNG support" on \
- TIFF "Enable TIFF support" on \
- PLUGINCFG "Build plugin configurator" on \
- PLAYER "Build player" on \
- KBD "Build keyboard daemon" on \
- TRANSCODER "Build transcoder" on \
- RECORDER "Build recorder" on \
- VISUALIZER "Build visualizer" on \
- THUMBNAILER "Build thumbnailer" on \
- OPTIMIZED_CFLAGS "Additional optimizations" on
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
+ gavl.1:${PORTSDIR}/multimedia/gavl
+
+OPTIONS_DEFINE= ALSA CDDB CDIO ESOUND JACK JPEG LIBVISUAL \
+ OPTIMIZED_CFLAGS PNG PULSEAUDIO QUICKTIME \
+ TIFF
+OPTIONS_DEFAULT= CDDB CDIO JACK JPEG LIBVISUAL \
+ OPTIMIZED_CFLAGS PNG PULSEAUDIO QUICKTIME \
+ TIFF
-USE_GNOME= gnomehack gtk20 libxml2
-USE_XORG= ice x11 xinerama xv
-USE_GL= gl
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-alsa --disable-v4l --disable-v4l2 \
- --disable-camelot --disable-alsamixer --disable-v4lconvert \
- --without-doxygen --without-cpuflags --disable-musicbrainz
+CONFIGURE_ARGS= --disable-v4l --disable-v4l2 --disable-v4lconvert \
+ --without-doxygen --with-cpuflags=none --disable-musicbrainz
+USE_GNOME= gnomehack gtk20 libxml2
+USE_XORG= x11 xext xfixes xinerama xv
+USE_GL= gl
USE_LDCONFIG= yes
INSTALL_ICONS= yes
@@ -50,11 +40,24 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INFO= gmerlin
-MAN1= gmerlin_play.1
+MAN1= gmerlin.1 \
+ gmerlin_play.1 \
+ gmerlin_remote.1 \
+ gmerlin_transcoder.1 \
+ gmerlin_transcoder_remote.1 \
+ gmerlin-record.1
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_PULSEAUDIO)
+.if ${PORT_OPTIONS:MALSA}
+LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
+PLIST_SUB+= ALSA=""
+.else
+CONFIGURE_ARGS+=--disable-alsa
+PLIST_SUB+= ALSA="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MPULSEAUDIO}
LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
PLIST_SUB+= PULSEAUDIO=""
.else
@@ -62,7 +65,7 @@ CONFIGURE_ARGS+=--disable-pulseaudio
PLIST_SUB+= PULSEAUDIO="@comment "
.endif
-.if !defined(WITHOUT_QUICKTIME)
+.if ${PORT_OPTIONS:MQUICKTIME}
LIB_DEPENDS+= quicktime.0:${PORTSDIR}/multimedia/libquicktime
PLIST_SUB+= QUICKTIME=""
.else
@@ -70,13 +73,13 @@ CONFIGURE_ARGS+=--disable-lqt
PLIST_SUB+= QUICKTIME="@comment "
.endif
-.if !defined(WITHOUT_VISUAL)
+.if ${PORT_OPTIONS:MLIBVISUAL}
LIB_DEPENDS+= visual-0.4:${PORTSDIR}/graphics/libvisual04
.else
CONFIGURE_ARGS+=--disable-libvisual
.endif
-.if !defined(WITHOUT_CDIO)
+.if ${PORT_OPTIONS:MCDIO}
LIB_DEPENDS+= cdio.13:${PORTSDIR}/sysutils/libcdio
PLIST_SUB+= CDIO=""
.else
@@ -84,13 +87,13 @@ CONFIGURE_ARGS+=--disable-libcdio
PLIST_SUB+= CDIO="@comment "
.endif
-.if !defined(WITHOUT_CDDB)
+.if ${PORT_OPTIONS:MCDDB}
LIB_DEPENDS+= cddb.4:${PORTSDIR}/audio/libcddb
.else
CONFIGURE_ARGS+=--disable-cddb
.endif
-.if defined(WITH_ESOUND)
+.if ${PORT_OPTIONS:MESOUND}
LIB_DEPENDS+= esd.2:${PORTSDIR}/audio/esound
PLIST_SUB+= ESOUND=""
.else
@@ -98,7 +101,7 @@ CONFIGURE_ARGS+=--disable-esd
PLIST_SUB+= ESOUND="@comment "
.endif
-.if defined(WITH_JACK)
+.if ${PORT_OPTIONS:MJACK}
LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
PLIST_SUB+= JACK=""
.else
@@ -106,7 +109,7 @@ CONFIGURE_ARGS+=--disable-jack
PLIST_SUB+= JACK="@comment "
.endif
-.if !defined(WITHOUT_JPEG)
+.if ${PORT_OPTIONS:MJPEG}
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
PLIST_SUB+= JPEG=""
.else
@@ -114,7 +117,7 @@ CONFIGURE_ARGS+=--disable-libjpeg
PLIST_SUB+= JPEG="@comment "
.endif
-.if !defined(WITHOUT_PNG)
+.if ${PORT_OPTIONS:MPNG}
LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
PLIST_SUB+= PNG=""
.else
@@ -122,7 +125,7 @@ CONFIGURE_ARGS+=--disable-libpng
PLIST_SUB+= PNG="@comment "
.endif
-.if !defined(WITHOUT_TIFF)
+.if ${PORT_OPTIONS:MTIFF}
LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
PLIST_SUB+= TIFF=""
.else
@@ -131,59 +134,15 @@ PLIST_SUB+= TIFF="@comment "
.endif
# applications
-.if !defined(WITHOUT_PLUGINCFG)
-PLIST_SUB+= PLUGINCFG=""
-.else
-CONFIGURE_ARGS+=--disable-plugincfg
-PLIST_SUB+= PLUGINCFG="@comment "
-.endif
-
-.if !defined(WITHOUT_PLAYER)
-MAN1+= gmerlin.1 gmerlin_remote.1
-PLIST_SUB+= PLAYER=""
-.else
-CONFIGURE_ARGS+=--disable-player
-PLIST_SUB+= PLAYER="@comment "
-.endif
-
-.if !defined(WITHOUT_KBD)
-PLIST_SUB+= KBD=""
-.else
-CONFIGURE_ARGS+=--disable-kbd
-PLIST_SUB+= KBD="@comment "
-.endif
-
-.if !defined(WITHOUT_TRANSCODER)
-MAN1+= gmerlin_transcoder.1 gmerlin_transcoder_remote.1
-PLIST_SUB+= TRANSCODER=""
-.else
-CONFIGURE_ARGS+=--disable-transcoder
-PLIST_SUB+= TRANSCODER="@comment "
-.endif
-
-.if !defined(WITHOUT_RECORDER)
-PLIST_SUB+= RECORDER=""
-.else
-CONFIGURE_ARGS+=--disable-recorder
-PLIST_SUB+= RECORDER="@comment "
-.endif
-
-.if !defined(WITHOUT_VISUALIZER)
-PLIST_SUB+= VISUALIZER=""
-.else
-CONFIGURE_ARGS+=--disable-visualizer
-PLIST_SUB+= VISUALIZER="@comment "
-.endif
-
-.if !defined(WITHOUT_THUMBNAILER)
-PLIST_SUB+= THUMBNAILER=""
+.if ${PORT_OPTIONS:MALSA}
+PLIST_SUB+= ALSAMIXER=""
.else
-CONFIGURE_ARGS+=--disable-thumbnailer
-PLIST_SUB+= THUMBNAILER="@comment "
+CONFIGURE_ARGS+=--disable-alsamixer
+PLIST_SUB+= ALSAMIXER="@comment "
.endif
# vendor ocflags from configure
-.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CFLAGS+= -O3 -funroll-all-loops -fomit-frame-pointer -ffast-math
CXXFLAGS+= -O3 -funroll-all-loops -fomit-frame-pointer -ffast-math
.endif
@@ -194,21 +153,18 @@ post-patch:
s|-DGTK_DISABLE_DEPRECATED||g ; \
/LIBS/ s|-ldl||g ; \
s|^LDFLAGS="|&$${LDFLAGS} |g' ${WRKSRC}/configure
-.for file in apps/cmdlineplayer/Makefile.in apps/kbd/Makefile.in \
- apps/player/Makefile.in apps/transcoder/Makefile.in \
- apps/thumbnailer/Makefile.in lib/Makefile.in tests/Makefile.in
@${REINPLACE_CMD} -e \
's|-ldl||g ; \
s|-lpthread|${PTHREAD_LIBS}|g ; \
- /^LIBS = / s|$$| @LIBINTL@ ${PTHREAD_LIBS}|g' ${WRKSRC}/${file}
-.endfor
-.for file in doc/Makefile.in
+ /^LIBS = / s|$$| @LIBINTL@ ${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/lib/Makefile.am ${WRKSRC}/lib/Makefile.in \
+ ${WRKSRC}/tests/Makefile.am ${WRKSRC}/tests/Makefile.in \
+ ${WRKSRC}/apps/*/Makefile.am ${WRKSRC}/apps/*/Makefile.in
@${REINPLACE_CMD} -e \
- 's|^texinfo_|#texinfo_|g' ${WRKSRC}/${file}
-.endfor
+ 's|^texinfo_|#texinfo_|g' ${WRKSRC}/doc/Makefile.in
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/multimedia/gmerlin/distinfo b/multimedia/gmerlin/distinfo
index 591328f381f2..8896ad471b72 100644
--- a/multimedia/gmerlin/distinfo
+++ b/multimedia/gmerlin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gmerlin-1.0.0.tar.gz) = a94bfd08869aa575982f4713a103bb0af314591414c02be6634239b70d7a9b14
-SIZE (gmerlin-1.0.0.tar.gz) = 2450041
+SHA256 (gmerlin-1.2.0.tar.gz) = 80a217c417b197562961cfd55bf5d356d7eb5278601f6f5e05636455822e3d62
+SIZE (gmerlin-1.2.0.tar.gz) = 3119224
diff --git a/multimedia/gmerlin/files/patch-plugins-png_ir_png.c b/multimedia/gmerlin/files/patch-plugins-png_ir_png.c
deleted file mode 100644
index 8b6ed3b80508..000000000000
--- a/multimedia/gmerlin/files/patch-plugins-png_ir_png.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- plugins/png/ir_png.c.orig 2011-11-17 15:55:16.000000000 +0100
-+++ plugins/png/ir_png.c 2011-11-17 15:55:29.000000000 +0100
-@@ -133,7 +133,6 @@
- png_set_expand_gray_1_2_4_to_8(png->png_ptr);
- #endif
-
-- png_set_gray_1_2_4_to_8(png->png_ptr);
- if (png_get_valid(png->png_ptr, png->info_ptr, PNG_INFO_tRNS))
- {
- png_set_tRNS_to_alpha(png->png_ptr);
diff --git a/multimedia/gmerlin/pkg-plist b/multimedia/gmerlin/pkg-plist
index f2ba81affd88..c12023577235 100644
--- a/multimedia/gmerlin/pkg-plist
+++ b/multimedia/gmerlin/pkg-plist
@@ -1,21 +1,25 @@
-%%PLAYER%%bin/gmerlin
-%%THUMBNAILER%%bin/gmerlin-video-thumbnailer
+bin/album2m3u
+bin/album2pls
+bin/gmerlin
+bin/gmerlin-video-thumbnailer
+%%ALSAMIXER%%bin/gmerlin_alsamixer
bin/gmerlin_imgconvert
bin/gmerlin_imgdiff
-%%KBD%%bin/gmerlin_kbd
-%%KBD%%bin/gmerlin_kbd_config
-%%PLAYER%%bin/gmerlin_launcher
+bin/gmerlin_kbd
+bin/gmerlin_kbd_config
+bin/gmerlin_launcher
bin/gmerlin_play
-%%PLUGINCFG%%bin/gmerlin_plugincfg
+bin/gmerlin_plugincfg
bin/gmerlin_psnr
-%%RECORDER%%bin/gmerlin_recorder
-%%PLAYER%%bin/gmerlin_remote
+bin/gmerlin-record
+bin/gmerlin_recorder
+bin/gmerlin_remote
bin/gmerlin_ssim
-%%TRANSCODER%%bin/gmerlin_transcoder
-%%TRANSCODER%%bin/gmerlin_transcoder_remote
+bin/gmerlin_transcoder
+bin/gmerlin_transcoder_remote
bin/gmerlin_vanalyze
bin/gmerlin_visualize
-%%VISUALIZER%%bin/gmerlin_visualizer
+bin/gmerlin_visualizer
bin/gmerlin_visualizer_slave
bin/gmerlin_vpsnr
include/gmerlin/accelerator.h
@@ -59,8 +63,11 @@ include/gmerlin/gui_gtk/urlselect.h
include/gmerlin/keycodes.h
include/gmerlin/lcdproc.h
include/gmerlin/log.h
+include/gmerlin/mediafiledevice.h
include/gmerlin/msgqueue.h
+include/gmerlin/ocr.h
include/gmerlin/osd.h
+include/gmerlin/ov.h
include/gmerlin/parameter.h
include/gmerlin/player.h
include/gmerlin/playermsg.h
@@ -130,16 +137,22 @@ lib/gmerlin/plugins/fv_oldcolor.la
lib/gmerlin/plugins/fv_oldcolor.so
lib/gmerlin/plugins/fv_pixelformat.la
lib/gmerlin/plugins/fv_pixelformat.so
+lib/gmerlin/plugins/fv_swapfields.la
+lib/gmerlin/plugins/fv_swapfields.so
lib/gmerlin/plugins/fv_tcdisplay.la
lib/gmerlin/plugins/fv_tcdisplay.so
lib/gmerlin/plugins/fv_tctweak.la
lib/gmerlin/plugins/fv_tctweak.so
+lib/gmerlin/plugins/fv_textlogo.la
+lib/gmerlin/plugins/fv_textlogo.so
lib/gmerlin/plugins/fv_tlp.la
lib/gmerlin/plugins/fv_tlp.so
lib/gmerlin/plugins/fv_transform.la
lib/gmerlin/plugins/fv_transform.so
lib/gmerlin/plugins/fv_zoom.la
lib/gmerlin/plugins/fv_zoom.so
+%%ALSA%%lib/gmerlin/plugins/i_alsa.la
+%%ALSA%%lib/gmerlin/plugins/i_alsa.so
%%CDIO%%lib/gmerlin/plugins/i_cdaudio.la
%%CDIO%%lib/gmerlin/plugins/i_cdaudio.so
lib/gmerlin/plugins/i_edl.la
@@ -186,6 +199,8 @@ lib/gmerlin/plugins/iw_tga.la
lib/gmerlin/plugins/iw_tga.so
%%TIFF%%lib/gmerlin/plugins/iw_tiff.la
%%TIFF%%lib/gmerlin/plugins/iw_tiff.so
+%%ALSA%%lib/gmerlin/plugins/oa_alsa.la
+%%ALSA%%lib/gmerlin/plugins/oa_alsa.so
%%ESOUND%%lib/gmerlin/plugins/oa_esd.la
%%ESOUND%%lib/gmerlin/plugins/oa_esd.so
%%JACK%%lib/gmerlin/plugins/oa_jack.la
@@ -206,12 +221,13 @@ lib/libgmerlin_gtk.so
lib/libgmerlin_gtk.so.0
libdata/pkgconfig/gmerlin-gtk.pc
libdata/pkgconfig/gmerlin.pc
-%%KBD%%share/applications/gmerlin-kbd.desktop
-%%PLAYER%%share/applications/gmerlin-player.desktop
-%%PLUGINCFG%%share/applications/gmerlin-plugincfg.desktop
-%%RECORDER%%share/applications/gmerlin-recorder.desktop
-%%TRANSCODER%%share/applications/gmerlin-transcoder.desktop
-%%VISUALIZER%%share/applications/gmerlin-visualizer.desktop
+%%ALSAMIXER%%share/applications/gmerlin-alsamixer.desktop
+share/applications/gmerlin-kbd.desktop
+share/applications/gmerlin-player.desktop
+share/applications/gmerlin-plugincfg.desktop
+share/applications/gmerlin-recorder.desktop
+share/applications/gmerlin-transcoder.desktop
+share/applications/gmerlin-visualizer.desktop
%%PORTDOCS%%%%DOCSDIR%%/README
%%DATADIR%%/icons/about_16.png
%%DATADIR%%/icons/add_16.png