aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile11
-rw-r--r--multimedia/mplayer/distinfo6
-rw-r--r--multimedia/mplayer/files/patch-ad36
-rw-r--r--multimedia/mplayer/files/patch-libdha-Makefile8
-rw-r--r--multimedia/mplayer/files/patch-libmpdemux-demux_rtp.cpp11
-rw-r--r--multimedia/mplayer/files/patch-libmpdemux-tvi_bsdbt84818
-rw-r--r--multimedia/mplayer/files/patch-vidix-drivers-Makefile10
-rw-r--r--multimedia/mplayer/pkg-plist8
8 files changed, 48 insertions, 60 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 02ec2984c097..5754738c6296 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -206,8 +206,7 @@
# to be installed.
PORTNAME= mplayer
-PORTVERSION= 0.99.4
-PORTREVISION= 2
+PORTVERSION= 0.99.5
CATEGORIES= multimedia audio ipv6
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
@@ -219,13 +218,7 @@ MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
ftp://ftp.lug.udel.edu/MPlayer/releases/ \
ftp://mirrors.xmission.com/MPlayer/releases/ \
http://www.rrr.de/~riggs/mplayer/
-DISTNAME= MPlayer-1.0pre4
-
-PATCH_SITES= http://www.mplayerhq.hu/MPlayer/patches/ \
- http://www4.mplayerhq.hu/MPlayer/patches/ \
- http://www7.mplayerhq.hu/MPlayer/patches/
-PATCHFILES= vuln04-fix.diff
-PATCH_DIST_STRIP= -p0
+DISTNAME= MPlayer-1.0pre5
MAINTAINER= riggs@rrr.de
COMMENT= High performance media player/encoder supporting many formats
diff --git a/multimedia/mplayer/distinfo b/multimedia/mplayer/distinfo
index 5507529f61e2..d8d3a7c22d14 100644
--- a/multimedia/mplayer/distinfo
+++ b/multimedia/mplayer/distinfo
@@ -1,4 +1,2 @@
-MD5 (MPlayer-1.0pre4.tar.bz2) = 83ebac0f05b192516a41fca2350ca01a
-SIZE (MPlayer-1.0pre4.tar.bz2) = 4913390
-MD5 (vuln04-fix.diff) = 4e5c1984d56d2c5f3bfd3a086df4f80c
-SIZE (vuln04-fix.diff) = 23440
+MD5 (MPlayer-1.0pre5.tar.bz2) = fbe6919eb025526e8ed129cd61a49969
+SIZE (MPlayer-1.0pre5.tar.bz2) = 5072836
diff --git a/multimedia/mplayer/files/patch-ad b/multimedia/mplayer/files/patch-ad
index d16072f7d5ba..c80f3683b83e 100644
--- a/multimedia/mplayer/files/patch-ad
+++ b/multimedia/mplayer/files/patch-ad
@@ -1,6 +1,6 @@
---- configure.orig Mon Apr 26 05:44:06 2004
-+++ configure Sun Jun 27 03:30:21 2004
-@@ -339,7 +339,7 @@
+--- configure.orig Thu Jul 15 00:04:42 2004
++++ configure Thu Jul 22 22:13:22 2004
+@@ -344,7 +344,7 @@
# 1st pass checking for vital options
@@ -9,7 +9,7 @@
_ranlib=ranlib
_cc=cc
test "$CC" && _cc="$CC"
-@@ -594,22 +594,10 @@
+@@ -601,22 +601,10 @@
_cpuinfo="echo"
# Cygwin has /proc/cpuinfo, but only supports Intel CPUs
# FIXME: Remove the cygwin check once AMD CPUs are supported
@@ -32,7 +32,7 @@
case "$host_arch" in
i[3-9]86|x86|x86pc|k5|k6|k6-2|k6-3|pentium*|athlon*|i586-i686)
-@@ -1656,8 +1644,8 @@
+@@ -1687,8 +1675,8 @@
;;
*)
@@ -43,7 +43,7 @@
;;
esac
-@@ -1667,7 +1655,7 @@
+@@ -1698,7 +1686,7 @@
test -z "$_bindir" && _bindir="$_prefix/bin"
test -z "$_datadir" && _datadir="$_prefix/share/mplayer"
test -z "$_mandir" && _mandir="$_prefix/man"
@@ -52,7 +52,7 @@
test -z "$_libdir" && _libdir="$_prefix/lib"
test -z "$_mlibdir" && _mlibdir="$MLIBHOME"
-@@ -2258,13 +2246,7 @@
+@@ -2371,13 +2359,7 @@
echocheck "memalign()"
@@ -66,7 +66,7 @@
if test "$_memalign" = yes ; then
_def_memalign='#define HAVE_MEMALIGN 1'
else
-@@ -2352,40 +2334,8 @@
+@@ -2465,45 +2447,10 @@
echocheck "pthread"
@@ -100,16 +100,20 @@
- fi
-fi
-if test "$_ld_pthread" != '' ; then
-- echores "yes (using $_ld_pthread)"
++_ld_pthread="${PTHREAD_LIBS}"
+ echores "yes (using $_ld_pthread)"
+ _pthreads='yes'
+ _def_pthreads='#define HAVE_PTHREADS 1'
-else
- echores "no"
+- _pthreads=''
+- _def_pthreads='#undef HAVE_PTHREADS'
-fi
-+_ld_pthread="${PTHREAD_LIBS}"
-+echores "yes (using $_ld_pthread)"
-
+-
echocheck "sys/soundcard.h"
-@@ -4458,11 +4408,11 @@
+ cat > $TMPC << EOF
+@@ -4670,11 +4617,11 @@
echocheck "RTC"
@@ -123,7 +127,7 @@
int main(void) { return RTC_IRQP_READ; }
EOF
_rtc=no
-@@ -5736,7 +5686,7 @@
+@@ -5909,7 +5856,7 @@
_stripbinaries=no
elif test -z "$CFLAGS" ; then
if test "$host_arch" != "mips" ; then
@@ -132,7 +136,7 @@
else
CFLAGS="-O4 $_march $_mcpu -ffast-math -fomit-frame-pointer"
fi
-@@ -5746,6 +5696,9 @@
+@@ -5919,6 +5866,9 @@
_stripbinaries=no
fi
else
@@ -142,7 +146,7 @@
cat <<EOF
MPlayer compilation will use the CFLAGS set by you, but:
-@@ -5772,7 +5725,7 @@
+@@ -5948,7 +5898,7 @@
CFLAGS="$CFLAGS -D_REENTRANT"
elif bsd ; then
# FIXME bsd needs this so maybe other OS'es
diff --git a/multimedia/mplayer/files/patch-libdha-Makefile b/multimedia/mplayer/files/patch-libdha-Makefile
index 5e2e22cfacf2..97202cf12906 100644
--- a/multimedia/mplayer/files/patch-libdha-Makefile
+++ b/multimedia/mplayer/files/patch-libdha-Makefile
@@ -1,9 +1,9 @@
---- libdha/Makefile.orig Sat Jan 24 20:54:51 2004
-+++ libdha/Makefile Sat Jan 24 20:55:44 2004
+--- libdha/Makefile.orig Mon Jul 12 12:54:10 2004
++++ libdha/Makefile Thu Jul 22 22:18:21 2004
@@ -4,8 +4,6 @@
- MAJOR_VERSION = 0
- MINOR_VERSION = 1
+ MAJOR_VERSION = 1
+ MINOR_VERSION = 0
-VERSION = $(MAJOR_VERSION).$(MINOR_VERSION)
-
diff --git a/multimedia/mplayer/files/patch-libmpdemux-demux_rtp.cpp b/multimedia/mplayer/files/patch-libmpdemux-demux_rtp.cpp
new file mode 100644
index 000000000000..dd6287b5bd38
--- /dev/null
+++ b/multimedia/mplayer/files/patch-libmpdemux-demux_rtp.cpp
@@ -0,0 +1,11 @@
+--- libmpdemux/demux_rtp.cpp.orig Thu Jun 3 15:30:55 2004
++++ libmpdemux/demux_rtp.cpp Thu Jul 22 23:29:36 2004
+@@ -407,7 +407,7 @@
+ delete rtpState->sdpDescription;
+ delete rtpState;
+
+- delete env; delete scheduler;
++ env->reclaim(); delete scheduler;
+ }
+
+ ////////// Extra routines that help implement the above interface functions:
diff --git a/multimedia/mplayer/files/patch-libmpdemux-tvi_bsdbt848 b/multimedia/mplayer/files/patch-libmpdemux-tvi_bsdbt848
deleted file mode 100644
index b135b49596bc..000000000000
--- a/multimedia/mplayer/files/patch-libmpdemux-tvi_bsdbt848
+++ /dev/null
@@ -1,18 +0,0 @@
-Index: libmpdemux/tvi_bsdbt848.c
-===================================================================
-RCS file: /cvsroot/mplayer/main/libmpdemux/tvi_bsdbt848.c,v
-retrieving revision 1.13
-diff -u -r1.13 tvi_bsdbt848.c
---- libmpdemux/tvi_bsdbt848.c 6 Apr 2004 12:23:09 -0000 1.13
-+++ libmpdemux/tvi_bsdbt848.c 18 Jun 2004 02:28:40 -0000
-@@ -366,8 +366,8 @@
- }
-
- #ifdef BT848_SAUDIO
-- if((priv->tunerready == TRUE) &&
-- ioctl(priv->btfd, BT848_SAUDIO, &tv_param_audio_id) < 0)
-+ if(priv->tunerready == TRUE &&
-+ ioctl(priv->tunerfd, BT848_SAUDIO, &tv_param_audio_id) < 0)
- {
- perror("audioid:ioctl");
- }
diff --git a/multimedia/mplayer/files/patch-vidix-drivers-Makefile b/multimedia/mplayer/files/patch-vidix-drivers-Makefile
index f131e51a1cca..d39d65e13b2c 100644
--- a/multimedia/mplayer/files/patch-vidix-drivers-Makefile
+++ b/multimedia/mplayer/files/patch-vidix-drivers-Makefile
@@ -1,5 +1,5 @@
---- vidix/drivers/Makefile.orig Wed Oct 22 18:45:33 2003
-+++ vidix/drivers/Makefile Mon Jun 14 15:23:29 2004
+--- vidix/drivers/Makefile.orig Mon May 31 16:15:35 2004
++++ vidix/drivers/Makefile Thu Jul 22 22:30:40 2004
@@ -8,55 +8,55 @@
CYBERBLADE_SRCS=cyberblade_vid.c
CYBERBLADE_OBJS=cyberblade_vid.o
@@ -10,14 +10,14 @@
RADEON_VID=radeon_vid.so
RADEON_SRCS=radeon_vid.c
RADEON_OBJS=radeon_vid.o
- RADEON_LIBS=-L../../libdha -ldha -lm
+ RADEON_LIBS=-L../../libdha -ldha -lm $(X_LIB)
-RADEON_CFLAGS=$(OPTFLAGS) -fPIC -I. -I..
+RADEON_CFLAGS=$(OPTFLAGS) $(X11_INC) -fPIC -I. -I..
RAGE128_VID=rage128_vid.so
RAGE128_SRCS=radeon_vid.c
RAGE128_OBJS=rage128_vid.o
- RAGE128_LIBS=-L../../libdha -ldha
+ RAGE128_LIBS=-L../../libdha -ldha -lm $(X_LIB)
-RAGE128_CFLAGS=$(OPTFLAGS) -fPIC -I. -I.. -DRAGE128
+RAGE128_CFLAGS=$(OPTFLAGS) $(X11_INC) -fPIC -I. -I.. -DRAGE128
@@ -54,7 +54,7 @@
NVIDIA_OBJS=nvidia_vid.o
NVIDIA_LIBS=-L../../libdha -ldha -lm
-NVIDIA_CFLAGS=$(OPTFLAGS) -fPIC -I. -I..
-+NVIDIA_CFLAGS=$(OPTFLAGS) $(X11_INC) -fPIC -I. -I..
++NVIDIA_CFLAGS=$(OPTFLAGS) $(X11_INC) -fPIC -I. -I..
SIS_VID=sis_vid.so
SIS_SRCS=sis_vid.c sis_bridge.c
diff --git a/multimedia/mplayer/pkg-plist b/multimedia/mplayer/pkg-plist
index 0a653aa52fb6..cb41dfd009c5 100644
--- a/multimedia/mplayer/pkg-plist
+++ b/multimedia/mplayer/pkg-plist
@@ -30,7 +30,7 @@ bin/mplayer
%%PORTDOCS%%share/doc/mplayer/gui.html
%%PORTDOCS%%share/doc/mplayer/history.html
%%PORTDOCS%%share/doc/mplayer/howtoread.html
-%%PORTDOCS%%share/doc/mplayer/hpux.html
+%%PORTDOCS%%share/doc/mplayer/hp-ux.html
%%PORTDOCS%%share/doc/mplayer/index.html
%%PORTDOCS%%share/doc/mplayer/install.html
%%PORTDOCS%%share/doc/mplayer/intro.html
@@ -39,12 +39,12 @@ bin/mplayer
%%PORTDOCS%%share/doc/mplayer/linux.html
%%PORTDOCS%%share/doc/mplayer/macos.html
%%PORTDOCS%%share/doc/mplayer/mailinglists.html
-%%PORTDOCS%%share/doc/mplayer/menc-feat-divx4.html
%%PORTDOCS%%share/doc/mplayer/menc-feat-dvd-mpeg4.html
%%PORTDOCS%%share/doc/mplayer/menc-feat-enc-images.html
%%PORTDOCS%%share/doc/mplayer/menc-feat-enc-libavcodec.html
%%PORTDOCS%%share/doc/mplayer/menc-feat-telecine.html
%%PORTDOCS%%share/doc/mplayer/menc-feat-mpeg.html
+%%PORTDOCS%%share/doc/mplayer/menc-feat-mpeg4.html
%%PORTDOCS%%share/doc/mplayer/menc-feat-extractsub.html
%%PORTDOCS%%share/doc/mplayer/menc-feat-fix-avi.html
%%PORTDOCS%%share/doc/mplayer/menc-feat-rescale.html
@@ -70,8 +70,8 @@ bin/mplayer
%%PORTDOCS%%share/doc/mplayer/users-vs-dev.html
%%PORTDOCS%%share/doc/mplayer/vcd.html
%%PORTDOCS%%share/doc/mplayer/windows.html
-%%VIDIX%%lib/libdha.so.0
-%%VIDIX%%lib/libdha-0.so.1
+%%VIDIX%%lib/libdha.so.1
+%%VIDIX%%lib/libdha-1.so.0
%%VIDIX%%lib/mplayer/vidix/cyberblade_vid.so
%%VIDIX%%lib/mplayer/vidix/mach64_vid.so
%%VIDIX%%lib/mplayer/vidix/mga_crtc2_vid.so