aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/gmimms/Makefile44
-rw-r--r--multimedia/gmimms/distinfo3
-rw-r--r--multimedia/gmimms/pkg-descr5
4 files changed, 53 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 8c5ccfd5c8bb..64675cf0ee7c 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -46,6 +46,7 @@
SUBDIR += gdvrecv
SUBDIR += ggrab
SUBDIR += gmencoder
+ SUBDIR += gmimms
SUBDIR += gnome-subtitles
SUBDIR += gnustep-mplayer
SUBDIR += goggles
diff --git a/multimedia/gmimms/Makefile b/multimedia/gmimms/Makefile
new file mode 100644
index 000000000000..7d06f74c23af
--- /dev/null
+++ b/multimedia/gmimms/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: gmimms
+# Date created: 3 Jul 2007
+# Whom: Yinghong.Liu <liu_yinghong@yahoo.com.cn>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmimms
+DISTVERSION= 0.0.9
+CATEGORIES= multimedia net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=${PORTNAME}
+
+MAINTAINER= liu_yinghong@yahoo.com.cn
+COMMENT= A frontend to MiMMS (Multimedia Stream ripper)
+
+RUN_DEPENDS= mimms:${PORTSDIR}/multimedia/mimms
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gtk20
+CONFIGURE_ARGS+=--disable-nls
+INSTALL_TARGET= install-exec
+
+PLIST_FILES= bin/gmimms
+
+PORTDOCS= AUTHORS ChangeLog COPYING INSTALL NEWS README
+
+DESKTOP_ENTRIES= "GIMMS" \
+ "A GTK+ frontend for MiMMS" \
+ "" \
+ "gmimms" \
+ "Application;GTK;AudioVideo;Network;" \
+ "false"
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/gmimms/distinfo b/multimedia/gmimms/distinfo
new file mode 100644
index 000000000000..3320ae177236
--- /dev/null
+++ b/multimedia/gmimms/distinfo
@@ -0,0 +1,3 @@
+MD5 (gmimms-0.0.9.tar.bz2) = 2b676c828822158208732e147488504a
+SHA256 (gmimms-0.0.9.tar.bz2) = 5264c9f8381a2543870aaa3b066fcd3d19150cdb3688a530cfaac86e2b3cdbd2
+SIZE (gmimms-0.0.9.tar.bz2) = 120200
diff --git a/multimedia/gmimms/pkg-descr b/multimedia/gmimms/pkg-descr
new file mode 100644
index 000000000000..b52c2b33e423
--- /dev/null
+++ b/multimedia/gmimms/pkg-descr
@@ -0,0 +1,5 @@
+GMiMMS is a GTK+ frontend for MiMMS, a multimedia-stream ripper.
+So it is easy to enter the MMS-URL and the output file. You can
+also record live-streams by setting the recording length in GMiMMS.
+
+WWW: http://gmimms.sourceforge.net/