aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/audacious-plugins/Makefile2
-rw-r--r--multimedia/gstreamer-plugins/Makefile2
-rw-r--r--multimedia/gstreamer1-plugins/Makefile2
-rw-r--r--multimedia/pHash/Makefile2
-rw-r--r--multimedia/qmmp-qt5/Makefile2
-rw-r--r--multimedia/sabbu/Makefile2
-rw-r--r--multimedia/vlc/Makefile13
7 files changed, 16 insertions, 9 deletions
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index 011cc8124312..ddd332eba7f5 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -3,7 +3,7 @@
PORTNAME= audacious-plugins
PORTVERSION= 4.0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia audio
MASTER_SITES= http://distfiles.audacious-media-player.org/
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index a971f94c53e4..56a643e0b5e9 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -6,7 +6,7 @@ PORTNAME= gstreamer
PORTVERSION?= ${BASE_PORTVERSION}
# When chasing a shared library for a plug-in bump the PORTREVISION in the
# plug-in port instead, like ${category}/gstreamer-plugin-${PLUGIN}.
-PORTREVISION?= 12
+PORTREVISION?= 13
PORTEPOCH= 3
CATEGORIES?= multimedia audio
MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-plugins-base/:base \
diff --git a/multimedia/gstreamer1-plugins/Makefile b/multimedia/gstreamer1-plugins/Makefile
index 487d630906c9..c18cedd07a8d 100644
--- a/multimedia/gstreamer1-plugins/Makefile
+++ b/multimedia/gstreamer1-plugins/Makefile
@@ -5,7 +5,7 @@ PORTNAME= gstreamer
PORTVERSION?= ${BASE_PORTVERSION}
# When chasing a shared library for a plug-in bump the PORTREVISION in the
# plug-in port instead, like ${category}/gstreamer1-plugin-${PLUGIN}.
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= multimedia audio
MASTER_SITES= GNOME/sources/gst-plugins-base/${PORTVERSION:R}:base \
GNOME/sources/gst-plugins-good/${PORTVERSION:R}:good \
diff --git a/multimedia/pHash/Makefile b/multimedia/pHash/Makefile
index 9aa0bf17435c..0ac7bf463223 100644
--- a/multimedia/pHash/Makefile
+++ b/multimedia/pHash/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pHash
PORTVERSION= 0.9.6
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= multimedia devel
MASTER_SITES= http://phash.org/releases/ \
http://www.cyberbotx.com/pHash/
diff --git a/multimedia/qmmp-qt5/Makefile b/multimedia/qmmp-qt5/Makefile
index 62a24d21aa4b..19f69ca35add 100644
--- a/multimedia/qmmp-qt5/Makefile
+++ b/multimedia/qmmp-qt5/Makefile
@@ -2,7 +2,7 @@
PORTNAME= qmmp
PORTVERSION= 1.2.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= multimedia
MASTER_SITES= http://qmmp.ylsoftware.com/files/ \
SF/qmmp-dev/${PORTNAME}/
diff --git a/multimedia/sabbu/Makefile b/multimedia/sabbu/Makefile
index 88813f6566d6..9a5448435bcf 100644
--- a/multimedia/sabbu/Makefile
+++ b/multimedia/sabbu/Makefile
@@ -2,7 +2,7 @@
PORTNAME= sabbu
PORTVERSION= 0.3.0
-PORTREVISION= 19
+PORTREVISION= 20
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Sabbu%20${PORTVERSION}
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index d2e5913a507d..f657e6629af1 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -26,14 +26,14 @@ BUILD_DEPENDS= gsed:textproc/gsed \
yasm:devel/yasm
RUN_DEPENDS= ffmpeg>=3.4.1,1:multimedia/ffmpeg
-USES= compiler:c++11-lib desktop-file-utils gettext-tools gmake gnome \
+USES= compiler:c++17-lang desktop-file-utils gettext-tools gmake gnome \
iconv libtool localbase pathfix pkgconfig tar:xz
# VLC git (post 2.2.4) requires C++11 support and passes the appropriate flag
# to the compiler. Until the port is updated, we explicitly pass -std=c++11 to
# the compiler because Qt 5.7+ requires C++11 support, and FreeBSD 10's clang
# does not default to C++11 mode.
-USE_CXXSTD= c++11
+# USE_CXXSTD= c++11
USE_GNOME= libxml2
USE_LDCONFIG= yes
@@ -63,7 +63,7 @@ CONFIGURE_ARGS+=--enable-debug
CFLAGS_i386= -fomit-frame-pointer
OPTIONS_DEFINE= A52 AALIB AOM ASS AVAHI CACA CHROMECAST DAV1D DBUS DCA DOCS DVDREAD \
- DVDNAV FAAD FLAC FLUID FREERDP FRIBIDI GME GNUTLS \
+ DEBUG DVDNAV FAAD FLAC FLUID FREERDP FRIBIDI GME GNUTLS \
GOOM HARFBUZZ JACK JPEG KATE LIBBLURAY LIBPLACEBO LIBRSVG2 LIBSSH2 LIRC \
LIVEMEDIA LUA MAD MFX MODPLUG MPEG2 MTP MUSEPACK \
NCURSES NFS NLS NOTIFY OGG OGGSPOTS OPTIMIZED_CFLAGS OPUS PNG PULSEAUDIO \
@@ -379,6 +379,13 @@ WITH_DVD_DEVICE?=/dev/cd0
INSTALLS_ICONS= yes
.endif
+.if ${PORT_OPTIONS:MDEBUG}
+WITH_DEBUG=yes
+CONFIGURE_ARGS+=--enable-debug --disable-optimizations
+CFLAGS+=-g -O0
+CXXFLAGS+=-g -O0
+.endif
+
post-patch:
@${REINPLACE_CMD} \
-e '\|LIBS|s|-lrt||' \