aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mpv/Makefile5
-rw-r--r--multimedia/mpv/distinfo6
-rw-r--r--multimedia/mpv/files/patch-video_vaapi.c82
-rw-r--r--multimedia/mpv/pkg-plist2
4 files changed, 6 insertions, 89 deletions
diff --git a/multimedia/mpv/Makefile b/multimedia/mpv/Makefile
index 4c47703c14c1..f93a8fdea540 100644
--- a/multimedia/mpv/Makefile
+++ b/multimedia/mpv/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= mpv
-PORTVERSION= 0.27.2
+PORTVERSION= 0.28.2
DISTVERSIONPREFIX= v
-PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= multimedia audio
@@ -14,7 +13,7 @@ COMMENT= Free and open-source general-purpose video player
LICENSE= GPLv2+ LGPL21+
LICENSE_COMB= multi
-BUILD_DEPENDS= ffmpeg>=3.3,1:multimedia/ffmpeg
+BUILD_DEPENDS= ffmpeg>=4.0,1:multimedia/ffmpeg
LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
USES= compiler:c11 desktop-file-utils iconv jpeg localbase:ldflags \
diff --git a/multimedia/mpv/distinfo b/multimedia/mpv/distinfo
index 0ecbff13ca1d..61b3fa8b8c71 100644
--- a/multimedia/mpv/distinfo
+++ b/multimedia/mpv/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1518720819
-SHA256 (mpv-player-mpv-v0.27.2_GH0.tar.gz) = 2ad104d83fd3b2b9457716615acad57e479fd1537b8fc5e37bfe9065359b50be
-SIZE (mpv-player-mpv-v0.27.2_GH0.tar.gz) = 2957191
+TIMESTAMP = 1520367163
+SHA256 (mpv-player-mpv-v0.28.2_GH0.tar.gz) = aada14e025317b5b3e8e58ffaf7902e8b6e4ec347a93d25a7c10d3579426d795
+SIZE (mpv-player-mpv-v0.28.2_GH0.tar.gz) = 2982558
SHA256 (waf-project-waf-waf-1.9.8_GH0.tar.gz) = b487efec83ea33cf8df0495cc5730e245f8dc8784e68aebf3dcf07c6712c5913
SIZE (waf-project-waf-waf-1.9.8_GH0.tar.gz) = 628874
diff --git a/multimedia/mpv/files/patch-video_vaapi.c b/multimedia/mpv/files/patch-video_vaapi.c
deleted file mode 100644
index ed8f5d98f2e1..000000000000
--- a/multimedia/mpv/files/patch-video_vaapi.c
+++ /dev/null
@@ -1,82 +0,0 @@
-From 2ecf240b1cd20875991a5b18efafbe799864ff7f Mon Sep 17 00:00:00 2001
-From: Mark Thompson <sw@jkqxz.net>
-Date: Mon, 9 Oct 2017 20:10:26 +0100
-Subject: [PATCH] vaapi: Use libva2 message callbacks
-
-They are no longer global, so they work vaguely sensibly.
---- video/vaapi.c.orig 2017-09-13 01:40:14 UTC
-+++ video/vaapi.c
-@@ -112,9 +112,27 @@ static void va_get_formats(struct mp_vaa
- ctx->image_formats = formats;
- }
-
--// VA message callbacks are global and do not have a context parameter, so it's
--// impossible to know from which VADisplay they originate. Try to route them
--// to existing mpv/libmpv instances within this process.
-+#if VA_CHECK_VERSION(1, 0, 0)
-+static void va_message_callback(void *context, const char *msg, int mp_level)
-+{
-+ struct mp_vaapi_ctx *res = context;
-+ mp_msg(res->log, mp_level, "libva: %s", msg);
-+}
-+
-+static void va_error_callback(void *context, const char *msg)
-+{
-+ va_message_callback(context, msg, MSGL_ERR);
-+}
-+
-+static void va_info_callback(void *context, const char *msg)
-+{
-+ va_message_callback(context, msg, MSGL_V);
-+}
-+#else
-+// Pre-libva2 VA message callbacks are global and do not have a context
-+// parameter, so it's impossible to know from which VADisplay they
-+// originate. Try to route them to existing mpv/libmpv instances within
-+// this process.
- static pthread_mutex_t va_log_mutex = PTHREAD_MUTEX_INITIALIZER;
- static struct mp_vaapi_ctx **va_mpv_clients;
- static int num_va_mpv_clients;
-@@ -149,6 +167,7 @@ static void va_info_callback(const char
- {
- va_message_callback(msg, MSGL_V);
- }
-+#endif
-
- static void open_lavu_vaapi_device(struct mp_vaapi_ctx *ctx)
- {
-@@ -181,6 +200,10 @@ struct mp_vaapi_ctx *va_initialize(VADis
- },
- };
-
-+#if VA_CHECK_VERSION(1, 0, 0)
-+ vaSetErrorCallback(display, va_error_callback, res);
-+ vaSetInfoCallback(display, va_info_callback, res);
-+#else
- pthread_mutex_lock(&va_log_mutex);
- MP_TARRAY_APPEND(NULL, va_mpv_clients, num_va_mpv_clients, res);
- pthread_mutex_unlock(&va_log_mutex);
-@@ -191,6 +214,7 @@ struct mp_vaapi_ctx *va_initialize(VADis
- vaSetErrorCallback(va_error_callback);
- vaSetInfoCallback(va_info_callback);
- #endif
-+#endif
-
- int major_version, minor_version;
- int status = vaInitialize(display, &major_version, &minor_version);
-@@ -231,6 +255,7 @@ void va_destroy(struct mp_vaapi_ctx *ctx
- if (ctx->destroy_native_ctx)
- ctx->destroy_native_ctx(ctx->native_ctx);
-
-+#if !VA_CHECK_VERSION(1, 0, 0)
- pthread_mutex_lock(&va_log_mutex);
- for (int n = 0; n < num_va_mpv_clients; n++) {
- if (va_mpv_clients[n] == ctx) {
-@@ -241,6 +266,7 @@ void va_destroy(struct mp_vaapi_ctx *ctx
- if (num_va_mpv_clients == 0)
- TA_FREEP(&va_mpv_clients); // avoid triggering leak detectors
- pthread_mutex_unlock(&va_log_mutex);
-+#endif
-
- talloc_free(ctx);
- }
diff --git a/multimedia/mpv/pkg-plist b/multimedia/mpv/pkg-plist
index d7650de01c1d..a42c2e77d6ff 100644
--- a/multimedia/mpv/pkg-plist
+++ b/multimedia/mpv/pkg-plist
@@ -6,7 +6,7 @@ include/mpv/qthelper.hpp
include/mpv/stream_cb.h
lib/libmpv.so
lib/libmpv.so.1
-lib/libmpv.so.1.25.0
+lib/libmpv.so.1.26.0
libdata/pkgconfig/mpv.pc
%%MANPAGES%%man/man1/mpv.1.gz
share/applications/mpv.desktop