aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/openquicktime/Makefile13
-rw-r--r--multimedia/openquicktime/files/patch-audioplugin_MP3_audioencoder_lame3.70_lame.c20
-rw-r--r--multimedia/openquicktime/pkg-descr33
3 files changed, 43 insertions, 23 deletions
diff --git a/multimedia/openquicktime/Makefile b/multimedia/openquicktime/Makefile
index 2ac7082c3ea5..a986180964e3 100644
--- a/multimedia/openquicktime/Makefile
+++ b/multimedia/openquicktime/Makefile
@@ -25,23 +25,24 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
PKGDEINSTALL= ${PKGINSTALL}
-OPTIONS= DEBUG "Turn on debugging" on
+OPTIONS= DEBUG "Turn on debugging" off
.include <bsd.port.pre.mk>
-.ifndef(WITH_DEBUG)
+.if !defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug=no
.endif
.if ${ARCH} != "i386"
-BROKEN= "Does not build on !i386"
+BROKEN= Does not build on !i386
.endif
post-patch:
- @${REINPLACE_CMD} \
- -e 's|xCC|xc|' \
- -e 's|-O2||' \
+ @${REINPLACE_CMD} -e 's|xCC|xc| ; s|-O2||' \
+ -e 's|ftello64|ftello| ; s|fseeko64|fseeko|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|"m"|"g"|' \
+ ${WRKSRC}/audioplugin/MP3/audioencoder/lame3.70/quantize-pvt.c
.if ${OSVERSION} >= 502126
@${REINPLACE_CMD} \
-e 's|-fpic||' \
diff --git a/multimedia/openquicktime/files/patch-audioplugin_MP3_audioencoder_lame3.70_lame.c b/multimedia/openquicktime/files/patch-audioplugin_MP3_audioencoder_lame3.70_lame.c
new file mode 100644
index 000000000000..357ee4435acd
--- /dev/null
+++ b/multimedia/openquicktime/files/patch-audioplugin_MP3_audioencoder_lame3.70_lame.c
@@ -0,0 +1,20 @@
+--- audioplugin/MP3/audioencoder/lame3.70/lame.c.orig Fri Jul 27 19:53:34 2001
++++ audioplugin/MP3/audioencoder/lame3.70/lame.c Mon Jul 2 10:31:21 2007
+@@ -47,6 +47,9 @@
+ #include "asmstuff.h"
+ #endif
+
++#ifdef __FreeBSD__
++#include <floatingpoint.h>
++#endif
+
+ /* Global variable definitions for lame.c */
+ static Bit_stream_struc bs;
+@@ -1198,7 +1201,6 @@
+ * Disable floating point exepctions
+ */
+ #ifdef __FreeBSD__
+-# include <floatingpoint.h>
+ {
+ /* seet floating point mask to the Linux default */
+ fp_except_t mask;
diff --git a/multimedia/openquicktime/pkg-descr b/multimedia/openquicktime/pkg-descr
index ba33c87c124c..792d2eda7b53 100644
--- a/multimedia/openquicktime/pkg-descr
+++ b/multimedia/openquicktime/pkg-descr
@@ -1,23 +1,22 @@
-[from developer's site]
OpenQuicktime aims to be a portable library for handling Apple's
-QuickTime (TM) popular media files on Unix-like environments. This
+QuickTime(TM) popular media files on Unix-like environments. This
project was firstly designed to allow the porting of the 3ivx codec
-on any Unix, but is now a completly separate and fully Open Source
+on any Unix, but is now a completely separate and fully Open Source
project. Details:
-o OpenQuicktime library contains no embedded codecs but has a plugin
- system to dynamically load audio and video codecs.
-o OpenQuicktime contains no colorspace conversion algorithm.
-o OpenQuicktime is fully portable and fully configurable with all
- the autoconfigure and automake magic we have been able to add.
-o OpenQuicktime supports compressed headers (decoding only for the
- moment).
-o OpenQuicktime supports Quicktime Sound System version 2.
-o OpenQuicktime can support any inputs and outputs (file, HTTP,
- FTP, RTP, ...), in fact the functions used to read, write and
- seek are overloadable.
-o OpenQuicktime has an overloadable plugin mechanism. This is a
- complexe feature which enables any application to use its own
- codecs instead of the OpenQuicktime ones.
+ - OpenQuicktime library contains no embedded codecs but has a
+ plugin system to dynamically load audio and video codecs.
+ - OpenQuicktime contains no colorspace conversion algorithm.
+ - OpenQuicktime is fully portable and fully configurable with all
+ the autoconfigure and automake magic we have been able to add.
+ - OpenQuicktime supports compressed headers (decoding only for the
+ moment).
+ - OpenQuicktime supports Quicktime Sound System version 2.
+ - OpenQuicktime can support any inputs and outputs (file, HTTP,
+ FTP, RTP, ...), in fact the functions used to read, write and
+ seek are overloadable.
+ - OpenQuicktime has an overloadable plugin mechanism. This is a
+ complex feature which enables any application to use its own
+ codecs instead of the OpenQuicktime ones.
WWW: http://openquicktime.sourceforge.net/