aboutsummaryrefslogtreecommitdiff
path: root/net-im/centericq
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/centericq')
-rw-r--r--net-im/centericq/Makefile37
-rw-r--r--net-im/centericq/distinfo1
-rw-r--r--net-im/centericq/files/patch-aa35
-rw-r--r--net-im/centericq/files/patch-ab22
-rw-r--r--net-im/centericq/files/patch-ac11
-rw-r--r--net-im/centericq/pkg-comment1
-rw-r--r--net-im/centericq/pkg-descr5
-rw-r--r--net-im/centericq/pkg-plist7
8 files changed, 0 insertions, 119 deletions
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
deleted file mode 100644
index f9ce14b3b4a9..000000000000
--- a/net-im/centericq/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# New ports collection makefile for: centericq
-# Date created: 25 December 1999
-# Whom: Chris Piazza <cpiazza@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= centericq
-PORTVERSION= 2.0.0
-CATEGORIES= net
-MASTER_SITES= http://konst.org.ua/download/
-DISTNAME= center-${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 400010
-LIB_DEPENDS= ncurses.4:${PORTSDIR}/devel/ncurses
-CFLAGS+= -nostdinc -I${LOCALBASE}/include/ncurses -I${LOCALBASE}/include\
- -I/usr/include
-.endif
-
-WRKSRC= ${WRKDIR}/center
-USE_GMAKE= yes
-
-post-patch:
- @${PERL} -pi -e 's:__PREFIX__:${PREFIX}:' ${WRKSRC}/centerICQ.cc
-
-pre-build:
- @(cd ${WRKDIR}/ktools/src; ${SETENV} CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" ${GMAKE} ${MAKE_ARGS} )
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/center ${PREFIX}/bin
- @${MKDIR} ${PREFIX}/share/center
- ${INSTALL_DATA} ${WRKSRC}/sound/* ${PREFIX}/share/center
-
-.include <bsd.port.post.mk>
diff --git a/net-im/centericq/distinfo b/net-im/centericq/distinfo
deleted file mode 100644
index a5d14f25c6a1..000000000000
--- a/net-im/centericq/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (center-2.0.0.tar.gz) = c7fe346cdd8a49242fe833c14584023a
diff --git a/net-im/centericq/files/patch-aa b/net-im/centericq/files/patch-aa
deleted file mode 100644
index ab31bf61fe63..000000000000
--- a/net-im/centericq/files/patch-aa
+++ /dev/null
@@ -1,35 +0,0 @@
---- ../ktools/src/Makefile.orig Wed Nov 24 12:22:50 1999
-+++ ../ktools/src/Makefile Sat Dec 25 13:32:33 1999
-@@ -1,15 +1,15 @@
- # macros and variables
-
--CC = gcc
--CPP = g++
-+CC ?= gcc
-+CPP = ${CXX}
- RANLIB = ranlib
-
- INSTDIR = .
- INSTDIR_LIB = $(INSTDIR)
-
--CFLAGS = #-g -Wall -DUNIX
-+CFLAGS += #-g -Wall -DUNIX
-
--INCLUDE = -I/usr/include -I../include
-+INCLUDE = -I../include
- OBJS = konst.fs.o konst.process.o konst.interface.o konst.string.o konst.socket.o konst.parser.o konst.logic.o
-
- #
-@@ -31,10 +31,10 @@
- all: $(LIB)
-
- %.o : %.cc
-- $(CPP) $*.cc -c $(INCLUDE) $(SSLINCL) -o $*.o
-+ $(CPP) ${CXXFLAGS} $*.cc -c $(INCLUDE) $(SSLINCL) -o $*.o
-
- %.o : %.c
-- $(CC) $*.c -c $(INCLUDE) $(SSLINCL) -o $*.o
-+ $(CC) ${CFLAGS} $*.c -c $(INCLUDE) $(SSLINCL) -o $*.o
-
- clean:
- rm -f *.o $(LIB); \
diff --git a/net-im/centericq/files/patch-ab b/net-im/centericq/files/patch-ab
deleted file mode 100644
index ab89c230f19f..000000000000
--- a/net-im/centericq/files/patch-ab
+++ /dev/null
@@ -1,22 +0,0 @@
---- Makefile.orig Sat Dec 25 13:35:19 1999
-+++ Makefile Sat Dec 25 13:36:05 1999
-@@ -1,14 +1,14 @@
- # macros and variables
--CC = gcc
--CPP = g++
-+CC ?= gcc
-+CPP = ${CXX}
-
- PROG1 = center
--CFLAGS = #-g -Wall -DUNIX
-+CFLAGS += #-g -Wall -DUNIX
-
--INCLUDE = -I/usr/include -I../ktools/include
-+INCLUDE = -I../ktools/include
- KTLIBDIR = ../ktools
- LIB = $(KTLIBDIR)/libkonst.a
--LIBDIR = -L/usr/lib -L/usr/local/lib
-+LIBDIR = -L${LOCALBASE}/lib -L${PREFIX}/lib
- OBJS = centerICQ.o centerinfo.o phonebook.o icqlib.o center.o centersearch.o
-
- # targets
diff --git a/net-im/centericq/files/patch-ac b/net-im/centericq/files/patch-ac
deleted file mode 100644
index 44f173e5fad8..000000000000
--- a/net-im/centericq/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- centerICQ.cc.orig Sat Dec 25 13:37:57 1999
-+++ centerICQ.cc Sat Dec 25 13:38:46 1999
-@@ -1680,7 +1680,7 @@
- mkdir(buf, S_IREAD | S_IWRITE | S_IEXEC);
-
- if(QanswerY) {
-- sprintf(fname, "cp /usr/local/lib/center/*.wav %s/.center", getenv("HOME"));
-+ sprintf(fname, "cp __PREFIX__/share/center/*.wav %s/.center", getenv("HOME"));
- system(fname);
- }
-
diff --git a/net-im/centericq/pkg-comment b/net-im/centericq/pkg-comment
deleted file mode 100644
index 967e7ff6fb56..000000000000
--- a/net-im/centericq/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-ICQ client with a useful ncurses menu and window-based interface
diff --git a/net-im/centericq/pkg-descr b/net-im/centericq/pkg-descr
deleted file mode 100644
index 16bdb1dc752f..000000000000
--- a/net-im/centericq/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-A textmode ncurses based window- and menu-driven ICQ client. It is
-fully featured and also includes the ability to associate sounds with
-certain events.
-
-WWW: http://konst.org.ua/software.centericq.html
diff --git a/net-im/centericq/pkg-plist b/net-im/centericq/pkg-plist
deleted file mode 100644
index 59feab2efacf..000000000000
--- a/net-im/centericq/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-bin/center
-share/center/Contact.wav
-share/center/Message.wav
-share/center/Online.wav
-share/center/email.wav
-share/center/url.wav
-@dirrm share/center