aboutsummaryrefslogtreecommitdiff
path: root/net-im/gaim-extprefs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/gaim-extprefs/Makefile')
-rw-r--r--net-im/gaim-extprefs/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-im/gaim-extprefs/Makefile b/net-im/gaim-extprefs/Makefile
new file mode 100644
index 000000000000..39f2e8a8f4d0
--- /dev/null
+++ b/net-im/gaim-extprefs/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gaim-extprefs
+# Date created: 28 November 2005
+# Whom: Victor Semionov <semionov@mail.bg>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gaim-extprefs
+PORTVERSION= 0.5
+CATEGORIES= net-im
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gaim-extprefs
+
+MAINTAINER= semionov@mail.bg
+COMMENT= A gaim plugin that provides additional preferences
+
+BUILD_DEPENDS= ${X11BASE}/include/gaim/config.h:${PORTSDIR}/net-im/gaim
+RUN_DEPENDS= gaim:${PORTSDIR}/net-im/gaim
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_AUTOTOOLS= libtool:15
+
+CONFIGURE_ARGS+=--enable-static=no
+CFLAGS+= "-fPIC"
+
+PLIST_FILES= lib/gaim/libextprefs.so
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/-g3//' ${WRKSRC}/configure
+
+.include <bsd.port.mk>