aboutsummaryrefslogtreecommitdiff
path: root/net-im/gaim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/gaim/Makefile')
-rw-r--r--net-im/gaim/Makefile65
1 files changed, 0 insertions, 65 deletions
diff --git a/net-im/gaim/Makefile b/net-im/gaim/Makefile
deleted file mode 100644
index cd6e4c396fb4..000000000000
--- a/net-im/gaim/Makefile
+++ /dev/null
@@ -1,65 +0,0 @@
-# New ports collection makefile for: gaim
-# Date created: 26 Mar 1999
-# Whom: Jim Mock <jim@FreeBSD.org>
-# $FreeBSD$
-#
-
-PORTNAME= gaim
-PORTVERSION= 0.68
-CATEGORIES?= net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER?= marcus@FreeBSD.org
-COMMENT= Gtk+-2.0 open-source 'clone' of AOL's Instant Messenger client
-
-USE_X_PREFIX= yes
-USE_GMAKE= yes
-USE_REINPLACE= yes
-USE_GNOME= gnomeprefix gnomehack gtk20
-USE_PERL5= yes
-USE_BZIP2= yes
-INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-static=yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-
-MAN1= gaim.1 gaim-remote.1
-
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-CONFIGURE_ARGS+= --disable-perl
-PLIST_SUB+= PERL:="@comment "
-.else
-PLIST_SUB+= PERL:=""
-.endif
-
-.ifndef(WITHOUT_GTKSPELL)
-LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell2
-.else
-CONFIGURE_ARGS+= --disable-gtkspell
-.endif
-
-.ifndef(WITHOUT_AUDIO)
-LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao \
- audiofile.0:${PORTSDIR}/audio/libaudiofile
-.else
-CONFIGURE_ARGS+= --disable-audio
-.endif
-
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Gaim has the following tunable option(s):"
- @${ECHO_MSG} " WITHOUT_GTKSPELL Turns off spell checking"
- @${ECHO_MSG} " WITHOUT_AUDIO Disable audio support"
- @${ECHO_MSG} ""
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthreads|${PTHREAD_LIBS:S/"//g}|g; \
- s|-lpthread|${PTHREAD_LIBS:S/"//g}|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- ${WRKSRC}/configure
-
-.include <bsd.port.post.mk>