aboutsummaryrefslogtreecommitdiff
path: root/net-im/gloox/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/gloox/Makefile')
-rw-r--r--net-im/gloox/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/net-im/gloox/Makefile b/net-im/gloox/Makefile
index b071e4ed5c54..8f39ef88a189 100644
--- a/net-im/gloox/Makefile
+++ b/net-im/gloox/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gloox
PORTVERSION= 1.0.10
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://camaya.net/download/
@@ -14,22 +15,20 @@ LICENSE= GPLv3
LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn \
libgnutls.so:${PORTSDIR}/security/gnutls
-USES= compiler:c++11-lang libtool:keepla pathfix pkgconfig tar:bzip2
-USE_LDCONFIG= yes
+USES= libtool:keepla pathfix pkgconfig tar:bzip2
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 900033
-USE_BINUTILS= yes
-LDFLAGS+= -B${LOCALBASE}/bin
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
- 's|-lgcrypt||' ${WRKSRC}/configure
+ 's| -ansi|| ; \
+ s| -lgcrypt||' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's| -pedantic|| ; \
+ s| -pipe||'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>