aboutsummaryrefslogtreecommitdiff
path: root/net-im/jabber
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/jabber')
-rw-r--r--net-im/jabber/Makefile43
-rw-r--r--net-im/jabber/distinfo2
-rw-r--r--net-im/jabber/files/jabberd.sh27
-rw-r--r--net-im/jabber/files/patch-aa57
-rw-r--r--net-im/jabber/files/patch-ab44
-rw-r--r--net-im/jabber/files/patch-ac11
-rw-r--r--net-im/jabber/files/patch-ad50
-rw-r--r--net-im/jabber/pkg-deinstall71
-rw-r--r--net-im/jabber/pkg-descr11
-rw-r--r--net-im/jabber/pkg-install151
-rw-r--r--net-im/jabber/pkg-plist23
11 files changed, 0 insertions, 490 deletions
diff --git a/net-im/jabber/Makefile b/net-im/jabber/Makefile
deleted file mode 100644
index abae78c09ccd..000000000000
--- a/net-im/jabber/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-# New ports collection makefile for: jabber
-# Date created: 5 February 2001
-# Whom: joe
-#
-# $FreeBSD$
-#
-
-PORTNAME= jabber
-PORTVERSION= 1.4.2
-PORTREVISION= 1
-CATEGORIES= net
-MASTER_SITES= http://jabberd.jabberstudio.org/downloads/ \
- http://download.jabber.org/dists/1.4/final/
-DISTNAME= ${PORTNAME}-${PORTVERSION}
-DIST_SUBDIR= jabber
-
-MAINTAINER= seanc@FreeBSD.org
-COMMENT= Online presence and instant messaging server
-
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_OPENSSL= yes
-USE_PERL5= yes
-
-CONFIGURE_ARGS+= --enable-ssl
-
-rc=${PREFIX}/etc/rc.d
-
-#JABDIR= ${PORTNAME}-${PORTVERSION}
-# Save this data for use later: jabber doesn't have an install target
-# or a sane set of defaults.
-post-patch:
- @echo "${WRKSRC}" > ${WRKSRC}/.wrksrc-freebsd
- @echo "${PREFIX}" > ${WRKSRC}/.prefix-freebsd
- @echo "${INSTALL_DATA}" > ${WRKSRC}/.install_data-freebsd
- @echo "${INSTALL_SCRIPT}" > ${WRKSRC}/.install_script-freebsd
- @echo "${INSTALL_PROGRAM}" > ${WRKSRC}/.install_program-freebsd
-
-post-install:
- @PREFIX=${PREFIX} ${PERL5} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- ${INSTALL_SCRIPT} ${FILESDIR}/jabberd.sh ${rc}
-
-.include <bsd.port.mk>
diff --git a/net-im/jabber/distinfo b/net-im/jabber/distinfo
deleted file mode 100644
index ab9a48722523..000000000000
--- a/net-im/jabber/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (jabber/jabber-1.4.2.tar.gz) = 10780dbdb93926ea5bb360e1186b939c
-SIZE (jabber/jabber-1.4.2.tar.gz) = 690217
diff --git a/net-im/jabber/files/jabberd.sh b/net-im/jabber/files/jabberd.sh
deleted file mode 100644
index d6aa960fb6f6..000000000000
--- a/net-im/jabber/files/jabberd.sh
+++ /dev/null
@@ -1,27 +0,0 @@
-#! /bin/sh
-
-if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/jabberd\.sh\$"); then
- echo "$0: Cannot determine the PREFIX" >&2
- exit 1
-fi
-
-USER="jabber"
-RUNDIR="/var/tmp"
-HOSTNAME=`/bin/hostname`
-
-test -x ${PREFIX}/sbin/jabberd || exit 1
-
-export PATH=/sbin:/bin:/usr/bin:${PREFIX}/bin:${PREFIX}/sbin
-umask 077
-
-echo -n " jabberd "
-cd ${RUNDIR} || exit
-
-case ${1:-start} in
-start)
- su -f -m ${USER} -c "jabberd -B -h ${HOSTNAME} -c ${PREFIX}/etc/jabber.xml" ;;
-
-stop)
- killall -SIGKILL -u ${USER} jabberd;
- rm -f ${RUNDIR}/jabber.pid;
-esac
diff --git a/net-im/jabber/files/patch-aa b/net-im/jabber/files/patch-aa
deleted file mode 100644
index 80239a100c69..000000000000
--- a/net-im/jabber/files/patch-aa
+++ /dev/null
@@ -1,57 +0,0 @@
---- configure.orig Mon Feb 11 11:14:06 2002
-+++ configure Sun Apr 14 18:38:40 2002
-@@ -32,7 +32,8 @@
- LDFLAGS="$LDFLAGS"
- LIBS="$LIBS"
- XLDFLAGS="$XLDFLAGS "
--JHOME=`pwd`
-+JHOME="`cat .prefix-freebsd`/lib/jabber"
-+WRKSRC="`cat .wrksrc-freebsd`"
-
- ##
- # Print a cool header
-@@ -76,31 +77,19 @@
- ##
- # Pth check
- ##
--printf "Getting pth settings..."
--PTH_CFLAGS=`pth-config --cflags`
--PTH_LDFLAGS=`pth-config --ldflags`
--PTH_LIBS=`pth-config --libs`
--PTH_LIBDIR=`pth-config --libdir`
--if [ -n "$PTH_CFLAGS" ]; then
-- CFLAGS="$CFLAGS $PTH_CFLAGS";
-- LDFLAGS="$LDFLAGS $PTH_LDFLAGS";
-- LIBS="$LIBS $PTH_LIBS";
-- SLIBS="$SLIBS $PTH_LIBDIR/libpth.a";
-- printf " Done.\n";
--else
-- if [ -d "jabberd/pth-1.4.0" ]; then
-- opwd=`pwd`
-- cd jabberd/pth-1.4.0;
-- ./configure || (printf "Error Configuring pth"; exit 1);
-- cd $opwd;
-- PSUBDIR="pth-1.4.0";
-- PTHP=`pwd`"/jabberd/pth-1.4.0";
-- PLINK="$PTHP/pth_*.o";
-- CFLAGS="$CFLAGS -I`pwd`/jabberd/pth-1.4.0";
-- else
-- printf " Error.\n\n No version of PTH is available on this system\nhttp://www.gnu.org/software/pth/";
-- fi
--fi
-+echo "Using jabber's internal copy of pth 1.4.0 because 1.4.1 is incompatible"
-+opwd=`pwd`
-+cd jabberd/pth-1.4.0;
-+echo "Configuring jabber pth-1.4.0..."
-+./configure || (echo "Error Configuring pth"; exit 1);
-+echo "Building pth-1.4.0..."
-+gmake
-+cd $opwd;
-+PSUBDIR="pth-1.4.0";
-+PTHP="`pwd`/jabberd/pth-1.4.0";
-+PLINK="$PTHP/pth_*.o";
-+CFLAGS="$CFLAGS -I${PTHP}";
-+LDFLAGS="$LDFLAGS -L${PTHP}";
-
-
-
diff --git a/net-im/jabber/files/patch-ab b/net-im/jabber/files/patch-ab
deleted file mode 100644
index 589e6646ceee..000000000000
--- a/net-im/jabber/files/patch-ab
+++ /dev/null
@@ -1,44 +0,0 @@
---- Makefile.orig Sat Jan 20 21:32:48 2001
-+++ Makefile Sun Apr 14 23:30:36 2002
-@@ -4,6 +4,10 @@
- include platform-settings
-
- SUBDIRS=pthsock xdb_file dnsrv jsm dialback jabberd
-+INSTALL_DATA=`cat .install_data-freebsd`
-+INSTALL_DIR=install -d
-+INSTALL_PROGRAM=`cat .install_program-freebsd`
-+INSTALL_SCRIPT=`cat .install_data-freebsd`
-
- all: all-recursive
-
-@@ -13,8 +17,29 @@
-
- single: single-recursive
-
-+LIBDIR=${PREFIX}/lib/jabber
-+INCDIR=${PREFIX}/include/jabber
- install:
-- printf "\n\nNo actual make install, you just run it out of the directory!\n"
-+ ${INSTALL_PROGRAM} jabberd/jabberd ${PREFIX}/sbin
-+ ${INSTALL_DATA} jabber.xml ${PREFIX}/etc/jabber.xml.sample
-+ ${INSTALL_DIR} ${LIBDIR}/jsm
-+ ${INSTALL_DATA} jsm/jsm.so ${LIBDIR}/jsm
-+ ${INSTALL_DIR} ${LIBDIR}/xdb_file
-+ ${INSTALL_DATA} xdb_file/xdb_file.so ${LIBDIR}/xdb_file
-+ ${INSTALL_DIR} ${LIBDIR}/pthsock
-+ ${INSTALL_DATA} pthsock/pthsock_client.so ${LIBDIR}/pthsock
-+ ${INSTALL_DIR} ${LIBDIR}/dnsrv
-+ ${INSTALL_DATA} dnsrv/dnsrv.so ${LIBDIR}/dnsrv
-+ ${INSTALL_DIR} ${LIBDIR}/dialback
-+ ${INSTALL_DATA} dialback/dialback.so ${LIBDIR}/dialback
-+ ${INSTALL_DIR} ${INCDIR}
-+ ${INSTALL_DATA} platform-settings ${INCDIR}
-+ ${INSTALL_DATA} jabberd/jabberd.h ${INCDIR}
-+ ${INSTALL_DIR} ${INCDIR}/lib
-+ ${INSTALL_DATA} jabberd/lib/lib.h ${INCDIR}/lib
-+ ${INSTALL_DATA} jabberd/lib/xmlparse.h ${INCDIR}/lib
-+ ${INSTALL_DATA} jabberd/pth-1.4.0/pth.h ${INCDIR}
-+
-
- all-local:
-
diff --git a/net-im/jabber/files/patch-ac b/net-im/jabber/files/patch-ac
deleted file mode 100644
index 45e15e08afaa..000000000000
--- a/net-im/jabber/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- jabber.xml.orig Sat Feb 3 22:46:56 2001
-+++ jabber.xml Sun Feb 11 01:19:01 2001
-@@ -576,7 +576,7 @@
- <!--
- This specifies the file to store the pid of the process in.
- -->
-- <pidfile>./jabber.pid</pidfile>
-+ <pidfile>/var/tmp/jabber.pid</pidfile>
-
-
- </jabber>
diff --git a/net-im/jabber/files/patch-ad b/net-im/jabber/files/patch-ad
deleted file mode 100644
index 63266c9a12eb..000000000000
--- a/net-im/jabber/files/patch-ad
+++ /dev/null
@@ -1,50 +0,0 @@
---- jabber.xml.orig Sun Feb 11 17:24:48 2001
-+++ jabber.xml Sun Feb 11 17:26:23 2001
-@@ -41,6 +41,10 @@
- Multiple <host/> entries are allowed - each one is for a
- separate virtual server. Note that each host entry must
- be on one line, the server doesn't like it otherwise! :)
-+
-+ Currently on FreeBSD jabberd is started with the -h option
-+ from /usr/local/etc/rc.d/jabberd.sh. You'll need to modify
-+ this before changing below.
- -->
-
- <host><jabberd:cmdline flag="h">localhost</jabberd:cmdline></host>
-@@ -193,7 +197,9 @@
- entry for <host/> above.
- -->
-
-+ <!--
- <update><jabberd:cmdline flag="h">localhost</jabberd:cmdline></update>
-+ -->
-
- <!--
- This enables the server to automatically update the
-@@ -298,7 +304,7 @@
- <xdb_file>./xdb_file/xdb_file.so</xdb_file>
- </load>
- <xdb_file xmlns="jabber:config:xdb_file">
-- <spool><jabberd:cmdline flag='s'>./spool</jabberd:cmdline></spool>
-+ <spool><jabberd:cmdline flag='s'>/var/spool/jabber</jabberd:cmdline></spool>
- </xdb_file>
- </xdb>
-
-@@ -357,7 +363,7 @@
- <host/>
- <logtype/>
- <format>%d: [%t] (%h): %s</format>
-- <file>error.log</file>
-+ <file>/var/log/jabber.error</file>
- <stderr/>
- </log>
-
-@@ -370,7 +376,7 @@
- <host/>
- <logtype>record</logtype>
- <format>%d %h %s</format>
-- <file>record.log</file>
-+ <file>/var/log/jabber.record</file>
- </log>
-
- <!-- The following two services are for handling server-to-server traffic. -->
diff --git a/net-im/jabber/pkg-deinstall b/net-im/jabber/pkg-deinstall
deleted file mode 100644
index 7c67ecc0cca6..000000000000
--- a/net-im/jabber/pkg-deinstall
+++ /dev/null
@@ -1,71 +0,0 @@
-#! /bin/sh
-
-ask() {
- local question default answer
-
- question=$1
- default=$2
- if [ -z "${PACKAGE_BUILDING}" ]; then
- read -p "${question} [${default}]? " answer
- fi
- if [ x${answer} = x ]; then
- answer=${default}
- fi
- echo ${answer}
-}
-
-yesno() {
- local dflt question answer
-
- question=$1
- dflt=$2
- while :; do
- answer=$(ask "${question}" "${dflt}")
- case "${answer}" in
- [Yy]*) return 0;;
- [Nn]*) return 1;;
- esac
- echo "Please answer yes or no."
- done
-}
-
-delete_account() {
- local u g home
-
- u=$1
- g=$2
- if yesno "Do you want me to remove group \"${g}\"" y; then
- pw groupdel -n ${g}
- echo "Done."
- fi
- if yesno "Do you want me to remove user \"${u}\"" y; then
- eval home=~${u}
- pw userdel -n ${u}
- echo "Done."
- if [ -d "${home}" ]; then
- echo "Please remember to remove the home directory \"${home}\" as"
- echo "well as the mirrored files."
- fi
- fi
-}
-
-if [ x$2 != xDEINSTALL ]; then
- exit
-fi
-
-export PATH=/bin:/usr/bin:/usr/sbin
-
-USER=jabber
-GROUP=jabber
-
-if ps -axc | grep -q jabberd; then
- if yesno "There are some jabberd processes running. Shall I kill them" y
- then
- killall -SIGKILL -u ${USER} jabberd
- sleep 2
- else
- echo "OK ... I hope you know what you are doing."
- fi
-fi
-
-delete_account ${USER} ${GROUP}
diff --git a/net-im/jabber/pkg-descr b/net-im/jabber/pkg-descr
deleted file mode 100644
index 7767352059ef..000000000000
--- a/net-im/jabber/pkg-descr
+++ /dev/null
@@ -1,11 +0,0 @@
-The Jabber server (jabberd) is a daemon for Jabber clients to connect
-and communicate with.
-
-After editing $PREFIX/etc/jabber.xml, the server can be started by
-rc.d script.
-
-Complete information about configuration can be found in the Jabber Server
-mini-HOWTO at http://www.jabber.org/admin/.
-
-You can learn more about Jabber at
-WWW: http://www.jabber.org/
diff --git a/net-im/jabber/pkg-install b/net-im/jabber/pkg-install
deleted file mode 100644
index 7714ddb1d21a..000000000000
--- a/net-im/jabber/pkg-install
+++ /dev/null
@@ -1,151 +0,0 @@
-#! /bin/sh
-
-chmods_done=" "
-
-ask() {
- local question default answer
-
- question=$1
- default=$2
- if [ -z "${PACKAGE_BUILDING}" ]; then
- read -p "${question} [${default}]? " answer
- fi
- if [ x${answer} = x ]; then
- answer=${default}
- fi
- echo ${answer}
-}
-
-yesno() {
- local dflt question answer
-
- question=$1
- dflt=$2
- while :; do
- answer=$(ask "${question}" "${dflt}")
- case "${answer}" in
- [Yy]*) return 0;;
- [Nn]*) return 1;;
- esac
- echo "Please answer yes or no."
- done
-}
-
-make_account() {
- local u g gcos homeopt home
-
- u=$1
- g=$2
- gcos=$3
- homeopt=${4:+"-d $4"}
-
- if pw group show "${g}" >/dev/null 2>&1; then
- echo "You already have a group \"${g}\", so I will use it."
- else
- echo "You need a group \"${g}\"."
- if which -s pw && yesno "Would you like me to create it" y; then
- pw groupadd ${g} || exit
- echo "Done."
- else
- echo "Please create it, and try again."
- if ! grep -q "^${u}:" /etc/passwd; then
- echo "While you're at it, please create a user \"${u}\" too,"
- echo "with a default group of \"${g}\"."
- fi
- exit 1
- fi
- fi
-
- if pw user show "${u}" >/dev/null 2>&1; then
- echo "You already have a user \"${u}\", so I will use it."
- else
- echo "You need a user \"${u}\"."
- if which -s pw && yesno "Would you like me to create it" y; then
- pw useradd ${u} -g ${g} -h - ${homeopt} \
- -s /nonexistent -c "${gcos}" || exit
- echo "Done."
- else
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
- if [ x"$homeopt" = x ]; then
- eval home=~${u}
- if [ ! -d "${home}" ]; then
- if yesno \
- "Would you like me to create ${u}'s home directory (${home})" y
- then
- (umask 77 && \
- mkdir -p ${home}) || exit
- chown -R ${u}:${g} ${home} || exit
- else
- echo "Please create it, and try again."
- exit 1
- fi
- fi
- fi
-}
-
-case $2 in
-
-POST-INSTALL)
- if which -s pw && which -s lockf; then
- :
- else
- cat <<EOF
-
-This system looks like a pre-2.2 version of FreeBSD. I see that it
-is missing the "lockf" and/or "pw" utilities. I need these utilities.
-Please get them and install them, and try again. You can get the
-sources from:
-
- ftp://ftp.freebsd.org/pub/FreeBSD/FreeBSD-current/src/usr.bin/lockf.tar.gz
- ftp://ftp.freebsd.org/pub/FreeBSD/FreeBSD-current/src/usr.sbin/pw.tar.gz
-
-EOF
- exit 1
- fi
-
- user=jabber
- group=jabber
- spooldir="/var/spool/jabber"
- etcdir=${PREFIX:-$PKG_PREFIX}/etc
-
- echo ""
- make_account ${user} ${group} "Jabber Daemon" "/nonexistent"
-
- if [ ! -d ${spooldir} ]; then
- echo "Creating \"${spooldir}\"."
- mkdir -p ${spooldir}
- fi
-
- echo "Fixing ownerships and modes in \"${spooldir}\"."
- chown -R ${user}:${group} ${spooldir}
- chmod -R go= ${spooldir}
-
- if [ ! -f ${etcdir}/jabber.xml ]; then
- echo "Creating \"${etcdir}/jabber.xml\"."
- cp -p ${etcdir}/jabber.xml.sample ${etcdir}/jabber.xml
- fi
-
- echo "Fixing config files ownerships and modes."
- chown root:${group} ${etcdir}/jabber.xml ${etcdir}/jabber.xml.sample
- chmod 640 ${etcdir}/jabber.xml ${etcdir}/jabber.xml.sample
-
- if [ ! -f /var/log/jabber.error ]; then
- echo "Creating \"/var/log/jabber.error\"."
- cp /dev/null /var/log/jabber.error
- fi
-
- if [ ! -f /var/log/jabber.record ]; then
- echo "Creating \"/var/log/jabber.record\"."
- cp /dev/null /var/log/jabber.record
- fi
-
- echo "Fixing log files ownerships and modes."
- chown ${user}:${group} /var/log/jabber.error /var/log/jabber.record
- chmod 640 /var/log/jabber.error /var/log/jabber.record
-
- ;;
-esac
diff --git a/net-im/jabber/pkg-plist b/net-im/jabber/pkg-plist
deleted file mode 100644
index 14a96c279805..000000000000
--- a/net-im/jabber/pkg-plist
+++ /dev/null
@@ -1,23 +0,0 @@
-sbin/jabberd
-@unexec if cmp -s %D/etc/jabber.xml.sample %D/etc/jabber.xml; then rm -f %D/etc/jabber.xml; fi
-etc/jabber.xml.sample
-etc/rc.d/jabberd.sh
-include/jabber/lib/lib.h
-include/jabber/lib/xmlparse.h
-include/jabber/platform-settings
-include/jabber/jabberd.h
-include/jabber/pth.h
-lib/jabber/dialback/dialback.so
-lib/jabber/dnsrv/dnsrv.so
-lib/jabber/jsm/jsm.so
-lib/jabber/pthsock/pthsock_client.so
-lib/jabber/xdb_file/xdb_file.so
-@dirrm include/jabber/lib
-@dirrm include/jabber
-@dirrm lib/jabber/dialback
-@dirrm lib/jabber/dnsrv
-@dirrm lib/jabber/jsm
-@dirrm lib/jabber/pthsock
-@dirrm lib/jabber/xdb_file
-@dirrm lib/jabber
-@unexec rmdir /var/spool/jabber 2>/dev/null || true