aboutsummaryrefslogtreecommitdiff
path: root/net-im/kde-telepathy
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/kde-telepathy')
-rw-r--r--net-im/kde-telepathy/Makefile44
-rw-r--r--net-im/kde-telepathy/pkg-descr7
2 files changed, 51 insertions, 0 deletions
diff --git a/net-im/kde-telepathy/Makefile b/net-im/kde-telepathy/Makefile
new file mode 100644
index 000000000000..7a80217a0eb4
--- /dev/null
+++ b/net-im/kde-telepathy/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= kde-telepathy
+PORTVERSION= ${KTP_VERSION}
+CATEGORIES= net-im kde
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= avilla@FreeBSD.org
+COMMENT= KDE integrated instant messaging framework
+
+RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/kcm_ktp_accounts.so:${PORTSDIR}/net-im/ktp-accounts-kcm \
+ ${KDE4_PREFIX}/lib/kde4/kded_ktp_approver.so:${PORTSDIR}/net-im/ktp-approver \
+ ${KDE4_PREFIX}/lib/kde4/libexec/ktp-auth-handler:${PORTSDIR}/net-im/ktp-auth-handler \
+ ${KDE4_PREFIX}/bin/ktp-contactlist:${PORTSDIR}/net-im/ktp-contact-list \
+ ${KDE4_PREFIX}/lib/kde4/krunner_ktp_contacts.so:${PORTSDIR}/net-im/ktp-contact-runner \
+ ${KDE4_PREFIX}/lib/kde4/libexec/ktp-filetransfer-handler:${PORTSDIR}/net-im/ktp-filetransfer-handler \
+ ${KDE4_PREFIX}/lib/kde4/kded_ktp_integration_module.so:${PORTSDIR}/net-im/ktp-kded-integration-module \
+ ${KDE4_PREFIX}/lib/kde4/libexec/ktp-text-ui:${PORTSDIR}/net-im/ktp-text-ui
+
+USE_KDE4= kdeprefix
+NO_BUILD= yes
+
+OPTIONS_DEFINE= PLASMA SEND_FILE
+OPTIONS_DEFAULT=PLASMA SEND_FILE
+
+PLASMA_DESC= Applets for KDE Plasma Desktop integration
+SEND_FILE_DESC= Context menu plugin for sending files
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPLASMA}
+RUN_DEPENDS+= ${KDE4_PREFIX}/lib/kde4/plasma_applet_ktp_presence.so:${PORTSDIR}/net-im/plasma-applet-ktp
+.endif
+
+.if ${PORT_OPTIONS:MSEND_FILE}
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/ktp-send-file:${PORTSDIR}/net-im/ktp-send-file
+.endif
+
+do-install:
+ @${DO_NADA}
+
+.include <bsd.port.mk>
diff --git a/net-im/kde-telepathy/pkg-descr b/net-im/kde-telepathy/pkg-descr
new file mode 100644
index 000000000000..821717164e72
--- /dev/null
+++ b/net-im/kde-telepathy/pkg-descr
@@ -0,0 +1,7 @@
+The KDE Telepathy project aims to integrate real time communication
+deeply into KDE Workspaces, and to provide an infrastructure to aid
+development of collaborative features for KDE Applications.
+
+This is the meta-port grouping all the components.
+
+WWW: http://community.kde.org/KTp