aboutsummaryrefslogtreecommitdiff
path: root/net-im/p5-Net-XMPP
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/p5-Net-XMPP')
-rw-r--r--net-im/p5-Net-XMPP/Makefile38
-rw-r--r--net-im/p5-Net-XMPP/distinfo2
-rw-r--r--net-im/p5-Net-XMPP/pkg-descr11
-rw-r--r--net-im/p5-Net-XMPP/pkg-plist18
4 files changed, 69 insertions, 0 deletions
diff --git a/net-im/p5-Net-XMPP/Makefile b/net-im/p5-Net-XMPP/Makefile
new file mode 100644
index 000000000000..310bcc910f28
--- /dev/null
+++ b/net-im/p5-Net-XMPP/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: p5-Net-XMPP
+# Date created: 2004-12-3
+# Whom: Lars Eggert <lars.eggert@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-XMPP
+PORTVERSION= 1.0
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars.eggert@gmx.net
+COMMENT= Net::XMPP provides Perl Developer access to the XMPP protocol
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/Stream.pm:${PORTSDIR}/textproc/p5-XML-Stream \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::XMPP.3 Net::XMPP::Client.3 Net::XMPP::Connection.3 \
+ Net::XMPP::Debug.3 Net::XMPP::IQ.3 Net::XMPP::JID.3 \
+ Net::XMPP::Message.3 Net::XMPP::Namespaces.3 \
+ Net::XMPP::Presence.3 Net::XMPP::PrivacyLists.3 \
+ Net::XMPP::Protocol.3 Net::XMPP::Roster.3 \
+ Net::XMPP::Stanza.3
+
+.include <bsd.port.pre.mk>
+
+# Require perl 5.8.x due to XML::Stream
+.if ${PERL_LEVEL} < 500800
+IGNORE= Port requires perl 5.8.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-im/p5-Net-XMPP/distinfo b/net-im/p5-Net-XMPP/distinfo
new file mode 100644
index 000000000000..4b3dc2e48c02
--- /dev/null
+++ b/net-im/p5-Net-XMPP/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-XMPP-1.0.tar.gz) = 6338484aa0d394e68c01666ca34e5241
+SIZE (Net-XMPP-1.0.tar.gz) = 96081
diff --git a/net-im/p5-Net-XMPP/pkg-descr b/net-im/p5-Net-XMPP/pkg-descr
new file mode 100644
index 000000000000..db9d9be69059
--- /dev/null
+++ b/net-im/p5-Net-XMPP/pkg-descr
@@ -0,0 +1,11 @@
+The Extensible Messaging and Presence Protocol (XMPP) is an IETF standard
+that provides a complete cross protocol messaging solution. The problem
+with current IM solutions is that they are all proprietary and cannot
+talk to each other. XMPP seeks to get rid of those barriers.
+
+Net::XMPP is a collection of Perl modules that provide a Perl Developer
+access to the XMPP protocol. Using OOP modules we provide a clean
+interface to writing anything from a full client to a simple protocol
+tester.
+
+WWW: http://www.xmpp.org/
diff --git a/net-im/p5-Net-XMPP/pkg-plist b/net-im/p5-Net-XMPP/pkg-plist
new file mode 100644
index 000000000000..ac6e30beec51
--- /dev/null
+++ b/net-im/p5-Net-XMPP/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/Net/XMPP.pm
+%%SITE_PERL%%/Net/XMPP/Client.pm
+%%SITE_PERL%%/Net/XMPP/Connection.pm
+%%SITE_PERL%%/Net/XMPP/Debug.pm
+%%SITE_PERL%%/Net/XMPP/IQ.pm
+%%SITE_PERL%%/Net/XMPP/JID.pm
+%%SITE_PERL%%/Net/XMPP/Message.pm
+%%SITE_PERL%%/Net/XMPP/Namespaces.pm
+%%SITE_PERL%%/Net/XMPP/Presence.pm
+%%SITE_PERL%%/Net/XMPP/PrivacyLists.pm
+%%SITE_PERL%%/Net/XMPP/Protocol.pm
+%%SITE_PERL%%/Net/XMPP/Roster.pm
+%%SITE_PERL%%/Net/XMPP/Stanza.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/XMPP/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/XMPP
+@unexec rmdir %D/%%SITE_PERL%%/mach/auto/Net 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Net/XMPP
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true