aboutsummaryrefslogtreecommitdiff
path: root/net-im/pidgin-latex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/pidgin-latex/Makefile')
-rw-r--r--net-im/pidgin-latex/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/net-im/pidgin-latex/Makefile b/net-im/pidgin-latex/Makefile
index 43ec88c0db78..6fb2b042cea8 100644
--- a/net-im/pidgin-latex/Makefile
+++ b/net-im/pidgin-latex/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: Gaim-LaTeX
+# New ports collection makefile for: Pidgin-LaTeX
# Date created: 2005-06-22
# Whom: Geoffrey Mainland <mainland@apeiron.net>
#
@@ -6,31 +6,32 @@
#
PORTNAME= latex
-PORTVERSION= 0.3
-PORTREVISION= 6
+PORTVERSION= 1.0
CATEGORIES= net-im
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
-PKGNAMEPREFIX= gaim-
+PKGNAMEPREFIX= pidgin-
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= mainland@apeiron.net
COMMENT= Display LaTeX output in your IMs
-BUILD_DEPENDS= ${LOCALBASE}/include/gaim/config.h:${PORTSDIR}/net-im/gaim
-RUN_DEPENDS= gaim:${PORTSDIR}/net-im/gaim \
+BUILD_DEPENDS= ${LOCALBASE}/include/pidgin/pidgin.h:${PORTSDIR}/net-im/pidgin
+RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin \
latex:${PORTSDIR}/print/teTeX \
convert:${PORTSDIR}/graphics/ImageMagick
+WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME}
+
CFLAGS+= "-fPIC"
USE_XLIB= yes
USE_GMAKE= yes
USE_GNOME= gtk20
USE_BZIP2= yes
-PLIST_FILES= lib/gaim/LaTeX.so
+PLIST_FILES= lib/pidgin/LaTeX.so
do-install:
- ${INSTALL_DATA} ${WRKSRC}/LaTeX.so ${PREFIX}/lib/gaim
+ ${INSTALL_DATA} ${WRKSRC}/LaTeX.so ${PREFIX}/lib/pidgin
.include <bsd.port.mk>