aboutsummaryrefslogtreecommitdiff
path: root/net-im/pidgin-latex
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/pidgin-latex')
-rw-r--r--net-im/pidgin-latex/Makefile17
-rw-r--r--net-im/pidgin-latex/distinfo6
-rw-r--r--net-im/pidgin-latex/files/patch-LaTeX.c17
-rw-r--r--net-im/pidgin-latex/pkg-descr4
4 files changed, 14 insertions, 30 deletions
diff --git a/net-im/pidgin-latex/Makefile b/net-im/pidgin-latex/Makefile
index 43ec88c0db78..6fb2b042cea8 100644
--- a/net-im/pidgin-latex/Makefile
+++ b/net-im/pidgin-latex/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: Gaim-LaTeX
+# New ports collection makefile for: Pidgin-LaTeX
# Date created: 2005-06-22
# Whom: Geoffrey Mainland <mainland@apeiron.net>
#
@@ -6,31 +6,32 @@
#
PORTNAME= latex
-PORTVERSION= 0.3
-PORTREVISION= 6
+PORTVERSION= 1.0
CATEGORIES= net-im
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
-PKGNAMEPREFIX= gaim-
+PKGNAMEPREFIX= pidgin-
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= mainland@apeiron.net
COMMENT= Display LaTeX output in your IMs
-BUILD_DEPENDS= ${LOCALBASE}/include/gaim/config.h:${PORTSDIR}/net-im/gaim
-RUN_DEPENDS= gaim:${PORTSDIR}/net-im/gaim \
+BUILD_DEPENDS= ${LOCALBASE}/include/pidgin/pidgin.h:${PORTSDIR}/net-im/pidgin
+RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin \
latex:${PORTSDIR}/print/teTeX \
convert:${PORTSDIR}/graphics/ImageMagick
+WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME}
+
CFLAGS+= "-fPIC"
USE_XLIB= yes
USE_GMAKE= yes
USE_GNOME= gtk20
USE_BZIP2= yes
-PLIST_FILES= lib/gaim/LaTeX.so
+PLIST_FILES= lib/pidgin/LaTeX.so
do-install:
- ${INSTALL_DATA} ${WRKSRC}/LaTeX.so ${PREFIX}/lib/gaim
+ ${INSTALL_DATA} ${WRKSRC}/LaTeX.so ${PREFIX}/lib/pidgin
.include <bsd.port.mk>
diff --git a/net-im/pidgin-latex/distinfo b/net-im/pidgin-latex/distinfo
index 3b10f941e2e8..bb3043d1ab6a 100644
--- a/net-im/pidgin-latex/distinfo
+++ b/net-im/pidgin-latex/distinfo
@@ -1,3 +1,3 @@
-MD5 (gaim-latex-0.3.tar.bz2) = e0ff7686b3e40a8f2e456785b0557a29
-SHA256 (gaim-latex-0.3.tar.bz2) = e7742ebd216bd7414525ba074f828e43db3093807e4c506e5a002f45855f84e4
-SIZE (gaim-latex-0.3.tar.bz2) = 12903
+MD5 (pidgin-latex-1.0.tar.bz2) = 35bd42017864823af2f79854a749990d
+SHA256 (pidgin-latex-1.0.tar.bz2) = 1aa76082ac29efa4325e617f0077528b6845c14fd4a2b049e8996afec66698ec
+SIZE (pidgin-latex-1.0.tar.bz2) = 15814
diff --git a/net-im/pidgin-latex/files/patch-LaTeX.c b/net-im/pidgin-latex/files/patch-LaTeX.c
deleted file mode 100644
index a09cfc364416..000000000000
--- a/net-im/pidgin-latex/files/patch-LaTeX.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- LaTeX.c.orig Sun Jul 3 11:23:45 2005
-+++ LaTeX.c Sun Jul 3 11:24:29 2005
-@@ -77,13 +77,13 @@
-
- while(ptr1 != NULL)
- {
-- retro = FALSE;
- char *tex, *message, *idstring;
- gchar *name, *buf;
- char *filedata;
- size_t size;
- GError *error = NULL;
- char *filter;
-+ retro = FALSE;
-
- pos1 = strlen(*tmp2) - strlen(ptr1);
-
diff --git a/net-im/pidgin-latex/pkg-descr b/net-im/pidgin-latex/pkg-descr
index 46c46e0e7ddb..0b6c45fcc876 100644
--- a/net-im/pidgin-latex/pkg-descr
+++ b/net-im/pidgin-latex/pkg-descr
@@ -1,4 +1,4 @@
-This is a plugin for Gaim that allows you to display LaTeX output in
+This is a plugin for Pidgin that allows you to display LaTeX output in
your IMs.
-WWW: http://sourceforge.net/projects/gaim-latex
+WWW: http://sourceforge.net/projects/pidgin-latex