aboutsummaryrefslogtreecommitdiff
path: root/net-im/pidgin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/pidgin/Makefile')
-rw-r--r--net-im/pidgin/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/net-im/pidgin/Makefile b/net-im/pidgin/Makefile
index 8ddb86ef7c53..4904c722aecd 100644
--- a/net-im/pidgin/Makefile
+++ b/net-im/pidgin/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= marcus@FreeBSD.org
COMMENT= Pidgin multi-protocol messaging client (GTK+ UI)
LIB_DEPENDS= startup-notification-1.0:${PORTSDIR}/x11/startup-notification \
- purple.3:${PORTSDIR}/net-im/libpurple
+ purple.4:${PORTSDIR}/net-im/libpurple
MASTERDIR= ${.CURDIR}/../libpurple
BUILD_WRKSRC= ${WRKSRC}/pidgin
@@ -30,4 +30,13 @@ USE_GNOME= gnomeprefix gnomehack intlhack gtk20
WANT_GNOME= yes
CONFIGURE_ARGS= --disable-consoleui
+post-build:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ Makefile ${MAKE_ARGS} pidgin.desktop
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/pidgin.desktop \
+ ${PREFIX}/share/applications/pidgin.desktop
+
.include "${MASTERDIR}/Makefile"