aboutsummaryrefslogtreecommitdiff
path: root/net-im/py-xmpppy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/py-xmpppy/Makefile')
-rw-r--r--net-im/py-xmpppy/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-im/py-xmpppy/Makefile b/net-im/py-xmpppy/Makefile
new file mode 100644
index 000000000000..cb16cfca2edc
--- /dev/null
+++ b/net-im/py-xmpppy/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: py-xmpppy
+# Date created: 21 April 2006
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmpppy
+PORTVERSION= 0.3.1
+CATEGORIES= net-im python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= A Python library that provides easy scripting with Jabber
+
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS= yes
+
+post-patch:
+ @${GREP} -lr '/usr/bin/python' ${WRKSRC} | \
+ ${XARGS} ${REINPLACE_CMD} -e "s.^#!/usr/bin/python.#!${PYTHON_CMD}."
+
+.include <bsd.port.mk>