aboutsummaryrefslogtreecommitdiff
path: root/net-im/sim-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/sim-im')
-rw-r--r--net-im/sim-im/Makefile66
-rw-r--r--net-im/sim-im/distinfo2
-rw-r--r--net-im/sim-im/files/patch-configure10
-rw-r--r--net-im/sim-im/files/patch-sim-api-fetch.cpp11
-rw-r--r--net-im/sim-im/files/patch-weather.cpp22
-rw-r--r--net-im/sim-im/pkg-descr17
-rw-r--r--net-im/sim-im/pkg-plist142
7 files changed, 0 insertions, 270 deletions
diff --git a/net-im/sim-im/Makefile b/net-im/sim-im/Makefile
deleted file mode 100644
index 588d8466f5a8..000000000000
--- a/net-im/sim-im/Makefile
+++ /dev/null
@@ -1,66 +0,0 @@
-# New Ports Collection Makefile for: sim-icq
-# Date created: 4 Nov 2002
-# Whom: Josef El-Rayes <j.el-rayes@daemon.li>
-#
-# $FreeBSD$
-
-PORTNAME= simicq
-PORTVERSION= 0.9.3
-PORTREVISION= 3
-CATEGORIES= net kde
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME:S/mi/m-i/}
-DISTNAME= ${PORTNAME:S/icq//}-${PORTVERSION}-2
-
-MAINTAINER= markus@FreeBSD.org
-COMMENT= Plugin-based instant messenger
-
-LIB_DEPENDS= xslt.2:${PORTSDIR}/textproc/libxslt
-
-WRKSRC= ${WRKDIR}/${DISTNAME:S/-2//}
-USE_GMAKE= yes
-USE_QT_VER= 3
-USE_PERL5_BUILD= yes
-GNU_CONFIGURE= yes
-USE_REINPLACE= yes
-INSTALLS_SHLIB= yes
-
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
-.if !defined(WITHOUT_SSL)
-USE_OPENSSL= yes
-PLIST_SUB+= SSL=""
-.else
-CONFIGURE_ARGS+=--disable-openssl
-PLIST_SUB+= SSL="@comment "
-.endif
-
-.if defined(WITHOUT_KDE)
-CONFIGURE_ARGS+=--disable-kde --enable-mt
-LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
-PLIST_SUB+= KDE="@comment " \
- SPELL=""
-.else
-USE_KDELIBS_VER=3
-PLIST_SUB+= KDE="" \
- SPELL="@comment "
-.endif
-
-pre-everything::
-.if !defined(WITHOUT_SSL)
- @${ECHO_MSG} "You can disable SSL support by defining WITHOUT_SSL."
-.endif
-.if !defined(WITHOUT_KDE)
- @${ECHO_MSG} "You can disable KDE support by defining WITHOUT_KDE."
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's/-O2//g; s/-lpthread/${PTHREAD_LIBS}/g' \
- ${CONFIGURE_WRKSRC}/configure
-
-post-configure:
-.if defined(WITHOUT_SSL)
- @${REINPLACE_CMD} -e 's|plugins/yahoo||g' ${WRKSRC}/Makefile
-.endif
-
-.include <bsd.port.mk>
diff --git a/net-im/sim-im/distinfo b/net-im/sim-im/distinfo
deleted file mode 100644
index 2f8dac231a3f..000000000000
--- a/net-im/sim-im/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (sim-0.9.3-2.tar.gz) = b16e462076540acc13da81832ae79d00
-SIZE (sim-0.9.3-2.tar.gz) = 3728770
diff --git a/net-im/sim-im/files/patch-configure b/net-im/sim-im/files/patch-configure
deleted file mode 100644
index dc006c222265..000000000000
--- a/net-im/sim-im/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Tue Nov 4 09:52:54 2003
-+++ configure Tue Nov 4 09:53:21 2003
-@@ -19002,6 +19002,7 @@
- ;;
- freebsd*)
- CPPFLAGS="$CPPFLAGS -D_THREAD_SAFE"
-+ LIBS="$LIBS -lpthread"
- echo "Setting FreeBSD pthread compilation options"
- ;;
- aix*)
diff --git a/net-im/sim-im/files/patch-sim-api-fetch.cpp b/net-im/sim-im/files/patch-sim-api-fetch.cpp
deleted file mode 100644
index 982bc837c1dd..000000000000
--- a/net-im/sim-im/files/patch-sim-api-fetch.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- sim/api/fetch.cpp.orig Fri Oct 15 01:17:45 2004
-+++ sim/api/fetch.cpp Fri Oct 15 01:21:31 2004
-@@ -24,6 +24,8 @@
- #include <qthread.h>
- #include <qtimer.h>
-
-+#include <time.h>
-+
- typedef map<my_string, string> HEADERS_MAP;
-
- class FetchThread;
diff --git a/net-im/sim-im/files/patch-weather.cpp b/net-im/sim-im/files/patch-weather.cpp
deleted file mode 100644
index 34f44292749c..000000000000
--- a/net-im/sim-im/files/patch-weather.cpp
+++ /dev/null
@@ -1,22 +0,0 @@
---- plugins/weather/weather.cpp.orig Fri Apr 2 12:21:54 2004
-+++ plugins/weather/weather.cpp Fri Apr 2 12:23:55 2004
-@@ -534,8 +534,8 @@
- res = res.replace(QRegExp("\\%h"), number(getHumidity()) + "%");
- res = res.replace(QRegExp("\\%w"), number(getWind_speed()) + " " + i18n(getUS()));
- res = res.replace(QRegExp("\\%x"), QString::number(getWind_speed() * 10 / 36) + " " + i18n("m/s"));
-- res = res.replace(QRegExp("\\%g"), getWindGust() ? QString("(") + i18n("gust ") + number(getWindGust()) + i18n(getUS()) + ")" : "");
-- res = res.replace(QRegExp("\\%y"), getWindGust() ? QString("(") + i18n("gust ") + number(getWindGust() * 10 / 36) + " " + i18n("m/s") + ")" : "");
-+ res = res.replace(QRegExp("\\%g"), getWindGust() ? QString("(") + i18n("gust ") + number(getWindGust()) + i18n(getUS()) + ")" : QString(""));
-+ res = res.replace(QRegExp("\\%y"), getWindGust() ? QString("(") + i18n("gust ") + number(getWindGust() * 10 / 36) + " " + i18n("m/s") + ")" : QString(""));
- res = res.replace(QRegExp("\\%p"), number(getPressure()) + " " + i18n(getUP()));
- res = res.replace(QRegExp("\\%a"), number(getPressure() * 75 / 100));
- res = res.replace(QRegExp("\\%q"), i18n("weather", getPressureD()));
-@@ -545,7 +545,7 @@
- res = res.replace(QRegExp("\\%r"), getSun_raise());
- res = res.replace(QRegExp("\\%s"), getSun_set());
- res = res.replace(QRegExp("\\%c"), i18n_conditions(getConditions()));
-- res = res.replace(QRegExp("\\%v"), i18n("weather", getVisibility()) + (atol(getVisibility()) ? QString(" ") + i18n(getUD()) : ""));
-+ res = res.replace(QRegExp("\\%v"), i18n("weather", getVisibility()) + (atol(getVisibility()) ? QString(" ") + i18n(getUD()) : QString("")));
- return res;
- }
-
diff --git a/net-im/sim-im/pkg-descr b/net-im/sim-im/pkg-descr
deleted file mode 100644
index d360feb72d62..000000000000
--- a/net-im/sim-im/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-SIM (Simple Instant Messenger) is a plugin-based instant messenger with
-support for various protocols (QT is needed, can be build for KDE).
-
-All protocols support richtext-messages, file transfer, typing notification,
-server-side contact list (with postponed synchronization - you can change
-contact list in offline mode and after log on all changes will be
-synchronized with server), new account registration and various searches.
-You can use several accounts for each protocol.
-
-Supported protocols:
- * Oscar - ICQ and AIM support
- * Jabber
- * MSN
- * Yahoo!
- * LiveJournal
-
-WWW: http://sim-icq.sourceforge.net/
diff --git a/net-im/sim-im/pkg-plist b/net-im/sim-im/pkg-plist
deleted file mode 100644
index 4555cb2b01a5..000000000000
--- a/net-im/sim-im/pkg-plist
+++ /dev/null
@@ -1,142 +0,0 @@
-bin/sim
-bin/simctrl
-lib/libsimapi.la
-lib/libsimapi.so
-lib/libsimapi.so.0
-lib/libsimui.la
-lib/libsimui.so
-lib/libsimui.so.0
-lib/menu/sim-kde.menu
-lib/sim/__homedir.so
-lib/sim/__migrate.so
-lib/sim/_core.so
-lib/sim/about.so
-lib/sim/action.so
-lib/sim/autoaway.so
-lib/sim/background.so
-lib/sim/dock.so
-lib/sim/filter.so
-lib/sim/floaty.so
-lib/sim/forward.so
-lib/sim/gpg.so
-lib/sim/icons.so
-lib/sim/icq.so
-lib/sim/jabber.so
-lib/sim/livejournal.so
-lib/sim/logger.so
-%%SSL%%lib/sim/msn.so
-lib/sim/navigate.so
-lib/sim/netmonitor.so
-%%KDE%%lib/sim/ontop.so
-lib/sim/osd.so
-lib/sim/proxy.so
-lib/sim/remote.so
-lib/sim/replace.so
-lib/sim/shortcuts.so
-lib/sim/sound.so
-%%SPELL%%lib/sim/spell.so
-lib/sim/splash.so
-lib/sim/styles.so
-%%KDE%%lib/sim/transparent.so
-lib/sim/update.so
-lib/sim/weather.so
-%%SSL%%lib/sim/yahoo.so
-lib/sim/zodiak.so
-share/applnk/Internet/sim.desktop
-share/apps/sim/COPYING
-share/apps/sim/pict/connect.gif
-share/apps/sim/pict/connect.mng
-share/apps/sim/pict/splash.png
-share/apps/sim/sounds/alert.wav
-share/apps/sim/sounds/auth.wav
-share/apps/sim/sounds/contacts.wav
-share/apps/sim/sounds/error.wav
-share/apps/sim/sounds/file.wav
-share/apps/sim/sounds/filedone.wav
-share/apps/sim/sounds/mailpager.wav
-share/apps/sim/sounds/message.wav
-share/apps/sim/sounds/message2.wav
-share/apps/sim/sounds/msgsent.wav
-share/apps/sim/sounds/sms.wav
-share/apps/sim/sounds/startup.wav
-share/apps/sim/sounds/system.wav
-share/apps/sim/sounds/url.wav
-share/apps/sim/sounds/vip-online.wav
-share/apps/sim/sounds/web.wav
-share/apps/sim/styles/SIM.2.xsl
-share/apps/sim/styles/SIM.3.xsl
-share/apps/sim/styles/SIM.4.(2+3).xsl
-share/apps/sim/styles/SIM.xsl
-share/apps/sim/styles/Separated.2.xsl
-share/apps/sim/styles/Separated.3.xsl
-share/apps/sim/styles/Separated.4.xsl
-share/apps/sim/styles/Separated.5.(2+3).xsl
-share/apps/sim/styles/Separated.6.(2+4).xsl
-share/apps/sim/styles/Separated.7.(3+4).xsl
-share/apps/sim/styles/Separated.8.(2+3+4).xsl
-share/apps/sim/styles/Separated.xsl
-share/apps/sim/styles/XChat.xsl
-share/apps/sim/styles/XChat2seconds.xsl
-share/apps/sim/styles/XChat3fullDate.xsl
-share/icons/hicolor/16x16/apps/sim.png
-share/icons/hicolor/22x22/apps/sim.png
-share/icons/hicolor/32x32/apps/sim.png
-share/icons/hicolor/48x48/apps/sim.png
-share/icons/hicolor/64x64/apps/sim.png
-share/icons/locolor/16x16/apps/sim.png
-share/icons/locolor/22x22/apps/sim.png
-share/icons/locolor/32x32/apps/sim.png
-share/locale/bg/LC_MESSAGES/sim.mo
-share/locale/ca/LC_MESSAGES/sim.mo
-share/locale/cs/LC_MESSAGES/sim.mo
-share/locale/de/LC_MESSAGES/sim.mo
-share/locale/el/LC_MESSAGES/sim.mo
-share/locale/es/LC_MESSAGES/sim.mo
-share/locale/fr/LC_MESSAGES/sim.mo
-share/locale/he/LC_MESSAGES/sim.mo
-share/locale/hu/LC_MESSAGES/sim.mo
-share/locale/it/LC_MESSAGES/sim.mo
-share/locale/nl/LC_MESSAGES/sim.mo
-share/locale/pl/LC_MESSAGES/sim.mo
-share/locale/pt_BR/LC_MESSAGES/sim.mo
-share/locale/ru/LC_MESSAGES/sim.mo
-share/locale/sk/LC_MESSAGES/sim.mo
-share/locale/sw/LC_MESSAGES/sim.mo
-share/locale/tr/LC_MESSAGES/sim.mo
-share/locale/uk/LC_MESSAGES/sim.mo
-share/locale/zh_TW/LC_MESSAGES/sim.mo
-share/mimelnk/application/x-icq.desktop
-share/services/simctrl.desktop
-@unexec rmdir %D/share/services 2>/dev/null || true
-@unexec rmdir %D/share/mimelnk/application 2>/dev/null || true
-@unexec rmdir %D/share/mimelnk 2>/dev/null || true
-@unexec rmdir %D/share/icons/locolor/32x32/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/locolor/32x32 2>/dev/null || true
-@unexec rmdir %D/share/icons/locolor/22x22/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/locolor/22x22 2>/dev/null || true
-@unexec rmdir %D/share/icons/locolor/16x16/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/locolor/16x16 2>/dev/null || true
-@unexec rmdir %D/share/icons/locolor 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/64x64/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/64x64 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/48x48/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/48x48 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/32x32 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/22x22/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/22x22 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/16x16/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/16x16 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor 2>/dev/null || true
-@unexec rmdir %D/share/icons 2>/dev/null || true
-@unexec rmdir %D/share/locale/sw/LC_MESSAGES 2> /dev/null || true
-@unexec rmdir %D/share/locale/sw 2> /dev/null || true
-@dirrm share/apps/sim/styles
-@dirrm share/apps/sim/sounds
-@dirrm share/apps/sim/pict
-@dirrm share/apps/sim
-@unexec rmdir %D/share/apps 2>/dev/null || true
-@unexec rmdir %D/share/applnk/Internet 2>/dev/null || true
-@unexec rmdir %D/share/applnk 2>/dev/null || true
-@dirrm lib/sim
-@unexec rmdir %D/lib/menu 2>/dev/null || true