aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-farstream
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telepathy-farstream')
-rw-r--r--net-im/telepathy-farstream/Makefile4
-rw-r--r--net-im/telepathy-farstream/files/patch-tools_glib-client-marshaller-gen.py33
-rw-r--r--net-im/telepathy-farstream/files/patch-tools_glib-ginterface-gen.py19
-rw-r--r--net-im/telepathy-farstream/files/patch-tools_libglibcodegen.py17
4 files changed, 71 insertions, 2 deletions
diff --git a/net-im/telepathy-farstream/Makefile b/net-im/telepathy-farstream/Makefile
index 1dafb75f3735..7a280fa4598c 100644
--- a/net-im/telepathy-farstream/Makefile
+++ b/net-im/telepathy-farstream/Makefile
@@ -3,7 +3,7 @@
PORTNAME= telepathy-farstream
PORTVERSION= 0.6.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
@@ -18,7 +18,7 @@ LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libtelepathy-glib.so:net-im/telepathy-glib \
libfarstream-0.2.so:net-im/farstream
-USES= gmake gnome libtool localbase:ldflags pathfix pkgconfig python:2.7
+USES= gmake gnome libtool localbase:ldflags pathfix pkgconfig python
USE_GNOME= glib20 libxslt:build introspection:build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/net-im/telepathy-farstream/files/patch-tools_glib-client-marshaller-gen.py b/net-im/telepathy-farstream/files/patch-tools_glib-client-marshaller-gen.py
new file mode 100644
index 000000000000..c523efb8b9a0
--- /dev/null
+++ b/net-im/telepathy-farstream/files/patch-tools_glib-client-marshaller-gen.py
@@ -0,0 +1,33 @@
+--- tools/glib-client-marshaller-gen.py.orig 2020-06-17 05:49:16 UTC
++++ tools/glib-client-marshaller-gen.py
+@@ -31,22 +31,22 @@ class Generator(object):
+ for signal in signals:
+ self.do_signal(signal)
+
+- print 'void'
+- print '%s_register_dbus_glib_marshallers (void)' % self.prefix
+- print '{'
++ print('void')
++ print('%s_register_dbus_glib_marshallers (void)' % self.prefix)
++ print('{')
+
+ all = self.marshallers.keys()
+ all.sort()
+ for marshaller in all:
+ rhs = self.marshallers[marshaller]
+
+- print ' dbus_g_object_register_marshaller (%s,' % marshaller
+- print ' G_TYPE_NONE, /* return */'
++ print(' dbus_g_object_register_marshaller (%s,' % marshaller)
++ print(' G_TYPE_NONE, /* return */')
+ for type in rhs:
+- print ' G_TYPE_%s,' % type.replace('VOID', 'NONE')
+- print ' G_TYPE_INVALID);'
++ print(' G_TYPE_%s,' % type.replace('VOID', 'NONE')}
++ print(' G_TYPE_INVALID);')
+
+- print '}'
++ print('}')
+
+
+ def types_to_gtypes(types):
diff --git a/net-im/telepathy-farstream/files/patch-tools_glib-ginterface-gen.py b/net-im/telepathy-farstream/files/patch-tools_glib-ginterface-gen.py
new file mode 100644
index 000000000000..e22b772e046d
--- /dev/null
+++ b/net-im/telepathy-farstream/files/patch-tools_glib-ginterface-gen.py
@@ -0,0 +1,19 @@
+--- tools/glib-ginterface-gen.py.orig 2020-06-17 05:47:06 UTC
++++ tools/glib-ginterface-gen.py
+@@ -748,7 +748,7 @@ class Generator(object):
+
+
+ def cmdline_error():
+- print """\
++ print("""\
+ usage:
+ gen-ginterface [OPTIONS] xmlfile Prefix_
+ options:
+@@ -769,6 +769,7 @@ options:
+ and return some sort of "not implemented" error via
+ dbus_g_method_return_error (context, ...)
+ """
++)
+ sys.exit(1)
+
+
diff --git a/net-im/telepathy-farstream/files/patch-tools_libglibcodegen.py b/net-im/telepathy-farstream/files/patch-tools_libglibcodegen.py
new file mode 100644
index 000000000000..9dbe7372ffa9
--- /dev/null
+++ b/net-im/telepathy-farstream/files/patch-tools_libglibcodegen.py
@@ -0,0 +1,17 @@
+--- tools/libglibcodegen.py.orig 2020-06-17 05:45:14 UTC
++++ tools/libglibcodegen.py
+@@ -154,7 +154,7 @@ def type_to_gtype(s):
+ return ("GHashTable *", "DBUS_TYPE_G_STRING_STRING_HASHTABLE", "BOXED", False)
+ elif s[:2] == 'a{': #some arbitrary hash tables
+ if s[2] not in ('y', 'b', 'n', 'q', 'i', 'u', 's', 'o', 'g'):
+- raise Exception, "can't index a hashtable off non-basic type " + s
++ raise Exception("can't index a hashtable off non-basic type " + s)
+ first = type_to_gtype(s[2])
+ second = type_to_gtype(s[3:-1])
+ return ("GHashTable *", "(dbus_g_type_get_map (\"GHashTable\", " + first[1] + ", " + second[1] + "))", "BOXED", False)
+@@ -169,4 +169,4 @@ def type_to_gtype(s):
+ return ("GValueArray *", gtype, "BOXED", True)
+
+ # we just don't know ..
+- raise Exception, "don't know the GType for " + s
++ raise Exception("don't know the GType for " + s)