aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-glib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telepathy-glib/Makefile')
-rw-r--r--net-im/telepathy-glib/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-im/telepathy-glib/Makefile b/net-im/telepathy-glib/Makefile
index ff25c75aec3a..7273ab234f2d 100644
--- a/net-im/telepathy-glib/Makefile
+++ b/net-im/telepathy-glib/Makefile
@@ -7,6 +7,7 @@
PORTNAME= telepathy-glib
PORTVERSION= 0.12.7
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
@@ -17,12 +18,12 @@ LIB_PC_DEPENDS= gobject-2.0.pc:${PORTSDIR}/devel/glib20 \
dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt \
- vapigen-0.10:${PORTSDIR}/lang/vala-vapigen \
+ vapigen:${PORTSDIR}/lang/vala-vapigen \
g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g} \
- vapigen-0.10:${PORTSDIR}/lang/vala-vapigen
+ vapigen:${PORTSDIR}/lang/vala-vapigen
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
@@ -35,7 +36,7 @@ CONFIGURE_ARGS= --enable-vala-bindings
post-patch:
@${REINPLACE_CMD} -e 's|\(^pkgconfigdir =\).*|\1 ${PREFIX}/libdata/pkgconfig|' \
${WRKSRC}/telepathy-glib/Makefile.in
- @${REINPLACE_CMD} -e 's|datarootdir)/vala/vapi|datarootdir)/vala-0.10/vapi|g' \
+ @${REINPLACE_CMD} -e 's|datarootdir)/vala/vapi|datarootdir)/vala-0.12/vapi|g' \
${WRKSRC}/vala/Makefile.in
.include <bsd.port.mk>