aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-idle/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telepathy-idle/Makefile')
-rw-r--r--net-im/telepathy-idle/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/net-im/telepathy-idle/Makefile b/net-im/telepathy-idle/Makefile
index bc5421166044..5bad0f0a081e 100644
--- a/net-im/telepathy-idle/Makefile
+++ b/net-im/telepathy-idle/Makefile
@@ -1,37 +1,35 @@
+# Created by: Florent Thoumie <flz@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/net-im/telepathy-idle/Makefile,v 1.6 2012/08/17 19:06:45 kwm Exp $
+# $MCom: ports/trunk/net-im/telepathy-idle/Makefile 20041 2014-11-04 11:13:49Z kwm $
PORTNAME= telepathy-idle
-PORTVERSION= 0.1.11
+PORTVERSION= 0.2.0
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= IRC Connection Manager for Telepathy Framework
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
- libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libtelepathy-glib.so:${PORTSDIR}/net-im/telepathy-glib
+USES= execinfo gmake libtool pathfix pkgconfig python:build
+USE_GNOME= glib20 libxslt:build
GNU_CONFIGURE= yes
-USES= gmake libtool pathfix pkgconfig python:build
USE_OPENSSL= yes
-USE_GNOME= glib20 libxslt:build
-
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.pre.mk>
-#.if defined(WITH_OPENSSL_BASE)
+.if defined(WITH_OPENSSL_BASE)
CONFIGURE_ENV+= OPENSSL_LIBS="-L/usr/lib -lssl -lcrypto" OPENSSL_CFLAGS="-I/usr/include"
-#.endif
-# OPENSSL_CFLAGS
-# C compiler flags for OPENSSL, overriding pkg-config
-# OPENSSL_LIBS
-# linker flags for OPENSSL, overriding pkg-config
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|strnlen(\([^,]*\), [^)]*)|strlen(\1)|' \
${WRKSRC}/src/idle-connection.c \
${WRKSRC}/src/idle-parser.c
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>