aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-mission-control/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telepathy-mission-control/Makefile')
-rw-r--r--net-im/telepathy-mission-control/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-im/telepathy-mission-control/Makefile b/net-im/telepathy-mission-control/Makefile
new file mode 100644
index 000000000000..32a5e0462607
--- /dev/null
+++ b/net-im/telepathy-mission-control/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: telepathy-mission-control
+# Date created: 2007-10-29
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/net-im/telepathy-mission-control/Makefile,v 1.4 2008/03/20 03:20:54 marcus Exp $
+
+PORTNAME= telepathy-mission-control
+PORTVERSION= 4.64
+CATEGORIES= net-im devel
+MASTER_SITES= SF/mission-control
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Telepathy component to apps to abstract details of connection managers
+
+LIB_DEPENDS= telepathy.2:${PORTSDIR}/net-im/libtelepathy \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+
+USE_GNOME= gnomeprefix pkgconfig gconf2 libxslt gnomehack ltverhack
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/gtk-doc/html|/${DOCSDIR}|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>