aboutsummaryrefslogtreecommitdiff
path: root/net-im/xicq/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/xicq/files')
-rw-r--r--net-im/xicq/files/patch-aa14
-rw-r--r--net-im/xicq/files/patch-af8
-rw-r--r--net-im/xicq/files/patch-ag17
-rw-r--r--net-im/xicq/files/patch-ah26
4 files changed, 0 insertions, 65 deletions
diff --git a/net-im/xicq/files/patch-aa b/net-im/xicq/files/patch-aa
deleted file mode 100644
index d74cae9a550b..000000000000
--- a/net-im/xicq/files/patch-aa
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/xicq/Makefile.orig Tue Jul 7 00:58:53 1998
-+++ src/xicq/Makefile Sat Sep 18 02:00:14 2004
-@@ -1,8 +1,8 @@
--CC = g++
-+CC = $(CXX)
- SHELL = /bin/sh
- INCLUDE = -I. -I../libXicq
--CXXFLAGS= -g -Wall $(INCLUDE)
--CFLAGS = -g -Wall $(INCLUDE)
-+CXXFLAGS= $(OPT) -g -Wall $(INCLUDE)
-+CFLAGS = $(OPT) -g -Wall $(INCLUDE)
- LIBDIR = -L../libXicq
- LIB = -lXicq
-
diff --git a/net-im/xicq/files/patch-af b/net-im/xicq/files/patch-af
deleted file mode 100644
index 2a2416c2eac3..000000000000
--- a/net-im/xicq/files/patch-af
+++ /dev/null
@@ -1,8 +0,0 @@
---- Makefile.orig Tue Dec 15 18:33:35 1998
-+++ Makefile Tue Dec 15 18:33:42 1998
-@@ -1,4 +1,4 @@
--all: lib xicq kxicq
-+all: lib xicq
-
- lib:
- @${MAKE} -C src/libXicq all
diff --git a/net-im/xicq/files/patch-ag b/net-im/xicq/files/patch-ag
deleted file mode 100644
index 662d773579a1..000000000000
--- a/net-im/xicq/files/patch-ag
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/libXicq/structs.h.orig Sun Feb 27 12:34:45 2000
-+++ src/libXicq/structs.h Sun Feb 27 12:37:10 2000
-@@ -16,10 +16,10 @@
- */
- struct LIB_INFORMATION
- {
-- const char NAME[] = "libXicq";
-- const char VERSION[] = "071298-snapshot";
-- const char AUTHOR[] = "tnc";
-- const char CONTACT[] = "xtrophy@it.dk";
-+ static const char NAME[] = "libXicq";
-+ static const char VERSION[] = "071298-snapshot";
-+ static const char AUTHOR[] = "tnc";
-+ static const char CONTACT[] = "xtrophy@it.dk";
- };
-
-
diff --git a/net-im/xicq/files/patch-ah b/net-im/xicq/files/patch-ah
deleted file mode 100644
index 3ac804237512..000000000000
--- a/net-im/xicq/files/patch-ah
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/libXicq/net.cc.orig Sun Feb 27 12:37:37 2000
-+++ src/libXicq/net.cc Sun Feb 27 12:38:59 2000
-@@ -6,6 +6,9 @@
- **************************************************************************/
-
-
-+#ifdef __FreeBSD__
-+#include <sys/param.h>
-+#endif
- #include "net.h"
-
- #define MAXWATCH 10
-@@ -144,8 +147,13 @@
- int net_udpRecv(unsigned char *mesg, int length)
- {
- structlength = sizeof(client);
-+#if defined(__FreeBSD__) && (__FreeBSD_version >= 400013)
-+ recvd = recvfrom(net_information.sock, mesg, length, 0,
-+ (struct sockaddr *) &client, (socklen_t *) &structlength);
-+#else
- recvd = recvfrom(net_information.sock, mesg, length, 0,
- (struct sockaddr *) &client, &structlength);
-+#endif
- if (recvd < 0)
- {
- perror("libXicq: recvfrom");