aboutsummaryrefslogtreecommitdiff
path: root/net-im/zephyr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/zephyr/Makefile')
-rw-r--r--net-im/zephyr/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/net-im/zephyr/Makefile b/net-im/zephyr/Makefile
index 948d8b29c06a..20231fd40748 100644
--- a/net-im/zephyr/Makefile
+++ b/net-im/zephyr/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zephyr
DISTVERSION= 3.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
MASTER_SITES= http://zephyr.1ts.org/export/2642/distribution/
@@ -13,6 +13,8 @@ COMMENT= Enterprise-scale distributed messaging system
LICENSE= MIT
GNU_CONFIGURE= yes
+# it is an upstream bug that --with-krb5 needs a path
+CONFIGURE_ARGS= --with-krb5="${KRB5_DIR}"
USES= iconv libtool readline
USE_RC_SUBR= zhm
USE_LDCONFIG= yes
@@ -24,7 +26,11 @@ CPPFLAGS+= -I${LOCALBASE}/include
OPTIONS_DEFINE= HEIMDAL
HEIMDAL_DESC= Link against libss.so from security/heimdal
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS+=ac_cv_lib_iconv_libiconv_open=no
+.endif
.if ${PORT_OPTIONS:MHEIMDAL}
BROKEN= bad depobj
@@ -39,13 +45,10 @@ LIB_DEPENDS+= libss.so.2:${PORTSDIR}/devel/e2fsprogs-libss
KRB5_DIR?= ${DESTDIR}/usr
.endif
-# it is an upstream bug that --with-krb5 needs a path
-CONFIGURE_ARGS= --with-krb5="${KRB5_DIR}"
-
# try to fix parallel (-jX) builds: add missing inter-source dependencies
post-patch:
@${REINPLACE_CMD} -e \
'/^eval\.o/,$$s,port\.h,& string_stack.h new_string.h, ; \
s,_aux\.h,.h,' ${WRKSRC}/zwgc/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>