aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/jabberd/Makefile15
-rw-r--r--net-im/jabberd/distinfo4
-rw-r--r--net-im/jabberd/files/patch-etc-Makefile.in20
-rw-r--r--net-im/jabberd/files/pkg-deinstall.in14
-rw-r--r--net-im/jabberd/files/pkg-install.in29
5 files changed, 35 insertions, 47 deletions
diff --git a/net-im/jabberd/Makefile b/net-im/jabberd/Makefile
index be1e8d779d7b..35c9ece8d733 100644
--- a/net-im/jabberd/Makefile
+++ b/net-im/jabberd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= jabberd
-PORTVERSION= 2.2.13
-PORTREVISION= 3
+PORTVERSION= 2.2.14
CATEGORIES= net-im
MASTER_SITES= http://codex.xiaoka.com/pub/jabberd2/releases/
DIST_SUBDIR= jabber
@@ -50,14 +49,16 @@ CONFIGURE_ARGS+= --localstatedir=/var \
--with-extra-library-path="${LOCALBASE}/lib ${ELP}"
JABBER_USER= jabber
-JABBER_UID= 93
-JABBER_GROUP= ${JABBER_USER}
-JABBER_GID= ${JABBER_UID}
+JABBER_GROUP= jabber
+
+USERS= ${JABBER_USER}
+GROUPS= ${JABBER_GROUP}
+
JABBER_ETCDIR= "${PREFIX}/etc/jabberd"
JABBER_RUNDIR= "/var/jabberd"
-SUB_LIST+= JABBER_USER=${JABBER_USER} JABBER_UID=${JABBER_UID} \
- JABBER_GROUP=${JABBER_GROUP} JABBER_GID=${JABBER_GID} \
+SUB_LIST+= JABBER_USER=${JABBER_USER} \
+ JABBER_GROUP=${JABBER_GROUP} \
JABBER_ETCDIR="${JABBER_ETCDIR}" \
JABBER_RUNDIR="${JABBER_RUNDIR}" \
PERL="${PERL}"
diff --git a/net-im/jabberd/distinfo b/net-im/jabberd/distinfo
index f8c853b6d7ba..10c823afacc4 100644
--- a/net-im/jabberd/distinfo
+++ b/net-im/jabberd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (jabber/jabberd-2.2.13.tar.bz2) = 17802a9a6f892dae5f81b3ff88f7a2c69789114f2886bfefd20bf393262fb258
-SIZE (jabber/jabberd-2.2.13.tar.bz2) = 626474
+SHA256 (jabber/jabberd-2.2.14.tar.bz2) = cd6bd518dda172935ad16f180f40ba6ebf7d4aa83ef4f9445ac6b55b438a9e3f
+SIZE (jabber/jabberd-2.2.14.tar.bz2) = 615984
diff --git a/net-im/jabberd/files/patch-etc-Makefile.in b/net-im/jabberd/files/patch-etc-Makefile.in
new file mode 100644
index 000000000000..5db085bde5bf
--- /dev/null
+++ b/net-im/jabberd/files/patch-etc-Makefile.in
@@ -0,0 +1,20 @@
+--- etc/Makefile.in.orig 2011-06-19 11:33:59.341460610 +0200
++++ etc/Makefile.in 2011-06-19 11:35:29.949061936 +0200
+@@ -539,7 +539,7 @@
+ uninstall: uninstall-recursive
+
+ install-am: all-am
+- @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
++ @$(MAKE) $(AM_MAKEFLAGS) install-exec-am
+
+ installcheck: installcheck-recursive
+ install-strip:
+@@ -623,7 +623,7 @@
+
+ ps-am:
+
+-uninstall-am: uninstall-initDATA uninstall-sysconfDATA
++uninstall-am: uninstall-sysconfDATA
+
+ .MAKE: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) ctags-recursive \
+ install-am install-data-am install-strip tags-recursive
diff --git a/net-im/jabberd/files/pkg-deinstall.in b/net-im/jabberd/files/pkg-deinstall.in
index 248fa7fe1ea9..d2915f81dda9 100644
--- a/net-im/jabberd/files/pkg-deinstall.in
+++ b/net-im/jabberd/files/pkg-deinstall.in
@@ -5,19 +5,9 @@ if [ "$2" != "POST-DEINSTALL" ]; then
exit 0
fi
-USER=%%JABBER_USER%%
-GROUP=%%JABBER_GROUP%%
RUNDIR="%%JABBER_RUNDIR%%"
-if pw usershow "${USER}" 2>/dev/null 1>&2; then
- echo "To delete Jabber user permanently, use 'pw userdel ${USER}'"
-fi
-
-if pw groupshow "${GROUP}" 2>/dev/null 1>&2; then
- echo "To delete Jabber group permanently, use 'pw groupdel ${USER}'"
-fi
-
-echo "You may want to delete the following directories:"
-echo "${RUNDIR}"
+echo "===> You should manually delete the following directories:"
+echo "${RUNDIR}"
exit 0
diff --git a/net-im/jabberd/files/pkg-install.in b/net-im/jabberd/files/pkg-install.in
index 76753f90a3da..ead0e703a634 100644
--- a/net-im/jabberd/files/pkg-install.in
+++ b/net-im/jabberd/files/pkg-install.in
@@ -7,41 +7,18 @@ fi
USER=%%JABBER_USER%%
GROUP=%%JABBER_GROUP%%
-UID=%%JABBER_UID%%
-GID=%%JABBER_GID%%
ETCDIR=%%JABBER_ETCDIR%%
RUNDIR=%%JABBER_RUNDIR%%
-if ! pw groupshow "${GROUP}" 2>/dev/null 1>&2; then
- if pw groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
-fi
-
-if ! pw usershow "${USER}" 2>/dev/null 1>&2; then
- if pw useradd ${USER} -u ${UID} -g ${GROUP} -h - \
- -s "/sbin/nologin" -d "/nonexistent" \
- -c "Jabber Daemon"; \
- then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- exit 1
- fi
-fi
-
if [ ! -d ${RUNDIR} ]; then
- echo "Creating \"${RUNDIR}\"."
+ echo "===> Creating \"${RUNDIR}\"."
mkdir -p ${RUNDIR}/pid ${RUNDIR}/db ${RUNDIR}/logs
fi
-echo "Fixing ownerships and modes in \"${ETCDIR}\"."
+echo "===> Changing owner and modes for \"${ETCDIR}\"."
chown -R ${USER}:${GROUP} ${ETCDIR}
chmod -R go= ${ETCDIR}
-echo "Fixing ownerships and modes in \"${RUNDIR}\"."
+echo "===> Changing owner and modes for \"${RUNDIR}\"."
chown -R ${USER}:${GROUP} ${RUNDIR}
chmod -R go= ${RUNDIR}