aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/jabber-pyicq/Makefile10
-rw-r--r--net-im/jabber-pymsn/Makefile10
2 files changed, 6 insertions, 14 deletions
diff --git a/net-im/jabber-pyicq/Makefile b/net-im/jabber-pyicq/Makefile
index a1b0a3a71e48..ea2c8785bfa0 100644
--- a/net-im/jabber-pyicq/Makefile
+++ b/net-im/jabber-pyicq/Makefile
@@ -18,10 +18,10 @@ MAINTAINER= garga@FreeBSD.org
COMMENT= Python ICQ-Transport for Jabber
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenSSL/__init__.py:${PORTSDIR}/security/py-openssl \
- ${PYTHON_SITELIBDIR}/twisted/__init__.py:${PORTSDIR}/devel/py-twisted
+ ${PYTHON_SITELIBDIR}/twisted/__init__.py:${PORTSDIR}/devel/py-twisted \
+ ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
-OPTIONS= EJABBERD "Use transport with ejabberd" off \
- X11 "Use X11 (required to avatars working)" on
+OPTIONS= EJABBERD "Use transport with ejabberd" off
NO_BUILD= yes
USE_PYTHON= yes
@@ -46,10 +46,6 @@ SUB_LIST+= JABBER_REQUIRE=jabberd
SUB_LIST+= JABBER_USER=${JABBER_USER}
-.if !defined(WITHOUT_X11)
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
-.endif
-
post-extract:
@${FIND} ${WRKSRC}/src -type d -name '.svn' | ${XARGS} ${RM} -rf
diff --git a/net-im/jabber-pymsn/Makefile b/net-im/jabber-pymsn/Makefile
index 71978e9bf1e4..91f52bf730c9 100644
--- a/net-im/jabber-pymsn/Makefile
+++ b/net-im/jabber-pymsn/Makefile
@@ -20,12 +20,12 @@ MAINTAINER= garga@FreeBSD.org
COMMENT= Python MSN-Transport for Jabber
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenSSL/__init__.py:${PORTSDIR}/security/py-openssl \
- ${PYTHON_SITELIBDIR}/twisted/__init__.py:${PORTSDIR}/devel/py-twisted
+ ${PYTHON_SITELIBDIR}/twisted/__init__.py:${PORTSDIR}/devel/py-twisted \
+ ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
WRKSRC= ${WRKDIR}/${PORTNAME}t-0.11
-OPTIONS= EJABBERD "Use transport with ejabberd" off \
- X11 "Use X11 (required to non-PNG avatars)" on
+OPTIONS= EJABBERD "Use transport with ejabberd" off
NO_BUILD= yes
USE_PYTHON= yes
@@ -50,10 +50,6 @@ SUB_LIST+= JABBER_REQUIRE=jabberd
SUB_LIST+= JABBER_USER=${JABBER_USER}
-.if !defined(WITHOUT_X11)
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
-.endif
-
post-extract:
@${FIND} ${WRKSRC}/ -type d \( -name CVS -or -name .svn \) | ${XARGS} ${RM} -rf