aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/p5-Jabber-SimpleSend/Makefile10
-rw-r--r--net-im/p5-Net-Jabber/Makefile10
-rw-r--r--net-im/p5-Net-NetSend/Makefile8
-rw-r--r--net-im/p5-Net-OSCAR/Makefile3
-rw-r--r--net-im/p5-Net-XMPP/Makefile11
5 files changed, 7 insertions, 35 deletions
diff --git a/net-im/p5-Jabber-SimpleSend/Makefile b/net-im/p5-Jabber-SimpleSend/Makefile
index d90a7d8e407f..79a20f89fbdc 100644
--- a/net-im/p5-Jabber-SimpleSend/Makefile
+++ b/net-im/p5-Jabber-SimpleSend/Makefile
@@ -19,14 +19,8 @@ RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/Net/Jabber.pm:${PORTSDIR}/net-im/p5-Net-Jabber
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+ # Inherited from net-im/p5-Net-Jabber
MAN3= Jabber::SimpleSend.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800 # Inherited from net-im/p5-Net-Jabber
-IGNORE= requires Perl 5.6.0 or newer. Install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/p5-Net-Jabber/Makefile b/net-im/p5-Net-Jabber/Makefile
index 1a534dac3548..33c905578950 100644
--- a/net-im/p5-Net-Jabber/Makefile
+++ b/net-im/p5-Net-Jabber/Makefile
@@ -19,7 +19,7 @@ COMMENT= Net::Jabber provides Perl Developer access to the Jabber protocol
BUILD_DEPENDS= ${SITE_PERL}/Net/XMPP.pm:${PORTSDIR}/net-im/p5-Net-XMPP
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+
MAN3= Net::Jabber.3 Net::Jabber::Client.3 Net::Jabber::Component.3 \
Net::Jabber::Data.3 Net::Jabber::Debug.3 \
@@ -31,10 +31,4 @@ MAN3= Net::Jabber.3 Net::Jabber::Client.3 Net::Jabber::Component.3 \
Net::Jabber::Server.3 Net::Jabber::Stanza.3 \
Net::Jabber::XDB.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/p5-Net-NetSend/Makefile b/net-im/p5-Net-NetSend/Makefile
index a8fd30181137..9cd04891877f 100644
--- a/net-im/p5-Net-NetSend/Makefile
+++ b/net-im/p5-Net-NetSend/Makefile
@@ -19,10 +19,4 @@ PERL_CONFIGURE= yes
MAN3= Net::NetSend.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6 or above
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/p5-Net-OSCAR/Makefile b/net-im/p5-Net-OSCAR/Makefile
index 3d6446c3975f..57711a5b0306 100644
--- a/net-im/p5-Net-OSCAR/Makefile
+++ b/net-im/p5-Net-OSCAR/Makefile
@@ -41,9 +41,6 @@ BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-
${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
-.if ${PERL_LEVEL} < 500601
-IGNORE= requires perl 5.6.1+, install lang/perl5.8 and try again
-.endif
.endif
.include <bsd.port.post.mk>
diff --git a/net-im/p5-Net-XMPP/Makefile b/net-im/p5-Net-XMPP/Makefile
index 7540eb255f67..a678de7b08f4 100644
--- a/net-im/p5-Net-XMPP/Makefile
+++ b/net-im/p5-Net-XMPP/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${SITE_PERL}/XML/Stream.pm:${PORTSDIR}/textproc/p5-XML-Stream \
${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+ # Require perl 5.8.x due to XML::Stream
MAN3= Net::XMPP.3 Net::XMPP::Client.3 Net::XMPP::Connection.3 \
Net::XMPP::Debug.3 Net::XMPP::IQ.3 Net::XMPP::JID.3 \
@@ -28,11 +28,4 @@ MAN3= Net::XMPP.3 Net::XMPP::Client.3 Net::XMPP::Connection.3 \
Net::XMPP::Protocol.3 Net::XMPP::Roster.3 \
Net::XMPP::Stanza.3
-.include <bsd.port.pre.mk>
-
-# Require perl 5.8.x due to XML::Stream
-.if ${PERL_LEVEL} < 500800
-IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>