aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/bpft/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/bpft/Makefile')
-rw-r--r--net-mgmt/bpft/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-mgmt/bpft/Makefile b/net-mgmt/bpft/Makefile
index 1a5e0a941877..80c47ed9f208 100644
--- a/net-mgmt/bpft/Makefile
+++ b/net-mgmt/bpft/Makefile
@@ -21,17 +21,21 @@ CONFLICTS= trafd-3.0.*
WRKSRC= ${WRKDIR}/bpft
MAN1= traflog.1 trafstat.1
MAN8= trafstatd.8 trafd.8
+PORTDOCS= README WhatsNew
MANCOMPRESSED= yes
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/include/pathnames.h
@${REINPLACE_CMD} -e 's|/usr/local/|${PREFIX}/|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|<net/slip.h>|"../linux-include/net/slip.h"|' \
+ ${WRKSRC}/lib/interfaces.c
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/WhatsNew ${DOCSDIR}
+. for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+. endfor
.endif
.include <bsd.port.mk>