aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/collectd/files/patch-configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/collectd/files/patch-configure.in')
-rw-r--r--net-mgmt/collectd/files/patch-configure.in44
1 files changed, 38 insertions, 6 deletions
diff --git a/net-mgmt/collectd/files/patch-configure.in b/net-mgmt/collectd/files/patch-configure.in
index 7f158b4b239a..b5d76f9d540a 100644
--- a/net-mgmt/collectd/files/patch-configure.in
+++ b/net-mgmt/collectd/files/patch-configure.in
@@ -1,6 +1,16 @@
---- configure.in.orig 2011-10-14 12:49:49.000000000 -0800
-+++ configure.in 2012-03-20 08:09:25.000000000 -0800
-@@ -98,7 +98,7 @@
+--- configure.in.orig 2012-11-11 11:43:05.000000000 +0100
++++ configure.in 2012-12-30 23:49:30.000000000 +0100
+@@ -67,6 +67,9 @@
+ *openbsd*)
+ ac_system="OpenBSD"
+ ;;
++ *freebsd*)
++ ac_system="FreeBSD"
++ ;;
+ *aix*)
+ AC_DEFINE([KERNEL_AIX], 1, [True if program is to be compiled for a AIX kernel])
+ ac_system="AIX"
+@@ -98,7 +101,7 @@
fi
# Where to install .pc files.
@@ -9,7 +19,16 @@
AC_SUBST(pkgconfigdir)
# Check for standards compliance mode
-@@ -1745,9 +1745,6 @@
+@@ -1200,6 +1203,8 @@
+ then
+ AC_DEFINE(HAVE_LIBKSTAT, 1,
+ [Define to 1 if you have the 'kstat' library (-lkstat)])
++ BUILD_WITH_LIBKSTAT_LIBS="-lkstat"
++ AC_SUBST(BUILD_WITH_LIBKSTAT_LIBS)
+ fi
+ AM_CONDITIONAL(BUILD_WITH_LIBKSTAT, test "x$with_kstat" = "xyes")
+ AM_CONDITIONAL(BUILD_WITH_LIBDEVINFO, test "x$with_devinfo" = "xyes")
+@@ -1562,9 +1567,6 @@
[with_libgcrypt="yes"],
[with_libgcrypt="no (symbol gcry_md_hash_buffer not found)"])
@@ -19,7 +38,7 @@
fi
CPPFLAGS="$SAVE_CPPFLAGS"
-@@ -3165,7 +3162,7 @@
+@@ -3059,7 +3061,7 @@
if test "x$with_python" = "xyes"
then
AC_MSG_CHECKING([for Python LIBS])
@@ -28,7 +47,7 @@
python_config_status=$?
if test "$python_config_status" -ne 0 || test "x$python_library_flags" = "x"
-@@ -3180,7 +3177,7 @@
+@@ -3074,7 +3076,7 @@
if test "x$with_python" = "xyes"
then
LDFLAGS="-L$python_library_path $LDFLAGS"
@@ -37,3 +56,16 @@
AC_CHECK_FUNC(PyObject_CallFunction,
[with_python="yes"],
+@@ -4171,6 +4173,12 @@
+ plugin_zfs_arc="yes"
+ fi
+
++# FreeBSD
++if test "x$ac_system" = "xFreeBSD"
++then
++ plugin_zfs_arc="yes"
++fi
++
+ if test "x$with_devinfo$with_kstat" = "xyesyes"
+ then
+ plugin_cpu="yes"