aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/collectd5/files/patch-configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/collectd5/files/patch-configure.ac')
-rw-r--r--net-mgmt/collectd5/files/patch-configure.ac66
1 files changed, 11 insertions, 55 deletions
diff --git a/net-mgmt/collectd5/files/patch-configure.ac b/net-mgmt/collectd5/files/patch-configure.ac
index ba35d98b1edb..d2da50ad1c1d 100644
--- a/net-mgmt/collectd5/files/patch-configure.ac
+++ b/net-mgmt/collectd5/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig 2016-01-22 09:51:17 UTC
+--- configure.ac.orig 2016-09-11 08:10:25 UTC
+++ configure.ac
-@@ -155,7 +155,7 @@ then
+@@ -185,7 +185,7 @@ then
fi
# Where to install .pc files.
@@ -9,7 +9,7 @@
AC_SUBST(pkgconfigdir)
# Check for standards compliance mode
-@@ -715,7 +715,7 @@ SAVE_CFLAGS="$CFLAGS"
+@@ -841,7 +841,7 @@ SAVE_CFLAGS="$CFLAGS"
# Emulate behavior of src/Makefile.am
if test "x$GCC" = "xyes"
then
@@ -18,7 +18,7 @@
fi
AC_CACHE_CHECK([for strtok_r],
-@@ -844,7 +844,7 @@ AC_CHECK_FUNCS(getutxent, [have_getutxen
+@@ -968,7 +968,7 @@ AC_CHECK_FUNCS(getutxent, [have_getutxen
if test "x$GCC" = "xyes"
then
SAVE_CFLAGS="$CFLAGS"
@@ -27,7 +27,7 @@
fi
AC_CHECK_FUNCS(strptime, [have_strptime="yes"], [have_strptime="no"])
-@@ -1571,6 +1571,7 @@ if test "x$with_kstat" = "xyes"
+@@ -1757,6 +1757,7 @@ if test "x$with_kstat" = "xyes"
then
AC_CHECK_LIB(kstat, kstat_open, [with_kstat="yes"], [with_kstat="no (libkstat not found)"], [])
fi
@@ -35,7 +35,7 @@
if test "x$with_kstat" = "xyes"
then
AC_CHECK_LIB(devinfo, di_init, [with_devinfo="yes"], [with_devinfo="no (not found)"], [])
-@@ -1580,6 +1581,8 @@ if test "x$with_kstat" = "xyes"
+@@ -1766,6 +1767,8 @@ if test "x$with_kstat" = "xyes"
then
AC_DEFINE(HAVE_LIBKSTAT, 1,
[Define to 1 if you have the 'kstat' library (-lkstat)])
@@ -44,7 +44,7 @@
fi
AM_CONDITIONAL(BUILD_WITH_LIBKSTAT, test "x$with_kstat" = "xyes")
AM_CONDITIONAL(BUILD_WITH_LIBDEVINFO, test "x$with_devinfo" = "xyes")
-@@ -2624,8 +2627,8 @@ AC_ARG_WITH(libmongoc, [AS_HELP_STRING([
+@@ -3053,8 +3056,8 @@ AC_ARG_WITH(libmongoc, [AS_HELP_STRING([
with_libmongoc="no"
else
with_libmongoc="yes"
@@ -55,7 +55,7 @@
fi; fi
],
[with_libmongoc="yes"])
-@@ -2642,7 +2645,7 @@ then
+@@ -3071,7 +3074,7 @@ then
then
AC_MSG_NOTICE([libmongoc CPPFLAGS: $LIBMONGOC_CPPFLAGS])
fi
@@ -64,7 +64,7 @@
[with_libmongoc="yes"],
[with_libmongoc="no ('mongo.h' not found)"],
[#if HAVE_STDINT_H
-@@ -2658,7 +2661,7 @@ then
+@@ -3087,7 +3090,7 @@ then
then
AC_MSG_NOTICE([libmongoc LDFLAGS: $LIBMONGOC_LDFLAGS])
fi
@@ -73,7 +73,7 @@
[with_libmongoc="yes"],
[with_libmongoc="no (symbol 'mongo_run_command' not found)"])
fi
-@@ -3415,7 +3418,7 @@ then
+@@ -3873,7 +3876,7 @@ then
SAVE_LIBS="$LIBS"
# trigger an error if Perl_load_module*() uses __attribute__nonnull__(3)
# (see issues #41 and #42)
@@ -82,43 +82,7 @@
LIBS="$LIBS $PERL_LIBS"
AC_CACHE_CHECK([for broken Perl_load_module()],
-@@ -3645,7 +3648,7 @@ fi
- if test "x$with_python" = "xyes"
- then
- AC_MSG_CHECKING([for Python CPPFLAGS])
-- python_include_path=`echo "import distutils.sysconfig;import sys;sys.stdout.write(distutils.sysconfig.get_python_inc())" | "$with_python_prog" 2>&1`
-+ python_include_path=`echo "import distutils.sysconfig;import sys;sys.stdout.write(distutils.sysconfig.get_python_inc())" | "$with_python_prog" 2>/dev/null`
- python_config_status=$?
-
- if test "$python_config_status" -ne 0 || test "x$python_include_path" = "x"
-@@ -3668,7 +3671,7 @@ fi
- if test "x$with_python" = "xyes"
- then
- AC_MSG_CHECKING([for Python LDFLAGS])
-- python_library_path=`echo "import distutils.sysconfig;import sys;sys.stdout.write(distutils.sysconfig.get_config_vars(\"LIBDIR\").__getitem__(0))" | "$with_python_prog" 2>&1`
-+ python_library_path=`echo "import distutils.sysconfig;import sys;sys.stdout.write(distutils.sysconfig.get_config_vars(\"LIBDIR\").__getitem__(0))" | "$with_python_prog" 2>/dev/null`
- python_config_status=$?
-
- if test "$python_config_status" -ne 0 || test "x$python_library_path" = "x"
-@@ -3683,7 +3686,7 @@ fi
- if test "x$with_python" = "xyes"
- then
- AC_MSG_CHECKING([for Python LIBS])
-- python_library_flags=`echo "import distutils.sysconfig;import sys;sys.stdout.write(distutils.sysconfig.get_config_vars(\"BLDLIBRARY\").__getitem__(0))" | "$with_python_prog" 2>&1`
-+ python_library_flags=`echo "import distutils.sysconfig;import sys;sys.stdout.write(distutils.sysconfig.get_config_vars(\"BLDLIBRARY\").__getitem__(0))" | "$with_python_prog" 2>/dev/null`
- python_config_status=$?
-
- if test "$python_config_status" -ne 0 || test "x$python_library_flags" = "x"
-@@ -3698,7 +3701,7 @@ fi
- if test "x$with_python" = "xyes"
- then
- LDFLAGS="-L$python_library_path $LDFLAGS"
-- LIBS="$python_library_flags $LIBS"
-+ LIBS="$python_library_flags $LIBS -lm -lpthread -lutil"
-
- AC_CHECK_FUNC(PyObject_CallFunction,
- [with_python="yes"],
-@@ -4761,8 +4764,8 @@ AC_ARG_WITH(libvarnish, [AS_HELP_STRING(
+@@ -5249,8 +5252,8 @@ AC_ARG_WITH(libvarnish, [AS_HELP_STRING(
else if test -d "$with_libvarnish/lib"
then
AC_MSG_NOTICE([Not checking for libvarnish: Manually configured])
@@ -129,11 +93,3 @@
with_libvarnish="yes"
fi; fi; fi
],
-@@ -5334,6 +5337,7 @@ fi
-
- if test "x$ac_system" = "xFreeBSD"
- then
-+ plugin_disk="yes"
- plugin_zfs_arc="yes"
- fi
-