aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/collectd5
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/collectd5')
-rw-r--r--net-mgmt/collectd5/Makefile191
-rw-r--r--net-mgmt/collectd5/distinfo3
-rw-r--r--net-mgmt/collectd5/files/collectd.in27
-rw-r--r--net-mgmt/collectd5/files/patch-src__collectd.h20
-rw-r--r--net-mgmt/collectd5/files/patch-src__dns.c18
-rw-r--r--net-mgmt/collectd5/pkg-descr6
-rw-r--r--net-mgmt/collectd5/pkg-plist61
7 files changed, 0 insertions, 326 deletions
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
deleted file mode 100644
index 43ce9fe4024b..000000000000
--- a/net-mgmt/collectd5/Makefile
+++ /dev/null
@@ -1,191 +0,0 @@
-# New ports collection makefile for: collectd
-# Date created: Sat Sep 29 05:19:31 PDT 2007
-# Whom: Matt Peterson <matt@peterson.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= collectd
-PORTVERSION= 4.1.2
-PORTREVISION= 3
-CATEGORIES= net-mgmt
-MASTER_SITES= http://collectd.org/files/ \
- http://mirror.roe.ch/dist/${PORTNAME}/
-
-MAINTAINER= daniel@roe.ch
-COMMENT= Systems & network statistics collection daemon
-
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-WANT_GNOME= yes
-
-OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
- DEBUG "Enable debugging" Off \
- APACHE "Input: Apache mod_status (libcurl)" Off \
- APCUPS "Input: APC UPS (apcupsd)" Off \
- INTERFACE "Input: Network interfaces (libstatgrab)" On \
- MBMON "Input: MBMon" Off \
- MYSQL "Input: MySQL" Off \
- PING "Input: Network latency (liboping)" On \
- SNMP "Input: SNMP" On \
- XMMS "Input: XMMS" Off \
- RRDTOOL "Output: RRDTool" On
-
-MAN1= collectd.1 collectd-nagios.1
-MAN5= collectd.conf.5 collectd-email.5 collectd-exec.5 \
- collectd-snmp.5 collectd-unixsock.5 collectd-perl.5
-USE_RC_SUBR= collectd
-
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
-.include <bsd.port.pre.mk>
-
-.if ( ${OSVERSION} < 601103 )
-BROKEN= Need bind9 import post 6.1
-.endif
-
-CONFIGURE_ARGS= --localstatedir=/var \
- --disable-apple_sensors \
- --disable-battery \
- --disable-hddtemp \
- --disable-multimeter \
- --disable-iptables \
- --disable-perl \
- --disable-sensors \
- --disable-serial \
- --disable-vserver \
- --disable-wireless
-
-.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+=--enable-debug
-.endif
-
-.if defined(WITH_CGI)
-RUN_DEPENDS+= ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
- ${SITE_PERL}/${PERL_ARCH}/Data/Dumper.pm:${PORTSDIR}/devel/p5-Data-Dumper
-PLIST_SUB+= CGI=""
-.else
-PLIST_SUB+= CGI="@comment "
-.endif
-
-.if defined(WITH_APACHE)
-CONFIGURE_ARGS+=--enable-apache
-LIB_DEPENDS+= curl.4:${PORTSDIR}/ftp/curl
-PLIST_SUB+= APACHE=""
-.else
-CONFIGURE_ARGS+=--disable-apache
-PLIST_SUB+= APACHE="@comment "
-.endif
-
-.if defined(WITH_APCUPS)
-CONFIGURE_ARGS+=--enable-apcups
-BUILD_DEPENDS+= ${LOCALBASE}/sbin/apcupsd:${PORTSDIR}/sysutils/apcupsd
-PLIST_SUB+= APCUPS=""
-.else
-CONFIGURE_ARGS+=--disable-apcups
-PLIST_SUB+= APCUPS="@comment "
-.endif
-
-.if defined(WITH_INTERFACE)
-BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
-CONFIGURE_ARGS+=--enable-interface
-LIB_DEPENDS+= statgrab.8:${PORTSDIR}/devel/libstatgrab
-PLIST_SUB+= INTERFACE=""
-CONFIGURE_ENV+= LIBS="`pkg-config --libs libstatgrab`"
-.else
-CONFIGURE_ARGS+=--disable-interface
-PLIST_SUB+= INTERFACE="@comment "
-.endif
-
-.if defined(WITH_MBMON)
-CONFIGURE_ARGS+=--enable-mbmon
-RUN_DEPENDS+= ${LOCALBASE}/sbin/mbmond:${PORTSDIR}/sysutils/mbmon
-PLIST_SUB+= MBMON=""
-.else
-CONFIGURE_ARGS+=--disable-mbmon
-PLIST_SUB+= MBMON="@comment "
-.endif
-
-.if defined(WITH_MYSQL)
-USE_MYSQL= yes
-CONFIGURE_ARGS+=--enable-mysql
-PLIST_SUB+= MYSQL=""
-.else
-CONFIGURE_ARGS+=--disable-mysql
-PLIST_SUB+= MYSQL="@comment "
-.endif
-
-.if defined(WITH_PING)
-LIB_DEPENDS+= oping:${PORTSDIR}/net/liboping
-CONFIGURE_ARGS+=--enable-ping
-PLIST_SUB+= PING=""
-.else
-CONFIGURE_ARGS+=--disable-ping
-PLIST_SUB+= PING="@comment "
-.endif
-
-.if defined(WITH_RRDTOOL)
-LIB_DEPENDS+= rrd:${PORTSDIR}/databases/rrdtool
-CONFIGURE_ARGS+=--enable-rrdtool
-PLIST_SUB+= RRD=""
-.else
-CONFIGURE_ARGS+=--disable-rrdtool
-PLIST_SUB+= RRD="@comment "
-.endif
-
-.if defined(WITH_SNMP)
-LIB_DEPENDS+= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
-CONFIGURE_ARGS+=--enable-snmp
-PLIST_SUB+= SNMP=""
-.else
-CONFIGURE_ARGS+=--disable-snmp
-PLIST_SUB+= SNMP="@comment "
-.endif
-
-.if defined(WITH_XMMS)
-LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
-CONFIGURE_ARGS+=--enable-xmms
-CFLAGS+= `xmms-config --cflags`
-PLIST_SUB+= XMMS=""
-.else
-CONFIGURE_ARGS+=--disable-xmms
-PLIST_SUB+= XMMS="@comment "
-.endif
-
-post-patch:
- @${REINPLACE_CMD} \
- -e 's;@prefix@/var/;/var/;' \
- -e 's;/var/lib/;/var/db/;' \
- ${WRKSRC}/src/collectd.conf.in
- @${REINPLACE_CMD} \
- -e 's;$$[(]DESTDIR)$$[(]sysconfdir)/collectd\.conf;&.sample;' \
- ${WRKSRC}/src/Makefile.in
- @${REINPLACE_CMD} -e '/$$[(]mkinstalldirs)/d' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} \
- -e 's;/etc/collection\.conf;${WWWDIR}/collection.conf;' \
- ${WRKSRC}/contrib/collection.cgi
- @${REINPLACE_CMD} \
- -e 's;/opt/collectd/var/lib;/var/db;' \
- -e 's;/opt/collectd/lib;${PREFIX}/lib;' \
- ${WRKSRC}/contrib/collection.conf
-
-post-install:
- ${MKDIR} /var/db/collectd
- if [ ! -f ${PREFIX}/etc/collectd.conf ]; then \
- ${CP} -p ${PREFIX}/etc/collectd.conf.sample \
- ${PREFIX}/etc/collectd.conf ; \
- fi
-.if defined(WITH_CGI)
- ${MKDIR} ${WWWDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/contrib/collection.cgi ${WWWDIR}/
- ${INSTALL_DATA} ${WRKSRC}/contrib/collection.conf \
- ${WWWDIR}/collection.conf.sample
- if [ ! -f ${WWWDIR}/collection.conf ]; then \
- ${CP} -p ${WWWDIR}/collection.conf.sample \
- ${WWWDIR}/collection.conf ; \
- fi
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/net-mgmt/collectd5/distinfo b/net-mgmt/collectd5/distinfo
deleted file mode 100644
index 7fce046fb9d7..000000000000
--- a/net-mgmt/collectd5/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (collectd-4.1.2.tar.gz) = 40458dabe8ec5df87323c1862a03cb94
-SHA256 (collectd-4.1.2.tar.gz) = fba4423378a8a270de8b48f98dc2f102f4f3c630381672267344776885a6e690
-SIZE (collectd-4.1.2.tar.gz) = 999229
diff --git a/net-mgmt/collectd5/files/collectd.in b/net-mgmt/collectd5/files/collectd.in
deleted file mode 100644
index 5ec218f3b27e..000000000000
--- a/net-mgmt/collectd5/files/collectd.in
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/sh
-
-# PROVIDE: collectd
-# REQUIRE: LOGIN
-#
-# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
-# to enable this service:
-#
-# collectd_enable (bool): Set to NO by default.
-# Set it to YES to enable collectd.
-# collectd_flags (string): Set to "" by default.
-# Additional flags to collecd, see manual page.
-#
-
-. %%RC_SUBR%%
-
-name="collectd"
-rcvar=${name}_enable
-
-command=%%PREFIX%%/sbin/${name}
-
-load_rc_config $name
-
-: ${collectd_enable="NO"}
-: ${collectd_flags=""}
-
-run_rc_command "$1"
diff --git a/net-mgmt/collectd5/files/patch-src__collectd.h b/net-mgmt/collectd5/files/patch-src__collectd.h
deleted file mode 100644
index 8058189613b1..000000000000
--- a/net-mgmt/collectd5/files/patch-src__collectd.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./src/collectd.h.orig 2007-09-28 17:55:34.000000000 +0300
-+++ ./src/collectd.h 2008-05-06 10:32:08.000000000 +0300
-@@ -183,7 +183,7 @@
- #endif
-
- #ifndef LOCALSTATEDIR
--#define LOCALSTATEDIR PREFIX "/var"
-+#define LOCALSTATEDIR "/var"
- #endif
-
- #ifndef PKGLOCALSTATEDIR
-@@ -191,7 +191,7 @@
- #endif
-
- #ifndef PIDFILE
--#define PIDFILE PREFIX "/var/run/" PACKAGE_NAME ".pid"
-+#define PIDFILE "/var/run/" PACKAGE_NAME ".pid"
- #endif
-
- #ifndef PLUGINDIR
diff --git a/net-mgmt/collectd5/files/patch-src__dns.c b/net-mgmt/collectd5/files/patch-src__dns.c
deleted file mode 100644
index fb045049b25a..000000000000
--- a/net-mgmt/collectd5/files/patch-src__dns.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/dns.c.orig 2008-09-05 15:26:02.000000000 +0000
-+++ src/dns.c 2008-09-05 15:25:55.000000000 +0000
-@@ -210,6 +210,15 @@
- pthread_sigmask (SIG_SETMASK, &sigmask, NULL);
- }
-
-+ /* Check for pcap_device, if needed */
-+#ifdef __sparc64__
-+ if (pcap_device == NULL)
-+ {
-+ ERROR ("dns plugin: Interface required");
-+ return (NULL);
-+ }
-+#endif
-+
- /* Passing `pcap_device == NULL' is okay and the same as passign "any" */
- DEBUG ("Creating PCAP object..");
- pcap_obj = pcap_open_live (pcap_device,
diff --git a/net-mgmt/collectd5/pkg-descr b/net-mgmt/collectd5/pkg-descr
deleted file mode 100644
index a591a0195caa..000000000000
--- a/net-mgmt/collectd5/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-collectd is a small daemon written in C for performance. It reads various
-system & network statistics along with updating output RRD or CSV files.
-The daemon is very fast and allows for frequent polling of values, with
-support for polling as frequent as every 10 seconds.
-
-WWW: http://www.collectd.org/
diff --git a/net-mgmt/collectd5/pkg-plist b/net-mgmt/collectd5/pkg-plist
deleted file mode 100644
index 2da1f6995781..000000000000
--- a/net-mgmt/collectd5/pkg-plist
+++ /dev/null
@@ -1,61 +0,0 @@
-@stopdaemon collectd
-sbin/collectd
-@unexec if cmp -s %D/etc/collectd.conf.sample %D/etc/collectd.conf; then rm -f %D/etc/collectd.conf; fi
-etc/collectd.conf.sample
-@exec if [ ! -f %B/collectd.conf ] ; then cp -p %B/%f %B/collectd.conf; fi
-%%CGI%%%%WWWDIR%%/collection.cgi
-%%CGI%%@unexec if cmp -s %B/collection.conf.sample %B/collection.conf; then rm -f %B/collection.conf; fi
-%%CGI%%%%WWWDIR%%/collection.conf.sample
-%%CGI%%@exec if [ ! -f %B/collection.conf ] ; then cp -p %B/%f %B/collection.conf; fi
-%%CGI%%@dirrmtry %%WWWDIR%%
-bin/collectd-nagios
-lib/collectd/types.db
-%%APACHE%%lib/collectd/apache.la
-%%APACHE%%lib/collectd/apache.so
-%%APCUPS%%lib/collectd/apcups.la
-%%APCUPS%%lib/collectd/apcups.so
-lib/collectd/cpu.la
-lib/collectd/cpu.so
-lib/collectd/csv.la
-lib/collectd/csv.so
-lib/collectd/df.la
-lib/collectd/df.so
-lib/collectd/dns.la
-lib/collectd/dns.so
-lib/collectd/email.la
-lib/collectd/email.so
-lib/collectd/exec.la
-lib/collectd/exec.so
-%%INTERFACE%%lib/collectd/interface.la
-%%INTERFACE%%lib/collectd/interface.so
-lib/collectd/load.la
-lib/collectd/load.so
-lib/collectd/logfile.la
-lib/collectd/logfile.so
-%%MBMON%%lib/collectd/mbmon.la
-%%MBMON%%lib/collectd/mbmon.so
-lib/collectd/memory.la
-lib/collectd/memory.so
-%%MYSQL%%lib/collectd/mysql.la
-%%MYSQL%%lib/collectd/mysql.so
-lib/collectd/network.la
-lib/collectd/network.so
-lib/collectd/ntpd.la
-lib/collectd/ntpd.so
-%%PING%%lib/collectd/ping.la
-%%PING%%lib/collectd/ping.so
-%%RRD%%lib/collectd/rrdtool.la
-%%RRD%%lib/collectd/rrdtool.so
-%%SNMP%%lib/collectd/snmp.la
-%%SNMP%%lib/collectd/snmp.so
-lib/collectd/swap.la
-lib/collectd/swap.so
-lib/collectd/syslog.la
-lib/collectd/syslog.so
-lib/collectd/unixsock.la
-lib/collectd/unixsock.so
-%%XMMS%%lib/collectd/xmms.la
-%%XMMS%%lib/collectd/xmms.so
-@dirrm lib/collectd
-@exec mkdir -p /var/db/collectd
-@unexec rmdir /var/db/collectd 2>/dev/null || true