aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/etherape/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/etherape/Makefile')
-rw-r--r--net-mgmt/etherape/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/net-mgmt/etherape/Makefile b/net-mgmt/etherape/Makefile
index ecbc4ace42e8..e8ad67de8e0e 100644
--- a/net-mgmt/etherape/Makefile
+++ b/net-mgmt/etherape/Makefile
@@ -7,7 +7,7 @@
PORTNAME= etherape
PORTVERSION= 0.8.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,15 +16,22 @@ MAINTAINER= petef@FreeBSD.org
LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext
-GNU_CONFIGURE= yes
USE_GNOME= yes
USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN1= etherape.1
CFLAGS+= `${X11BASE}/bin/libglade-config --cflags`
-post-patch:
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
@${PERL} -pi -e 's!^confdir = .*!confdir = ${PREFIX}/share/etherape!' \
${WRKSRC}/Makefile.in