aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/grepip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/grepip/Makefile')
-rw-r--r--net-mgmt/grepip/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-mgmt/grepip/Makefile b/net-mgmt/grepip/Makefile
new file mode 100644
index 000000000000..3bc2b8deafc0
--- /dev/null
+++ b/net-mgmt/grepip/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: grepip
+# Date created: 2 Nov 2005
+# Whom: Serge Maslov <serge@maslov.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= grepip
+PORTVERSION= 1.0
+CATEGORIES= net-mgmt
+MASTER_SITES= ftp://ftp.lexa.ru/pub/domestic/lexa/ \
+ ftp://ftp.des.tstu.ru/pub/mirror/Unix/apache/apache.lexa.ru/pub/domestic/lexa/
+
+MAINTAINER= Serge@Maslov.biz
+COMMENT= Print lines contans IP matching a pattern in CIDR format
+
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+
+PLIST_FILES= bin/grepip %%PORTDOCS%%%%DOCSDIR%%/README.txt
+PLIST_DIRS= %%PORTDOCS%%%%DOCSDIR%%
+
+do-build:
+ cd ${WRKSRC}; \
+ ${CC} ${CFLAGS} -c patricia.c; \
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -o grepip grepip.c patricia.o -L${LOCALBASE}/lib -lpcre
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/grepip ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>