aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icinga/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/icinga/Makefile')
-rw-r--r--net-mgmt/icinga/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/net-mgmt/icinga/Makefile b/net-mgmt/icinga/Makefile
index a0aad834ef7c..706eb4e8b18b 100644
--- a/net-mgmt/icinga/Makefile
+++ b/net-mgmt/icinga/Makefile
@@ -31,8 +31,8 @@ ICINGAWWWDIR?= www/icinga
ICINGAHTMURL?= /icinga
ICINGACGIURL?= ${ICINGAHTMURL}/cgi-bin
-CPPFLAGS+= -I${LOCALBASE}/include -fPIC
-CFLAGS+= ${CPPFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-command-user=${ICINGAUSER} \
--with-command-group=${WWWGRP} \
@@ -53,8 +53,7 @@ CONFIGURE_ARGS= --with-command-user=${ICINGAUSER} \
--enable-event-broker \
--enable-nanosleep
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
- PERL=${PERL} \
+CONFIGURE_ENV= PERL=${PERL} \
HOME=${WRKDIR} # prevent creation of .rnd file
INSTALL_TARGET= install install-config install-eventhandlers install-webconf