aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ifgraph/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/ifgraph/Makefile')
-rw-r--r--net-mgmt/ifgraph/Makefile79
1 files changed, 79 insertions, 0 deletions
diff --git a/net-mgmt/ifgraph/Makefile b/net-mgmt/ifgraph/Makefile
new file mode 100644
index 000000000000..0a4f31ae28f8
--- /dev/null
+++ b/net-mgmt/ifgraph/Makefile
@@ -0,0 +1,79 @@
+# New ports collection makefile for: ifgraph
+# Date created: Sep 18 2003
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ifgraph
+PORTVERSION= 0.4.9
+CATEGORIES= net www
+MASTER_SITES= http://ifgraph.sourceforge.net/stable/
+
+MAINTAINER= lars@thegler.dk
+COMMENT= Simple grapher of SNMP data with RRD
+
+RUN_DEPENDS= rrdtool:${PORTSDIR}/net/rrdtool
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+PKGINSTALL= ${WRKDIR}/pkg-install
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+
+IFGRAPH_USER= ifgraph
+IFGRAPH_GROUP= ifgraph
+
+PLFILES= find-if.pl ifgraph.pl makegraph.pl
+DOCFILES= CHANGELOG INSTALACAO INSTALL TODO LICENSE.TXT MUDANCAS
+
+FILES_SUB= USER=${IFGRAPH_USER} GROUP=${IFGRAPH_GROUP} \
+ PREFIX=${PREFIX} DOCSDIR=${DOCSDIR}
+
+pre-install:
+ @ ${SED} ${FILES_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${PKGDIR}/pkg-install > ${PKGINSTALL}
+ @ ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
+do-install:
+ @ ${SED} ${FILES_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${PKGDIR}/pkg-deinstall > ${PKGDEINSTALL}
+ @ ${SED} ${FILES_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${PKGDIR}/pkg-message > ${PKGMESSAGE}
+.for plfile in ${PLFILES}
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/${plfile} ${PREFIX}/bin
+.endfor
+ @ ${SED} ${FILES_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${WRKSRC}/ifgraph.conf > ${WRKSRC}/ifgraph.conf.sample
+ @ ${INSTALL_DATA} ${WRKSRC}/ifgraph.conf.sample ${PREFIX}/etc
+ @ ${MKDIR} ${PREFIX}/ifgraph
+ @ ${MKDIR} ${PREFIX}/ifgraph/htdocs
+ @ ${CP} -Rp ${WRKSRC}/templates ${PREFIX}/ifgraph
+ @ ${SED} ${FILES_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/crontab.in > ${PREFIX}/ifgraph/crontab.in
+ @ ${CHOWN} -R ifgraph:ifgraph ${PREFIX}/ifgraph
+ @ ${MKDIR} ${PREFIX}/var/ifgraph
+ @ ${CHOWN} ifgraph:ifgraph ${PREFIX}/var/ifgraph
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${DOCSDIR}
+.for docfile in ${DOCFILES}
+ @ ${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
+.endfor
+.endif
+
+post-install:
+ @ ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.if !defined(BATCH)
+ @ ${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+RUN_DEPENDS+= ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net/p5-Net-SNMP3
+.else
+RUN_DEPENDS+= ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net/p5-Net-SNMP
+.endif
+
+.include <bsd.port.post.mk>