aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ipaudit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/ipaudit/Makefile')
-rw-r--r--net-mgmt/ipaudit/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/net-mgmt/ipaudit/Makefile b/net-mgmt/ipaudit/Makefile
index 299095e6f633..5f95d2bf5be4 100644
--- a/net-mgmt/ipaudit/Makefile
+++ b/net-mgmt/ipaudit/Makefile
@@ -5,30 +5,29 @@ PORTNAME= ipaudit
PORTVERSION= 0.95
CATEGORIES= net-mgmt sysutils
MASTER_SITES= http://ipaudit.sourceforge.net/download/
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= IP traffic summarizer
-MANPAGE= ipaudit.1 ipstrings.1 total.1
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
-BIN= ipaudit ipstrings total
-
-MSG_FILE= ${PKGDIR}/pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
+USES= tar:tgz
+SUB_FILES= pkg-message
OPTIONS_DEFINE= DOCS
do-install:
-.for f in ${BIN}
+.for f in ipaudit ipstrings total
${INSTALL_PROGRAM} ${WRKSRC}/src/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
-.for f in ${MANPAGE}
+.for f in ipaudit.1 ipstrings.1 total.1
${INSTALL_MAN} ${WRKSRC}/man/man1/${f} ${STAGEDIR}${PREFIX}/man/man1
.endfor
${INSTALL_DATA} ${WRKSRC}/src/ipaudit.conf.sample ${STAGEDIR}${PREFIX}/etc
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
- @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${MSG_FILE} > ${PKGMESSAGE}
.include <bsd.port.mk>