aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/kismet/files/patch-restricted-plugin-autowep_Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/kismet/files/patch-restricted-plugin-autowep_Makefile')
-rw-r--r--net-mgmt/kismet/files/patch-restricted-plugin-autowep_Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/net-mgmt/kismet/files/patch-restricted-plugin-autowep_Makefile b/net-mgmt/kismet/files/patch-restricted-plugin-autowep_Makefile
new file mode 100644
index 000000000000..acc4b650e7b8
--- /dev/null
+++ b/net-mgmt/kismet/files/patch-restricted-plugin-autowep_Makefile
@@ -0,0 +1,22 @@
+--- restricted-plugin-autowep/Makefile.orig 2016-07-02 18:06:10 UTC
++++ restricted-plugin-autowep/Makefile
+@@ -9,8 +9,8 @@ top_builddir = $(BLDHOME)
+
+ PLUGINLDFLAGS += -shared -rdynamic
+ LIBS += -lstdc++
+-CFLAGS += -I$(KIS_INC_DIR) -g -fPIC
+-CXXFLAGS += -I$(KIS_INC_DIR) -g -fPIC
++CFLAGS += -I$(KIS_INC_DIR) -fPIC
++CXXFLAGS += -I$(KIS_INC_DIR) -fPIC
+
+ PLUGOBJS = autowep-kismet.o
+ PLUGOUT = autowep-kismet.so
+@@ -22,7 +22,7 @@ $(PLUGOUT): $(PLUGOBJS)
+
+ install: $(PLUGOUT)
+ mkdir -p $(DESTDIR)/$(plugindir)
+- $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)/$(plugindir)/$^
++ $(INSTALL) -m 644 $(PLUGOUT) $(DESTDIR)/$(plugindir)/$(PLUGOUT)
+
+ userinstall: $(PLUGOUT)
+ mkdir -p ${HOME}/.kismet/plugins/