aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/libsmi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/libsmi/Makefile')
-rw-r--r--net-mgmt/libsmi/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-mgmt/libsmi/Makefile b/net-mgmt/libsmi/Makefile
index 9adeef4dd8f5..1e141c128dd6 100644
--- a/net-mgmt/libsmi/Makefile
+++ b/net-mgmt/libsmi/Makefile
@@ -6,23 +6,24 @@
#
PORTNAME= libsmi
-PORTVERSION= 0.4.1
-PORTREVISION= 1
+PORTVERSION= 0.4.2
CATEGORIES= net-mgmt
MASTER_SITES= ftp://ftp.ibr.cs.tu-bs.de/pub/local/libsmi/
MAINTAINER= saper@system.pl
COMMENT= A library to access SMI MIB information
-USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
+USE_GNOME= pkgconfig gnomehack
USE_GMAKE= yes
+PIBDIR= ${PREFIX}/share/smi/pibs
MIBDIR= ${PREFIX}/share/smi/mibs
+GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-data-dir=${PREFIX}/share/smi \
- --with-mibdir=${MIBDIR}
+ --with-pibdir=${PIBDIR} --with-mibdir=${MIBDIR}
MAN1= smiquery.1 smilint.1 smidump.1 smistrip.1 smidiff.1 smicache.1
MAN3= libsmi.3 smi_config.3 smi_module.3 smi_macro.3 smi_node.3 smi_type.3 \
- smi_render.3
+ smi_render.3
.include <bsd.port.mk>