aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/mrtg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/mrtg/Makefile')
-rw-r--r--net-mgmt/mrtg/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-mgmt/mrtg/Makefile b/net-mgmt/mrtg/Makefile
index 9129659de996..c0784deb2d99 100644
--- a/net-mgmt/mrtg/Makefile
+++ b/net-mgmt/mrtg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mrtg
PORTVERSION= 2.9.29
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= http://people.ee.ethz.ch/~oetiker/webtools/mrtg/pub/ \
@@ -25,7 +25,7 @@ LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd2
CONFIGURE_ARGS= --with-gd-lib=${LOCALBASE}/lib \
--with-gd-inc=${LOCALBASE}/include
.else
-LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= gd1.2:${PORTSDIR}/graphics/gd
CONFIGURE_ARGS= --with-gd-lib=${LOCALBASE}/lib \
--with-gd-inc=${LOCALBASE}/include/gd
.endif
@@ -43,6 +43,11 @@ MAN1= cfgmaker.1 contrib.1 faq.1 forum.1 indexmaker.1 logfile.1 \
post-patch:
${RM} ${WRKSRC}/lib/mrtg2/BER.pm ${WRKSRC}/lib/mrtg2/SNMP_*.pm
+.if defined(WITH_GD2)
+ ${PERL} -pi -e 's:%%GD%%:-lgd:g' ${WRKSRC}/configure
+.else
+ ${PERL} -pi -e 's:%%GD%%:-lgd1:g' ${WRKSRC}/configure
+.endif
do-install:
${MKDIR} -m 755 ${PREFIX}/etc/mrtg