aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagiosgraph
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/nagiosgraph')
-rw-r--r--net-mgmt/nagiosgraph/Makefile61
-rw-r--r--net-mgmt/nagiosgraph/distinfo3
-rw-r--r--net-mgmt/nagiosgraph/pkg-descr6
-rw-r--r--net-mgmt/nagiosgraph/pkg-plist15
4 files changed, 85 insertions, 0 deletions
diff --git a/net-mgmt/nagiosgraph/Makefile b/net-mgmt/nagiosgraph/Makefile
new file mode 100644
index 000000000000..5123448c672c
--- /dev/null
+++ b/net-mgmt/nagiosgraph/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: nagiosgraph
+# Date created: Wed May 3 17:26:19 MSD 2006
+# Whom: Denis Shaposhnikov <dsh@vlink.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nagiosgraph
+PORTVERSION= 0.8.2
+CATEGORIES= net-mgmt
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= dsh@vlink.ru
+COMMENT= Generate rrdtool's graphs by performance data from nagios plugins
+
+RUN_DEPENDS= ${LOCALBASE}/bin/nagios:${PORTSDIR}/net-mgmt/nagios \
+ ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/net/rrdtool
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+
+PORTDOCS= CHANGELOG INSTALL README README.map
+
+PLIST_SUB= NAGIOSWWWDIR=${NAGIOSWWWDIR}
+
+NAGIOSWWWDIR?= www/nagios
+
+post-patch:
+.for i in insert.pl show.cgi testcolor.cgi testentry.pl
+ ${REINPLACE_CMD} -e 's!/usr/bin/perl!${PERL}!g' -e 's!/usr/local!${PREFIX}!g' -e 's!nagiosgraph\.conf!nagios/nagiosgraph/nagiosgraph.conf!g' ${WRKSRC}/$i
+.endfor
+
+do-install:
+ ${MKDIR} ${PREFIX}/etc/nagios/nagiosgraph
+.for i in map nagiosgraph.conf
+ ${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/etc/nagios/nagiosgraph/${i}.example
+.endfor
+
+ ${MKDIR} ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/insert.pl ${PREFIX}/libexec/${PORTNAME}
+
+ ${MKDIR} ${PREFIX}/${NAGIOSWWWDIR}/cgi-bin/nagiosgraph
+.for i in show.cgi testcolor.cgi
+ ${INSTALL_SCRIPT} ${WRKSRC}/$i ${PREFIX}/${NAGIOSWWWDIR}/cgi-bin/nagiosgraph
+.endfor
+
+ ${MKDIR} ${PREFIX}/${NAGIOSWWWDIR}/stylesheets
+ ${INSTALL_DATA} ${WRKSRC}/nagiosgraph.css ${PREFIX}/${NAGIOSWWWDIR}/stylesheets
+
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/testentry.pl ${EXAMPLESDIR}
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/nagiosgraph/distinfo b/net-mgmt/nagiosgraph/distinfo
new file mode 100644
index 000000000000..4e0d6ca6f784
--- /dev/null
+++ b/net-mgmt/nagiosgraph/distinfo
@@ -0,0 +1,3 @@
+MD5 (nagiosgraph-0.8.2.tar.gz) = 7e756b4e9190fceee89d60e3717786a5
+SHA256 (nagiosgraph-0.8.2.tar.gz) = 238bdb138c1060a4ae568ea7db2e5b65f96237a4d12745b674958e2b6bcb0d86
+SIZE (nagiosgraph-0.8.2.tar.gz) = 12407
diff --git a/net-mgmt/nagiosgraph/pkg-descr b/net-mgmt/nagiosgraph/pkg-descr
new file mode 100644
index 000000000000..357757ecb3c4
--- /dev/null
+++ b/net-mgmt/nagiosgraph/pkg-descr
@@ -0,0 +1,6 @@
+nagiosgraph is an application to collect performance data from nagios
+plugins, insert the data into rrdtool database, and generate webpages
+with rrdtool graphs of the performance data. nagiosgraph is easy to
+configure, and ready to use for many nagios plugins.
+
+WWW: http://nagiosgraph.sourceforge.net/
diff --git a/net-mgmt/nagiosgraph/pkg-plist b/net-mgmt/nagiosgraph/pkg-plist
new file mode 100644
index 000000000000..930a41cdd09a
--- /dev/null
+++ b/net-mgmt/nagiosgraph/pkg-plist
@@ -0,0 +1,15 @@
+etc/nagios/nagiosgraph/map.example
+etc/nagios/nagiosgraph/nagiosgraph.conf.example
+libexec/nagiosgraph/insert.pl
+%%EXAMPLESDIR%%/testentry.pl
+%%NAGIOSWWWDIR%%/cgi-bin/nagiosgraph/show.cgi
+%%NAGIOSWWWDIR%%/cgi-bin/nagiosgraph/testcolor.cgi
+%%NAGIOSWWWDIR%%/stylesheets/nagiosgraph.css
+@dirrm etc/nagios/nagiosgraph
+@dirrmtry etc/nagios
+@dirrm libexec/nagiosgraph
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%NAGIOSWWWDIR%%/cgi-bin/nagiosgraph
+@dirrmtry %%NAGIOSWWWDIR%%/cgi-bin
+@dirrmtry %%NAGIOSWWWDIR%%/stylesheets
+@dirrmtry %%NAGIOSWWWDIR%%