aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/netleak/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/netleak/Makefile')
-rw-r--r--net-mgmt/netleak/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-mgmt/netleak/Makefile b/net-mgmt/netleak/Makefile
new file mode 100644
index 000000000000..7c853ffcfff8
--- /dev/null
+++ b/net-mgmt/netleak/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: netleak
+# Date created: 1 Nov 2005
+# Whom: Vaida Bogdan
+#
+# $FreeBSD$
+#
+
+PORTNAME= netleak
+PORTVERSION= 0.1a
+CATEGORIES= net-mgmt
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= vaida.bogdan@gmail.com
+COMMENT= Tool to detect connectivity between network segments
+
+RUN_DEPENDS= ${SITE_PERL}/Net/PcapUtils.pm:${PORTSDIR}/net/p5-Net-PcapUtils \
+ ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
+ ${SITE_PERL}/NetPacket/Ethernet.pm:${PORTSDIR}/net/p5-NetPacket \
+ ${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail \
+ ${SITE_PERL}/${PERL_ARCH}/Net/RawIP.pm:${PORTSDIR}/net/p5-Net-RawIP \
+ ${SITE_PERL}/${PERL_ARCH}/IO/Interface.pm:${PORTSDIR}/net/p5-IO-Interface \
+ ${SITE_PERL}/NetAddr/IP.pm:${PORTSDIR}/net-mgmt/p5-NetAddr-IP
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_PERL5_RUN= yes
+MAN8= netleak.8 netleakd.8
+
+PORTDOCS= BUGS README TODO
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>