aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nfsen-devel
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/nfsen-devel')
-rw-r--r--net-mgmt/nfsen-devel/Makefile66
-rw-r--r--net-mgmt/nfsen-devel/distinfo3
-rw-r--r--net-mgmt/nfsen-devel/files/nfsen.sh.in86
-rw-r--r--net-mgmt/nfsen-devel/files/patch-etc_nfsen-dist.conf84
-rw-r--r--net-mgmt/nfsen-devel/files/patch-html_navigator.php14
-rw-r--r--net-mgmt/nfsen-devel/files/patch-install.pl46
-rw-r--r--net-mgmt/nfsen-devel/pkg-descr12
-rw-r--r--net-mgmt/nfsen-devel/pkg-plist96
8 files changed, 0 insertions, 407 deletions
diff --git a/net-mgmt/nfsen-devel/Makefile b/net-mgmt/nfsen-devel/Makefile
deleted file mode 100644
index 2e7c680bc62e..000000000000
--- a/net-mgmt/nfsen-devel/Makefile
+++ /dev/null
@@ -1,66 +0,0 @@
-# New ports collection makefile for: nfsen
-# Date created: 25 March 2005
-# Whom: janos.mohacsi@bsd.hu
-#
-# $FreeBSD$
-#
-
-PORTNAME= nfsen
-PORTVERSION= 1.2.4.20060810
-CATEGORIES= net-mgmt
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://nfsen.sourceforge.net/
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-snapshot-20060810
-
-MAINTAINER= janos.mohacsi@bsd.hu
-COMMENT= Web based frontend to nfdump netflow collector
-
-RUN_DEPENDS= ${SITE_PERL}/RRDp.pm:${PORTSDIR}/net/rrdtool \
- nfdump:${PORTSDIR}/net-mgmt/nfdump
-
-USE_ICONV= yes
-USE_PERL5= yes
-USE_PHP= session pcre sockets
-NO_BUILD= yes
-PLIST_SUB+= PORTNAME=${PORTNAME}
-USE_RC_SUBR= nfsen.sh
-
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least perl 5.6.0
-.endif
-
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "*****************************************************"
- @${ECHO_MSG} "Before upgrading you may backup the original profile "
- @${ECHO_MSG} "stat data:"
- @${ECHO_MSG} "cd ${WRKSRC}/helpers"
- @${ECHO_MSG} "./mk_backup.sh /path/to/your/profilestatdir /path/to/backupdir"
- @${ECHO_MSG} "*****************************************************"
- @${ECHO_MSG} ""
-
-post-patch:
- @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' -e 's,%%PORTNAME%%,${PORTNAME},' \
- ${WRKSRC}/etc/nfsen-dist.conf
- @${RM} ${WRKSRC}/etc/nfsen-dist.conf.*
- @${REINPLACE_CMD} -e 's,%%PERL%%,${PERL},' -e 's,%%PREFIX%%,${PREFIX},' ${WRKSRC}/install.pl
-
-do-install:
- @${MKDIR} ${PREFIX}/var/${PORTNAME}/profiles/live
- @${MKDIR} ${PREFIX}/libexec/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/installer-items/CopyRecursive.pm ${PREFIX}/libexec/${PORTNAME}/
- ${INSTALL_DATA} ${WRKSRC}/installer-items/RRDconvertv1.pm ${PREFIX}/libexec/${PORTNAME}/
- @ if [ -f ${PREFIX}/etc/nfsen.conf ] ; then \
- ${ECHO_MSG} "installing with existing nfsen.conf"; \
- cd ${WRKSRC} ;${PERL} ${WRKSRC}/install.pl ${PREFIX}/etc/nfsen.conf; \
- else \
- ${ECHO_MSG} "installing with sample nfsen.conf"; \
- cd ${WRKSRC} ;${PERL} ${WRKSRC}/install.pl ${WRKSRC}/etc/nfsen-dist.conf; \
- fi
- @${ECHO_MSG} "Configure your ${LOCALBASE}/etc/nfsen.conf to have necessary sources ";
- @${ECHO_MSG} "Then run 'nfsen -R ${LOCALBASE}/etc/nfsen.conf' to correctly setup source, RRD, and profile files";
-
-.include <bsd.port.post.mk>
diff --git a/net-mgmt/nfsen-devel/distinfo b/net-mgmt/nfsen-devel/distinfo
deleted file mode 100644
index d34da0a50fc1..000000000000
--- a/net-mgmt/nfsen-devel/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (nfsen-snapshot-20060810.tar.gz) = 4274e60f8a007e4a01923e975a18ef65
-SHA256 (nfsen-snapshot-20060810.tar.gz) = 11c73c5207ea608a2a1d50d84cddeee6ecbd59e048d0622b322e07100e8af50d
-SIZE (nfsen-snapshot-20060810.tar.gz) = 3362157
diff --git a/net-mgmt/nfsen-devel/files/nfsen.sh.in b/net-mgmt/nfsen-devel/files/nfsen.sh.in
deleted file mode 100644
index 83ecfc335215..000000000000
--- a/net-mgmt/nfsen-devel/files/nfsen.sh.in
+++ /dev/null
@@ -1,86 +0,0 @@
-#! /bin/sh
-#
-
-PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
-DAEMON=%%PREFIX%%/bin/nfsen.rc
-NAME=nfsen
-
-test -x $DAEMON || exit 0
-
-set -e
-
-case "$1" in
- start)
- echo -n "Starting $NAME"
- $DAEMON start
- echo "."
- ;;
- stop)
- echo -n "Stopping $NAME "
- $DAEMON stop
- echo "."
- ;;
- restart|force-reload)
- #
- # If the "reload" option is implemented, move the "force-reload"
- # option to the "reload" entry above. If not, "force-reload" is
- # just the same as "restart".
- #
- echo -n "Restarting $NAME"
- $DAEMON stop
- sleep 1
- $DAEMON start
- echo "."
- ;;
- *)
- N=/tmp/nfsen-1.2.4.20060325/etc/rc.d/${NAME}.sh
- # echo "Usage: $N {start|stop|restart|reload|force-reload}" >&2
- echo "Usage: $N {start|stop|restart|force-reload}" >&2
- exit 1
- ;;
-esac
-
-exit 0
-#! /bin/sh
-#
-
-PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
-DAEMON=/usr/local/bin/nfsen.rc
-NAME=nfsen
-
-test -x $DAEMON || exit 0
-
-set -e
-
-case "$1" in
- start)
- echo -n "Starting $NAME"
- $DAEMON start
- echo "."
- ;;
- stop)
- echo -n "Stopping $NAME "
- $DAEMON stop
- echo "."
- ;;
- restart|force-reload)
- #
- # If the "reload" option is implemented, move the "force-reload"
- # option to the "reload" entry above. If not, "force-reload" is
- # just the same as "restart".
- #
- echo -n "Restarting $NAME"
- $DAEMON stop
- sleep 1
- $DAEMON start
- echo "."
- ;;
- *)
- N=/tmp/nfsen-1.2.4.20060325/etc/rc.d/${NAME}.sh
- # echo "Usage: $N {start|stop|restart|reload|force-reload}" >&2
- echo "Usage: $N {start|stop|restart|force-reload}" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/net-mgmt/nfsen-devel/files/patch-etc_nfsen-dist.conf b/net-mgmt/nfsen-devel/files/patch-etc_nfsen-dist.conf
deleted file mode 100644
index 0d260cabe3a4..000000000000
--- a/net-mgmt/nfsen-devel/files/patch-etc_nfsen-dist.conf
+++ /dev/null
@@ -1,84 +0,0 @@
-
-$FreeBSD$
-
---- etc/nfsen-dist.conf.orig
-+++ etc/nfsen-dist.conf
-@@ -26,7 +26,7 @@
-
- #
- # Required for default layout
--$BASEDIR = "/data/nfsen";
-+$BASEDIR = "%%PREFIX%%";
-
- #
- # Where to install the NfSen binaries
-@@ -34,7 +34,7 @@
-
- #
- # Where to install the NfSen Perl modules
--$LIBEXECDIR="${BASEDIR}/libexec";
-+$LIBEXECDIR="${BASEDIR}/libexec/%%PORTNAME%%";
-
- #
- # Where to install the config files
-@@ -44,7 +44,7 @@
- # NfSen html pages directory:
- # All php scripts will be installed here.
- # URL: Entry point for nfsen: http://<webserver>/nfsen/nfsen.php
--$HTMLDIR = "/var/www/nfsen/";
-+$HTMLDIR = "%%PREFIX%%/www/%%PORTNAME%%/";
-
- #
- # Where to install the docs
-@@ -52,20 +52,20 @@
-
- #
- # Var space for NfSen
--$VARDIR="${BASEDIR}/var";
-+$VARDIR="${BASEDIR}/var/%%PORTNAME%%";
-
- #
- # The Profiles stat directory, where all profile information
- # RRD DBs and gif pictures of the profile are stored
--$PROFILESTATDIR="${BASEDIR}/profiles";
-+$PROFILESTATDIR="${VARDIR}/profiles";
-
- #
- # The Profiles directory, where all netflow data is stored
--$PROFILEDATADIR="${BASEDIR}/profiles";
-+$PROFILEDATADIR="${VARDIR}/profiles";
-
- #
- # Where go all the backend plugins
--$BACKEND_PLUGINDIR="${BASEDIR}/plugins";
-+$BACKEND_PLUGINDIR="${LIBEXECDIR}/plugins";
-
- #
- # Where go all the frontend plugins
-@@ -73,7 +73,7 @@
-
- #
- # nfdump tools path
--$PREFIX = '/usr/local/bin';
-+$PREFIX = '%%PREFIX%%/bin';
-
- #
- # BASEDIR unrelated vars:
-@@ -82,7 +82,7 @@
- # This may be a different or the same uid than your web server.
- # Note: This user must be in group $WWWGROUP, otherwise nfcapd
- # is not able to write data files!
--$USER = "netflow";
-+$USER = "www";
-
- # user and group of the web server process
- # All netflow processing will be done with this user
-@@ -106,7 +106,7 @@
-
- %sources = (
- 'upstream1' => { 'port' => '9995', 'col' => '#0000ff', 'type' => 'netflow' },
-- 'peer1' => { 'port' => '9996', 'col' => '#ff0000' },
-+# 'peer1' => { 'port' => '9996', 'col' => '#ff0000' },
- );
-
- #
diff --git a/net-mgmt/nfsen-devel/files/patch-html_navigator.php b/net-mgmt/nfsen-devel/files/patch-html_navigator.php
deleted file mode 100644
index 9249f8afc3d2..000000000000
--- a/net-mgmt/nfsen-devel/files/patch-html_navigator.php
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- html/navigator.php.orig
-+++ html/navigator.php
-@@ -18,7 +18,7 @@
- * Copy the doc directory into HTML dir
- */
-
-- // print "<a href='$DOCURL/NfSen.html' target='_blank' >Docu</a>\n";
-+ print "<a href='$DOCURL/NfSen.html' target='_blank' >Docu</a>\n";
-
- print "<a href='$self?bookmark=" . $_SESSION['bookmark'] . "'>Bookmark URL</a>\n";
- print "Selected Profile:&nbsp;\n";
diff --git a/net-mgmt/nfsen-devel/files/patch-install.pl b/net-mgmt/nfsen-devel/files/patch-install.pl
deleted file mode 100644
index 4b4113a85cc1..000000000000
--- a/net-mgmt/nfsen-devel/files/patch-install.pl
+++ /dev/null
@@ -1,46 +0,0 @@
-
-$FreeBSD$
-
---- install.pl.orig
-+++ install.pl
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!%%PERL%% -I %%PREFIX%%/libexec/nfsen
- #
- #
- # Copyright (c) 2004, SWITCH - Teleinformatikdienste fuer Lehre und Forschung
-@@ -81,33 +81,7 @@
- # Get Perl
- sub GetPerl {
-
-- my $whichperl;
-- my $ans;
-- $whichperl = FindCommand("perl");
-- if ( defined $whichperl ) {
-- print "Perl to use: [$whichperl] ";
-- chomp($ans = <STDIN>);
-- if ( length $ans ) {
-- $whichperl = $ans;
-- }
-- } else {
-- print "No Perl found in your PATH. Please specify where to find perl [] ";
-- chomp($whichperl = <STDIN>);
-- }
--
-- while (1) {
-- if ( -x $whichperl ) {
-- my $err = system("$whichperl -e 'require 5.6.0;'") >> 8;
-- last if $err == 0;
-- print "Found errors while testing Perl\n";
-- } else {
-- print "No executable: '$whichperl'\n";
-- }
-- print "Perl to use: [] ";
-- chomp($whichperl = <STDIN>);
-- }
--
-- return $whichperl;
-+ return "%%PERL%%";
-
- } # End of GetPerl
-
diff --git a/net-mgmt/nfsen-devel/pkg-descr b/net-mgmt/nfsen-devel/pkg-descr
deleted file mode 100644
index 312491947d5d..000000000000
--- a/net-mgmt/nfsen-devel/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-NfSen is a graphical web based front end for the nfdump netflow tools.
-
-NfSen allows you to:
-
- * Display your netflow data: Flows, Packets and Bytes using RRD
- (Round Robin Database).
- * Easily navigate through the netflow data.
- * Process the netflow data within the specified time span.
- * Create history as well as continuous profiles.
- * Write your own plugins to process netflow data on a regular interval
-
-WWW: http://nfsen.sourceforge.net/
diff --git a/net-mgmt/nfsen-devel/pkg-plist b/net-mgmt/nfsen-devel/pkg-plist
deleted file mode 100644
index f57b7798bf94..000000000000
--- a/net-mgmt/nfsen-devel/pkg-plist
+++ /dev/null
@@ -1,96 +0,0 @@
-bin/nfsen
-bin/nfsen.rc
-bin/nfsend
-bin/RebuildHierarchy.pl
-bin/testPlugin
-@unexec if cmp -s %D/etc/nfsen.conf %D/etc/nfsen-dist.conf; then rm -f %D/etc/nfsen.conf; fi
-@exec [ -f %D/etc/nfsen.conf ] || cp %D/etc/nfsen-dist.conf %D/etc/nfsen.conf
-etc/nfsen-dist.conf
-libexec/%%PORTNAME%%/CopyRecursive.pm
-libexec/%%PORTNAME%%/GenGraph.pl
-libexec/%%PORTNAME%%/Log.pm
-libexec/%%PORTNAME%%/NfConf.pm
-libexec/%%PORTNAME%%/NfProfile.pm
-libexec/%%PORTNAME%%/NfSen.pm
-libexec/%%PORTNAME%%/NfSenRC.pm
-libexec/%%PORTNAME%%/NfSenRRD.pm
-libexec/%%PORTNAME%%/Nfcomm.pm
-libexec/%%PORTNAME%%/Nfsources.pm
-libexec/%%PORTNAME%%/Notification.pm
-libexec/%%PORTNAME%%/RRDconvertv1.pm
-libexec/%%PORTNAME%%/plugins/demoplugin.pm
-www/%%PORTNAME%%/conf.php
-www/%%PORTNAME%%/EmptyGraph.gif
-www/%%PORTNAME%%/ErrorGraph.gif
-www/%%PORTNAME%%/css-admin.html
-www/%%PORTNAME%%/css.html
-www/%%PORTNAME%%/details.php
-www/%%PORTNAME%%/edit.png
-www/%%PORTNAME%%/info.php
-www/%%PORTNAME%%/invisible.gif
-www/%%PORTNAME%%/navigator.php
-www/%%PORTNAME%%/navigator.php.orig
-www/%%PORTNAME%%/nfsen.php
-www/%%PORTNAME%%/nfsenutil.php
-www/%%PORTNAME%%/overview.php
-www/%%PORTNAME%%/pic.php
-www/%%PORTNAME%%/process.php
-www/%%PORTNAME%%/profileadmin.php
-www/%%PORTNAME%%/rrdgraph.php
-www/%%PORTNAME%%/trash.png
-www/%%PORTNAME%%/plugins/demoplugin.php
-www/%%PORTNAME%%/doc/BSD-license.html
-www/%%PORTNAME%%/doc/Bookmark.png
-www/%%PORTNAME%%/doc/BuildingProfile.png
-www/%%PORTNAME%%/doc/ConfirmDelete.png
-www/%%PORTNAME%%/doc/DefaultFilter.png
-www/%%PORTNAME%%/doc/DeleteProfile.png
-www/%%PORTNAME%%/doc/DisabledSources.png
-www/%%PORTNAME%%/doc/InputEnd.png
-www/%%PORTNAME%%/doc/Navigating.png
-www/%%PORTNAME%%/doc/NewProfile.png
-www/%%PORTNAME%%/doc/OutOfData.png
-www/%%PORTNAME%%/doc/ProcessingControls.png
-www/%%PORTNAME%%/doc/ProcessingOutput.png
-www/%%PORTNAME%%/doc/ProfileCreated.png
-www/%%PORTNAME%%/doc/ResetWindow.png
-www/%%PORTNAME%%/doc/SelectLeft.png
-www/%%PORTNAME%%/doc/SelectRight.png
-www/%%PORTNAME%%/doc/StatSummary.png
-www/%%PORTNAME%%/doc/TimeWindow.png
-www/%%PORTNAME%%/doc/WinScale.png
-www/%%PORTNAME%%/doc/bytes.png
-www/%%PORTNAME%%/doc/cursor_control.png
-www/%%PORTNAME%%/doc/details-graphs.png
-www/%%PORTNAME%%/doc/details-processing.png
-www/%%PORTNAME%%/doc/dirstruct.png
-www/%%PORTNAME%%/doc/edit.png
-www/%%PORTNAME%%/doc/exiisting.png
-www/%%PORTNAME%%/doc/flows.png
-www/%%PORTNAME%%/doc/index.html
-www/%%PORTNAME%%/doc/linegraph.png
-www/%%PORTNAME%%/doc/nfsen-options.png
-www/%%PORTNAME%%/doc/overview.png
-www/%%PORTNAME%%/doc/packets.png
-www/%%PORTNAME%%/doc/plugins.png
-www/%%PORTNAME%%/doc/processing-1.png
-www/%%PORTNAME%%/doc/selectprofile.png
-www/%%PORTNAME%%/doc/stat.png
-www/%%PORTNAME%%/doc/views-2.png
-www/%%PORTNAME%%/doc/views.png
-@dirrm www/%%PORTNAME%%/plugins
-@dirrm www/%%PORTNAME%%/doc
-@dirrm www/%%PORTNAME%%
-@exec mkdir -p %D/var/%%PORTNAME%%/profiles/live/upstream1
-var/%%PORTNAME%%/profiles/live/upstream1.rrd
-var/%%PORTNAME%%/profiles/live/profile.dat
-@exec mkdir -p %D/var/%%PORTNAME%%/run
-@exec mkdir -p %D/var/%%PORTNAME%%/filters
-@dirrm var/%%PORTNAME%%/run
-@dirrm var/%%PORTNAME%%/filters
-@dirrmtry var/%%PORTNAME%%/profiles/live/upstream1
-@dirrmtry var/%%PORTNAME%%/profiles/live
-@dirrmtry var/%%PORTNAME%%/profiles
-@dirrmtry var/%%PORTNAME%%
-@dirrm libexec/%%PORTNAME%%/plugins
-@dirrm libexec/%%PORTNAME%%