aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/observium
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/observium')
-rw-r--r--net-mgmt/observium/Makefile16
-rw-r--r--net-mgmt/observium/files/patch-poller-wrapper.py6
2 files changed, 8 insertions, 14 deletions
diff --git a/net-mgmt/observium/Makefile b/net-mgmt/observium/Makefile
index 8b90f39015a9..b04d1de85bd8 100644
--- a/net-mgmt/observium/Makefile
+++ b/net-mgmt/observium/Makefile
@@ -3,7 +3,7 @@
PORTNAME= observium
PORTVERSION= 0.16.10.8128
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://www.observium.org/
DISTNAME= ${PORTNAME}-community-latest
@@ -16,7 +16,7 @@ LICENSE= GPLv3
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= python shebangfix
+USES= php:cli python shebangfix
SHEBANG_FILES= mibs/process.pl \
scripts/agent-local/areca-hw \
scripts/agent-local/asterisk \
@@ -51,10 +51,10 @@ SHEBANG_FILES= mibs/process.pl \
scripts/removespikes.php \
scripts/removespikes.pl \
scripts/rename-mibs.pl \
- scripts/rrdtoolx.py
+ scripts/rrdtoolx.py \
+ poller-wrapper.py
USE_PHP= ctype filter gd iconv json mcrypt mysql mysqli posix session snmp tokenizer xml zlib
-WANT_PHP_CLI= yes
IGNORE_WITH_PHP= 70
NO_BUILD= yes
@@ -102,17 +102,17 @@ PORTDOCS= INSTALL README
PORTEXAMPLES= snmp.conf.example snmpd.conf.example
.if ${PORT_OPTIONS:MAPACHEMOD} && !defined(PACKAGE_BUILDING)
-WANT_PHP_MOD= yes
+USES+= php:mod
USE_APACHE_RUN= 22+
.else
# Package builder doesn't create php5 with module
-WANT_PHP_WEB= yes
+USES+= php:web
.endif
.if ${PORT_OPTIONS:MMYSQLD}
-USE_MYSQL= server
+USES+= mysql:server
.else
-USE_MYSQL= client
+USES+= mysql:client
.endif
post-patch:
diff --git a/net-mgmt/observium/files/patch-poller-wrapper.py b/net-mgmt/observium/files/patch-poller-wrapper.py
index 7b49f68255de..ba11a1203e8e 100644
--- a/net-mgmt/observium/files/patch-poller-wrapper.py
+++ b/net-mgmt/observium/files/patch-poller-wrapper.py
@@ -1,11 +1,5 @@
--- poller-wrapper.py.orig 2014-11-04 16:14:27 UTC
+++ poller-wrapper.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#! %%LOCALBASE%%/bin/python
- """
- poller-wrapper A small tool which wraps around the Observium poller
- and tries to guide the polling process with a more modern
@@ -38,6 +38,8 @@ except:
print "threading, Queue, sys, subprocess, time, os, json"
sys.exit(2)