aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ocsinventory-ng/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/ocsinventory-ng/Makefile')
-rw-r--r--net-mgmt/ocsinventory-ng/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-mgmt/ocsinventory-ng/Makefile b/net-mgmt/ocsinventory-ng/Makefile
index 4d8e2ee16073..37f6a1530d56 100644
--- a/net-mgmt/ocsinventory-ng/Makefile
+++ b/net-mgmt/ocsinventory-ng/Makefile
@@ -6,7 +6,7 @@
PORTNAME= ocsinventory-ng
PORTVERSION= 1.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= http://launchpad.net/ocsinventory-server/stable-${PORTVERSION:R}/${PORTVERSION}/+download/
DISTNAME= OCSNG_UNIX_SERVER-${PORTVERSION}
@@ -15,7 +15,6 @@ MAINTAINER= araujo@FreeBSD.org
COMMENT= Open Computer and Software Inventory Next Generation
RUN_DEPENDS= ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
- ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql \
${SITE_PERL}/Net/IP.pm:${PORTSDIR}/net-mgmt/p5-Net-IP \
@@ -32,6 +31,12 @@ USE_PHP= mysql pcre zlib session xml gd zip
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
do-install:
@${MKDIR} ${DATADIR}
@(cd ${WRKSRC}/ && ${COPYTREE_SHARE} "Apache binutils dtd etc ocsreports" ${DATADIR}/)
@@ -41,4 +46,4 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>