aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/p5-GRNOC-Config
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/p5-GRNOC-Config')
-rw-r--r--net-mgmt/p5-GRNOC-Config/Makefile28
-rw-r--r--net-mgmt/p5-GRNOC-Config/distinfo2
-rw-r--r--net-mgmt/p5-GRNOC-Config/pkg-descr5
3 files changed, 35 insertions, 0 deletions
diff --git a/net-mgmt/p5-GRNOC-Config/Makefile b/net-mgmt/p5-GRNOC-Config/Makefile
new file mode 100644
index 000000000000..4b306521f2e1
--- /dev/null
+++ b/net-mgmt/p5-GRNOC-Config/Makefile
@@ -0,0 +1,28 @@
+# Created by: Muhammad Moinur Rahman <5u623l20@gmail.com>
+# $FreeBSD$
+
+PORTNAME= GRNOC-Config
+PORTVERSION= 1.0.9
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= SF/routerproxy/${PORTNAME}
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= 5u623l20@gmail.com
+COMMENT= Module to allow everyone to access config files
+
+BUILD_DEPENDS= p5-XML-LibXML>=2:${PORTSDIR}/textproc/p5-XML-LibXML \
+ p5-XML-XPath>=1:${PORTSDIR}/textproc/p5-XML-XPath \
+ p5-XML-Simple>=2:${PORTSDIR}/textproc/p5-XML-Simple
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_PERL5= configure
+USES= perl5
+
+MAN3= GRNOC::Config.3
+PLIST_FILES= %%SITE_PERL%%/GRNOC/Config.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/GRNOC/Config/.packlist
+PLIST_DIRSTRY= %%SITE_PERL%%/%%PERL_ARCH%%/auto/GRNOC/Config \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/GRNOC \
+ %%SITE_PERL%%/GRNOC
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/p5-GRNOC-Config/distinfo b/net-mgmt/p5-GRNOC-Config/distinfo
new file mode 100644
index 000000000000..d68a3a4c920f
--- /dev/null
+++ b/net-mgmt/p5-GRNOC-Config/distinfo
@@ -0,0 +1,2 @@
+SHA256 (GRNOC-Config-1.0.9.tar.gz) = b49942acc317d578b81208f615a27f84abc29fe6da0b1e63b6220d1c6642b927
+SIZE (GRNOC-Config-1.0.9.tar.gz) = 7746
diff --git a/net-mgmt/p5-GRNOC-Config/pkg-descr b/net-mgmt/p5-GRNOC-Config/pkg-descr
new file mode 100644
index 000000000000..2638b960f6c8
--- /dev/null
+++ b/net-mgmt/p5-GRNOC-Config/pkg-descr
@@ -0,0 +1,5 @@
+A module to allow everyone to access config files in a fairly standard
+way. Uses XML::XPath and XML::Simple to parse our XML files, and
+stores all configs it has access to in this module.
+
+WWW: http://www.sourceforge.net/projects/routerproxy