aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/pdagent-integrations/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/pdagent-integrations/Makefile')
-rw-r--r--net-mgmt/pdagent-integrations/Makefile24
1 files changed, 15 insertions, 9 deletions
diff --git a/net-mgmt/pdagent-integrations/Makefile b/net-mgmt/pdagent-integrations/Makefile
index 8a6570eb5035..077e0077d5d8 100644
--- a/net-mgmt/pdagent-integrations/Makefile
+++ b/net-mgmt/pdagent-integrations/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pdagent-integrations
-PORTVERSION= 1.4
+PORTVERSION= 1.5
DISTVERSIONPREFIX=v
CATEGORIES= net-mgmt python
@@ -10,10 +10,11 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= PagerDuty integrations for monitoring monitoring tools
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pdagent>0:net-mgmt/py-pdagent@${PY_FLAVOR}
-USES= python:2.7 shebangfix
+USES= python:2.7 shebangfix
USE_GITHUB= yes
GH_ACCOUNT= PagerDuty
@@ -24,19 +25,24 @@ SUB_FILES= pagerduty-icinga2.conf pkg-message
NO_ARCH= yes
NO_BUILD= yes
+PORTDOCS= *-testing.txt
+EXAMPLES= conf.d/sensu_pagerduty_handler.json \
+ pagerduty_nagios.cfg
-OPTIONS_DEFINE= EXAMPLES
+OPTIONS_DEFINE= DOCS EXAMPLES
post-patch:
${REINPLACE_CMD} 's|/usr/share/pdagent-integrations/bin|${PREFIX}/bin|g' ${WRKSRC}/pagerduty_nagios.cfg ${WRKSRC}/conf.d/sensu_pagerduty_handler.json
do-install:
+ (cd ${WRKSRC}/bin ; ${INSTALL_SCRIPT} * ${STAGEDIR}${PREFIX}/bin)
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+do-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/pd-nagios ${STAGEDIR}${LOCALBASE}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/pd-sensu ${STAGEDIR}${LOCALBASE}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/pd-zabbix ${STAGEDIR}${LOCALBASE}/bin
- ${INSTALL_DATA} ${WRKSRC}/conf.d/sensu_pagerduty_handler.json ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/pagerduty_nagios.cfg ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKDIR}/pagerduty-icinga2.conf ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>