aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/py-snmp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/py-snmp/Makefile')
-rw-r--r--net-mgmt/py-snmp/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/net-mgmt/py-snmp/Makefile b/net-mgmt/py-snmp/Makefile
index 1232575f80bf..69c168d3b4fe 100644
--- a/net-mgmt/py-snmp/Makefile
+++ b/net-mgmt/py-snmp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= snmp
-PORTVERSION= 2.0.1
+PORTVERSION= 2.0.3
CATEGORIES= net python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pysnmp
@@ -16,10 +16,15 @@ DISTNAME= pysnmp-${PORTVERSION}
MAINTAINER= perky@fallin.lv
USE_PYTHON= yes
+USE_REINPLACE= yes
USE_PYDISTUTILS=yes
EXAMPLESDIR= ${PREFIX}/share/examples/py-snmp
DOCSDIR= ${PREFIX}/share/doc/py-snmp
+post-patch:
+ @${REINPLACE_CMD} -E -e 's|^(#!/usr/bin/env[ ]+)python|\1${PYTHON_CMD}|' \
+ ${WRKSRC}/setup.py
+
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${EXAMPLESDIR}