aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/rackmonkey/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/rackmonkey/Makefile')
-rw-r--r--net-mgmt/rackmonkey/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-mgmt/rackmonkey/Makefile b/net-mgmt/rackmonkey/Makefile
index 637bbac05db2..a155275a1e89 100644
--- a/net-mgmt/rackmonkey/Makefile
+++ b/net-mgmt/rackmonkey/Makefile
@@ -34,7 +34,7 @@ SUB_FILES= pkg-message
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= yes
+USES+= sqlite
RUN_DEPENDS+= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
.endif
.if ${PORT_OPTIONS:MMYSQL}
@@ -65,7 +65,7 @@ do-install:
cd ${WRKSRC}/perl && ${COPYTREE_SHARE} RackMonkey ${STAGEDIR}${WWWDIR}/
${MKDIR} ${WRKDIR}/build_conf; \
${CP} ${WRKSRC}/conf/rackmonkey.conf-default ${WRKDIR}/build_conf/rackmonkey.conf; \
- if [ "${USE_SQLITE}" ]; then \
+ if [ "${USES:MSQLITE}" ]; then \
${ECHO} "Building with SQLite............."; \
${SED} -i '' -e 's%dbconnect =%dbconnect = dbi:SQLite:dbname=${WWWDIR}/rackmonkey.db%' ${WRKDIR}/build_conf/rackmonkey.conf; \
if [ "${INIT_DB}" ]; then \